X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

Why is the number 9 replaced with a dash?

Δημοσιεύτηκε

The number 9 is replaced with a dash (-) in documents I open through my work website. This just started happening recently and has never happened before. Oddly, though, the 9s reappear when I download the documents and open them as pdfs. See the attached screenshot for a better idea of what's happening.

The number 9 is replaced with a dash (-) in documents I open through my work website. This just started happening recently and has never happened before. Oddly, though, the 9s reappear when I download the documents and open them as pdfs. See the attached screenshot for a better idea of what's happening.
Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

Hi JeffC, could you review your default fonts and change them to TrueType fonts for testing? Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:

Ανάγνωση απάντησης σε πλαίσιο 1
Παράθεση

Επιπρόσθετες λεπτομέρειες συστήματος

Εγκατεστημένα αρθρώματα

  • Shockwave Flash 32.0 r0

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:69.0) Gecko/20100101 Firefox/69.0

Περισσότερες πληροφορίες

McCoy
  • Top 10 Contributor
546 λύσεις 5143 απαντήσεις
Δημοσιεύτηκε

Hello JeffC,

Would you please take a look at this thread :

https://support.mozilla.org/en-US/questions/1268528

Maybe the Helvetica font may be the culprit in your case as well (?)

If not : you could try some of the other suggestions there ....

Hello JeffC, Would you please take a look at this thread : https://support.mozilla.org/en-US/questions/1268528 Maybe the Helvetica font may be the culprit in your case as well (?) If not : you could try some of the other suggestions there ....
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Χρήσιμη απάντηση

Thanks for the thread, but I already read through it and have no idea what I'm doing wrt "inspect element" or font book, etc. I tried the inspect element idea and don't know how to interpret the information. I'm not a developer, just a lay end user of Firefox. I did see listed in the font box on the far right "Courier", so, Helvetica doesn't appear to be the culprit.

On another note, I now notice the letters "Y" and "Z" missing on certain pages. Inspect element shows Times Roman. Again, no Helvetica.

Thanks for any ideas a simpleton like me can implement. Otherwise, I'm at a loss with the technical stuff.

Thanks for the thread, but I already read through it and have no idea what I'm doing wrt "inspect element" or font book, etc. I tried the inspect element idea and don't know how to interpret the information. I'm not a developer, just a lay end user of Firefox. I did see listed in the font box on the far right "Courier", so, Helvetica doesn't appear to be the culprit. On another note, I now notice the letters "Y" and "Z" missing on certain pages. Inspect element shows Times Roman. Again, no Helvetica. Thanks for any ideas a simpleton like me can implement. Otherwise, I'm at a loss with the technical stuff.
Σάς φάνηκε χρήσιμο; 1
Παράθεση
McCoy
  • Top 10 Contributor
546 λύσεις 5143 απαντήσεις
Δημοσιεύτηκε

There's another thread here :

https://support.mozilla.org/en-US/questions/1268572

(and there are more)

As nobody here has been able to come up with a solution; would you consider filing a bug report ?

https://bugzilla.mozilla.org/enter_bug.cgi

https://developer.mozilla.org/docs/Mozilla/QA/Bug_writing_guidelines

There's another thread here : https://support.mozilla.org/en-US/questions/1268572 (and there are more) As nobody here has been able to come up with a solution; would you consider filing a bug report ? https://bugzilla.mozilla.org/enter_bug.cgi https://developer.mozilla.org/docs/Mozilla/QA/Bug_writing_guidelines
Σάς φάνηκε χρήσιμο;
Παράθεση
jscher2000
  • Top 10 Contributor
8801 λύσεις 71984 απαντήσεις
Δημοσιεύτηκε

Επιλεγμένη λύση

Hi JeffC, could you review your default fonts and change them to TrueType fonts for testing? Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:

Hi JeffC, could you review your default fonts and change them to TrueType fonts for testing? Here's how: Open the Preferences page: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it Scroll down to the Language and Appearance section, and click the '''Advanced...''' button. This should open the Fonts dialog. (1) Select the '''Latin''' character set Near the top there is a character set selector. Latin is used for pages in English. (2) Change the fonts to basic TrueType fonts Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts. * '''Serif''' - Change from Times or Times Roman (or other serif font) to '''Times New Roman''' * '''Sans-serif''' - Change from Helvetica (or other sans-serif font) to '''Arial''' * '''Monospace''' - Change from Courier (or other fixed-pitch font) to '''Courier New''' (3) Repeat #1 and #2 with the "Other Writing Systems" character set (4) Click OK to save changes Any difference on the problem sites? ''Screenshot for reference:'' <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-27-08-17-06-866df5.png" width="500">
Σάς φάνηκε χρήσιμο; 1
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Jscher2000-

You did it! Although there is a small appearance difference due to the font change, it doesn't matter to me.

Thank you for the step by step instructions and screenshot. You made it fool proof. Very much appreciated!

Jscher2000- You did it! Although there is a small appearance difference due to the font change, it doesn't matter to me. Thank you for the step by step instructions and screenshot. You made it fool proof. Very much appreciated!
Σάς φάνηκε χρήσιμο;
Παράθεση
jscher2000
  • Top 10 Contributor
8801 λύσεις 71984 απαντήσεις
Δημοσιεύτηκε

Hi JeffC, thank you for reporting back. I don't know why there are individual character glitches with some fonts. It seems to be a recent development. If it would be helpful to learn more about the specific fonts, hopefully a developer will chime in and ask for the necessary details. Until then, we have a workaround.

Hi JeffC, thank you for reporting back. I don't know why there are individual character glitches with some fonts. It seems to be a recent development. If it would be helpful to learn more about the specific fonts, hopefully a developer will chime in and ask for the necessary details. Until then, we have a workaround.
Σάς φάνηκε χρήσιμο;
Παράθεση
s-cargo 0 λύσεις 2 απαντήσεις
Δημοσιεύτηκε

Hi, thanks for the answer, I had the same problem and these instructions helped to solve the problem. However, I also had to switch off the option "allow pages to choose their own fonts" to make the error disappear.

This of all places happened on the BBC news pages and impacted all instances of the number '9', including datelines in the footer sections - and even search fields. Yet the behavior was not linked to specific sites, it also happened in form fields in lockwise when I tried to enter or change passwords. Interestingly, the dashes could be found by searching for '9' in the search field (which was not impacted).

This must be a fairly recent phenomenon, since it did not happen before I switched to FF 70 (Mac 64bit) - it was however reproducible with older versions (I only tested 69 and 68).

But thanks again, I can keep FF my default browser ;-)

Hi, thanks for the answer, I had the same problem and these instructions helped to solve the problem. However, I also had to switch off the option "allow pages to choose their own fonts" to make the error disappear. This of all places happened on the BBC news pages and impacted '''all''' instances of the number '9', including datelines in the footer sections - and even search fields. Yet the behavior was not linked to specific sites, it also happened in form fields in lockwise when I tried to enter or change passwords. Interestingly, the dashes could be found by searching for '9' in the search field (which was not impacted). This must be a fairly recent phenomenon, since it did not happen before I switched to FF 70 (Mac 64bit) - it was however reproducible with older versions (I only tested 69 and 68). But thanks again, I can keep FF my default browser ;-)
Σάς φάνηκε χρήσιμο;
Παράθεση
cor-el
  • Top 10 Contributor
  • Moderator
17591 λύσεις 159130 απαντήσεις
Δημοσιεύτηκε

Note that if you disable "allow pages to choose their own fonts" that this affects downloaded icon fonts that are used on a lot of website to display small images anmd you may see little boxes with the hex code.

Note that if you disable "allow pages to choose their own fonts" that this affects downloaded icon fonts that are used on a lot of website to display small images anmd you may see little boxes with the hex code.
Σάς φάνηκε χρήσιμο;
Παράθεση
s-cargo 0 λύσεις 2 απαντήσεις
Δημοσιεύτηκε

cor-el said

Note that if you disable "allow pages to choose their own fonts" that this affects downloaded icon fonts that are used on a lot of website to display small images anmd you may see little boxes with the hex code.

Sadly enough, that is true - that's why the solution is a workaround, not a real solution. It is quite annoying that this happens with an upgrade and why does it affect something like type fonts? I wonder if there are more people seeing this kind of error?

''cor-el [[#answer-1265233|said]]'' <blockquote> Note that if you disable "allow pages to choose their own fonts" that this affects downloaded icon fonts that are used on a lot of website to display small images anmd you may see little boxes with the hex code. </blockquote> Sadly enough, that is true - that's why the solution is a workaround, not a real solution. It is quite annoying that this happens with an upgrade and why does it affect something like type fonts? I wonder if there are more people seeing this kind of error?
Σάς φάνηκε χρήσιμο;
Παράθεση
jscher2000
  • Top 10 Contributor
8801 λύσεις 71984 απαντήσεις
Δημοσιεύτηκε

Hi s-cargo, are you also on MacOS? Can you tell which font BBC uses? One method is to "inspect" the text (right-click > Inspect Element) in the developer tools and use the "Fonts" panel on the right side of the HTML tree diagram.

https://developer.mozilla.org/docs/Tools/Page_Inspector/How_to/Edit_fonts

Hi s-cargo, are you also on MacOS? Can you tell which font BBC uses? One method is to "inspect" the text (right-click > Inspect Element) in the developer tools and use the "Fonts" panel on the right side of the HTML tree diagram. https://developer.mozilla.org/docs/Tools/Page_Inspector/How_to/Edit_fonts
Σάς φάνηκε χρήσιμο;
Παράθεση
Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.