Αναζήτηση υποστήριξης

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Search not working w/ Firefox

  • 20 απαντήσεις
  • 3 έχουν αυτό το πρόβλημα
  • 1571 προβολές
  • Τελευταία απάντηση από FredMcD

more options

Hi,

 When I do a search w/ Google it doesn't work w/ Firefox. Typically I get " your search did not match any documents"

Google works fine w/ Chrome. Also, other search engines work fine w/ Firefox. Any help appreciated. Thanks

Επιλεγμένη λύση

OK. Clicked the "Show site info" for Google.com in the address bar & deleted cookies there. Problem seems fixed.

Ανάγνωση απάντησης σε πλαίσιο 👍 2

Όλες οι απαντήσεις (20)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

I tried w/ my extensions disabled. Did not help. I use CCleaner. No help. Hardware Acceleration unchecked.

more options

Επιλεγμένη λύση

OK. Clicked the "Show site info" for Google.com in the address bar & deleted cookies there. Problem seems fixed.

more options

Give it a few days. If the problem is gone,

That was very good work. Well done. Please flag your last post as Solved Problem as this could help others with the same problem.

more options

I'll give it a few days. Never had a problem like this. I have no idea why this happened. I appreciate your help. I'll flag as problem solved in a few days.

more options

There is an issue today where Google gives no results (the entire results list is missing) for some users when they are logged in to their Google account. But searches work normally when they are logged out or delete Google cookies (which also logs you out). Some discussion on Reddit today: https://www.reddit.com/r/firefox/comments/c5qx94/google_results_are_not_showing_on_firefox/

more options

I don't think my problem is quite the same but it might be related. After deleting Google.com cookies as described the search works when signed in or not. When the search didn't work I either got nothing or maybe one item. I'm pretty sure I tried the search signed in & not signed in & it didn't work. It would be nice to know what's going on. Thanks for the Reddit link.

more options

Change your default search on Firefox Focus for Android | How to Firefox Focus for Android Change your default search on Firefox Focus for Android

Firefox Focus for Android gives you the option to change your default search.

Here's how to do it:

   Tap the menu button at the top right corner
   focus menu android
   Tap Settings.
   Tap Search.
   Choose the search engine that you want to make your default.
   Tap the back arrow to save your changes and return to the previous screen. 

Was this article helpful?

// These fine people helped write this article:Joni. You can help too - find out how.

Last Update: 2017-05-18 Get support for another platform: Customize this article Firefox Focus

more options

Change your default search on Firefox Focus for Android | How to Firefox Focus for Android Change your default search on Firefox Focus for Android

Firefox Focus for Android gives you the option to change your default search.

Here's how to do it:

   Tap the menu button at the top right corner
   focus menu android
   Tap Settings.
   Tap Search.
   Choose the search engine that you want to make your default.
   Tap the back arrow to save your changes and return to the previous screen. 

Was this article helpful?

// These fine people helped write this article:Joni. You can help too - find out how.

Last Update: 2017-05-18 Get support for another platform: Customize this article Firefox Focus

more options

This problem is on a desktop/Win 10 not an Android device.

more options

canyonlight3142 said

OK. Clicked the "Show site info" for Google.com in the address bar & deleted cookies there. Problem seems fixed.

Could have been this Shield Studies extension acting up :

"ETP Search Volume Study 1.2 (etp-search-volume-study@shield.mozilla.org) "

(listed in your system details)

https://github.com/mozilla/etp-search-volume-study

more options

I don't have that extension.

more options

Found it in Firefox Data Collection & Use. If the problem returns I'll uncheck this.

more options

canyonlight3142 said

I don't have that extension.

It shows in your system details (to the right of your original post).

In 3-bar menu (or Tools) => Add-ons => Extensions : Not there  ?

more options

It doesn't show up in extensions. It does show up in system details. A "hidden extension"?

more options

canyonlight3142 said

It doesn't show up in extensions. It does show up in system details. A "hidden extension"?

Well, you found it on the "about:studies" page - that's good enough - you can remove it, should the problem return.

But it was only a wild guess that this extension might have had anything to do with it, though .....

Everything is working now the way it should, so let's just wait and see what happens.

more options

Seems Google doesn't play well w/ Firefox. Maybe just switch to DuckDuckGo.

more options

canyonlight3142 said

Seems Google doesn't play well w/ Firefox. Maybe just switch to DuckDuckGo.

Does this mean that the problem is back ?

If so : did you remove the Shield Studies extension (just in case that's what causing the problem) ?

more options

No. Everything good. Just a general observation. Thanks.

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.