X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

restore previous session not working

Δημοσιεύτηκε

I have Windows 7 Ultimate 64-bit PC.

Start Firefox and open up 4 tabs with different websites for each tab.

With the 4th tab displaying, close Firefox

Wait until all instances of Firefox in Task Manager have ended

Restart Firefox

The restore previous session loads the 4 tabs but does not display tab 4 being the last tab showing when closed. It displays a blank page and is totally unresponsive. Starting a new tab (5) is also unresponsive. Yet the other 3 tabs work fine.

Steps taken – uninstalled Firefox and deleted existing profile then reinstalled Firefox with a new profile but no change. No add-ons, bookmarks, history or settings changed.

Please help.

I have Windows 7 Ultimate 64-bit PC. Start Firefox and open up 4 tabs with different websites for each tab. With the 4th tab displaying, close Firefox Wait until all instances of Firefox in Task Manager have ended Restart Firefox The restore previous session loads the 4 tabs but does not display tab 4 being the last tab showing when closed. It displays a blank page and is totally unresponsive. Starting a new tab (5) is also unresponsive. Yet the other 3 tabs work fine. Steps taken – uninstalled Firefox and deleted existing profile then reinstalled Firefox with a new profile but no change. No add-ons, bookmarks, history or settings changed. Please help.

Επιλεγμένη λύση

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Ανάγνωση απάντησης σε πλαίσιο 0
Παράθεση

Επιπρόσθετες λεπτομέρειες συστήματος

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; GWX:RESERVED; rv:11.0) like Gecko

Περισσότερες πληροφορίες

FredMcD
  • Top 10 Contributor
4220 λύσεις 58906 απαντήσεις
Δημοσιεύτηκε

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

You may have corrupt '''sessionstore''' [v56] '''sessionstore.jsonlz4''' file(s). Delete all '''sessionstore*''' files and the '''sessionstore-backups''' folder. Type '''about:support'''<enter> in the address bar. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Locate the above file. Then rename or delete it. Restart Firefox. '''Don't delete the files''' if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Thank you for your swift response and suggestion. I carried out your instructions but it hasn’t fixed my problem unfortunately.

Further information – it doesn’t do it every time, about 1 in 3.

Also, there are multiple Firefox processes in Task Manager that take 20 seconds to clear after closing Firefox and if I restart before all have cleared Firefox does not start. I’ve tried changing from multiple tabs in about:config/browser.tabs.remote.autostart and changing to true but problem still evident.

Thanks

Thank you for your swift response and suggestion. I carried out your instructions but it hasn’t fixed my problem unfortunately. Further information – it doesn’t do it every time, about 1 in 3. Also, there are multiple Firefox processes in Task Manager that take 20 seconds to clear after closing Firefox and if I restart before all have cleared Firefox does not start. I’ve tried changing from multiple tabs in about:config/browser.tabs.remote.autostart and changing to true but problem still evident. Thanks
Σάς φάνηκε χρήσιμο;
Παράθεση
FredMcD
  • Top 10 Contributor
4220 λύσεις 58906 απαντήσεις
Δημοσιεύτηκε

FFoxUser01 said

Also, there are multiple Firefox processes . . . .

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess

''FFoxUser01 [[#answer-1209961|said]]'' <blockquote> Also, there are multiple Firefox processes . . . . </blockquote> More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess
Σάς φάνηκε χρήσιμο;
Παράθεση
FredMcD
  • Top 10 Contributor
4220 λύσεις 58906 απαντήσεις
Δημοσιεύτηκε

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Ok, tab 4 is not responsive – close FF – start in Safe Mode – all tabs up & responsive. However, when in a non safe mode closing & restarting fixes the tabs anyway. I do not have any add-ons installed.

Tried replicating again. 4 tabs up & responsive, close FF – start FF after 10 seconds but before all processes have ended in Task Manager - tab 1 is now unresponsive & others fine - Close FF but this time wait 20 seconds for all processes to end in Task Manager – Start FF now ALL tabs responsive. How bizarre!

One indicator is that it’s taking too long for all FF processes to end after closing. This means that if I close FF inadvertently I’ll have to wait 20 seconds before starting again which is not how it should be. My pc has an i7 cpu, 8gb RAM running 64-bit Firefox.

Thanks again Fred. I’ve been trying to fix this issue for weeks, thinking that an version update would solve it but no. It must be my setup as no-one else appears to have the issue. Interesting though.

Ok, tab 4 is not responsive – close FF – start in Safe Mode – all tabs up & responsive. However, when in a non safe mode closing & restarting fixes the tabs anyway. I do not have any add-ons installed. Tried replicating again. 4 tabs up & responsive, close FF – start FF after 10 seconds but before all processes have ended in Task Manager - tab 1 is now unresponsive & others fine - Close FF but this time wait 20 seconds for all processes to end in Task Manager – Start FF now ALL tabs responsive. How bizarre! One indicator is that it’s taking too long for all FF processes to end after closing. This means that if I close FF inadvertently I’ll have to wait 20 seconds before starting again which is not how it should be. My pc has an i7 cpu, 8gb RAM running 64-bit Firefox. Thanks again Fred. I’ve been trying to fix this issue for weeks, thinking that an version update would solve it but no. It must be my setup as no-one else appears to have the issue. Interesting though.
Σάς φάνηκε χρήσιμο;
Παράθεση
FredMcD
  • Top 10 Contributor
4220 λύσεις 58906 απαντήσεις
Δημοσιεύτηκε

Επιλεγμένη λύση

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.
Σάς φάνηκε χρήσιμο;
Παράθεση
Pj 42 λύσεις 869 απαντήσεις
Δημοσιεύτηκε

FFoxUser01 said

4 tabs up & responsive, close FF – start FF after 10 seconds but before all processes have ended in Task Manager - tab 1 is now unresponsive & others fine - Close FF but this time wait 20 seconds for all processes to end in Task Manager – Start FF now ALL tabs responsive.

If you think 20 seconds is long... how about 45 seconds or at times, over 1 minute! I ALWAYS wait for ALL FF's Processes to close - AND on top of that, wait until HDD activity has quieted-down before I do anything else.


~Pj

''FFoxUser01 [[#answer-1209975|said]]'' <blockquote> 4 tabs up & responsive, close FF – start FF after 10 seconds but before all processes have ended in Task Manager - tab 1 is now unresponsive & others fine - Close FF but this time wait 20 seconds for all processes to end in Task Manager – Start FF now ALL tabs responsive. </blockquote> If you think 20 seconds is long... how about 45 seconds or at times, over 1 minute! I ALWAYS wait for ALL FF's Processes to close - AND on top of that, wait until HDD activity has quieted-down before I do anything else. ~Pj
Σάς φάνηκε χρήσιμο;
Παράθεση
cor-el
  • Top 10 Contributor
  • Moderator
17407 λύσεις 157258 απαντήσεις
Δημοσιεύτηκε
Did you try Firefox Safe Mode? *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Perhaps I didn’t make it clear in my last post. Yes, I restarted FF in safe mode and all tabs were responsive. However, this was how I cleared the fault before (when in normal made) by just closing Firefox, waiting 20 secs and restarting FF. Therefore, I am unsure whether testing in safe mode has solved the issue. I don’t think so, as I have no add-ons, I carried out a new FF installation with a new profile and all remnants of previous FF were moved from the Profiles folder before the new install.

My next step was to change browser.tabs.remote.autostart from true to false. There was no browser.tabs.remote.autostart2 present. I tried this before with my old profile without success but this time it seems to have sorted it out and I now have only 1 process of FF loaded but the size is 850mb with 6 tabs open.

It seems that the e10s do not work in my setup which is a shame.

Many thanks for helping me.

Perhaps I didn’t make it clear in my last post. Yes, I restarted FF in safe mode and all tabs were responsive. However, this was how I cleared the fault before (when in normal made) by just closing Firefox, waiting 20 secs and restarting FF. Therefore, I am unsure whether testing in safe mode has solved the issue. I don’t think so, as I have no add-ons, I carried out a new FF installation with a new profile and all remnants of previous FF were moved from the Profiles folder before the new install. My next step was to change browser.tabs.remote.autostart from true to false. There was no browser.tabs.remote.autostart2 present. I tried this before with my old profile without success but this time it seems to have sorted it out and I now have only 1 process of FF loaded but the size is 850mb with 6 tabs open. It seems that the e10s do not work in my setup which is a shame. Many thanks for helping me.
Σάς φάνηκε χρήσιμο;
Παράθεση
FredMcD
  • Top 10 Contributor
4220 λύσεις 58906 απαντήσεις
Δημοσιεύτηκε

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.


Note: If you need more advice on the e10's issue, please ask another question.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support. Note: If you need more advice on the e10's issue, please ask another question.
Σάς φάνηκε χρήσιμο;
Παράθεση
Pj 42 λύσεις 869 απαντήσεις
Δημοσιεύτηκε

FFoxUser01 said

I now have only 1 process of FF loaded but the size is 850mb with 6 tabs open.

Do you still have to wait 20 seconds upon Closing FF?


~Pj

''FFoxUser01 [[#answer-1210153|said]]'' <blockquote> I now have only 1 process of FF loaded but the size is 850mb with 6 tabs open. </blockquote> Do you still have to wait 20 seconds upon Closing FF? ~Pj
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Hi Pj

Just had 6 tabs loaded with one firefox.exe in Task Manager amounting to 895mb.

I clicked the red x to close FF and the process ending was immediate (less than a second). I then started FF within a few seconds of it closing down and all 6 tabs loaded up and were responsive.

Good luck.

Hi Pj Just had 6 tabs loaded with one firefox.exe in Task Manager amounting to 895mb. I clicked the red x to close FF and the process ending was immediate (less than a second). I then started FF within a few seconds of it closing down and all 6 tabs loaded up and were responsive. Good luck.
Σάς φάνηκε χρήσιμο;
Παράθεση
Pj 42 λύσεις 869 απαντήσεις
Δημοσιεύτηκε

FFoxUser01 said

Just had 6 tabs loaded with one firefox.exe in Task Manager amounting to 895mb.

I clicked the red x to close FF and the process ending was immediate (less than a second). I then started FF within a few seconds of it closing down and all 6 tabs loaded up and were responsive.

Your not setup to 'Restore a Session' then if your clicking the X to Close-out? If so, you should be using 'Exit' instead of X. Or does X maintain the Session with just 1 browser window?

I have 4 FireFox.exe Processes going. 22 browser windows (one window is over a Gig - over 1,300 Tabs). I have Multi-Processing off in the GUI (set to 1), but I'm wondering if I have to set this in About:Config.


~Pj

''FFoxUser01 [[#answer-1210286|said]]'' <blockquote> Just had 6 tabs loaded with one firefox.exe in Task Manager amounting to 895mb. <Br> <Br> I clicked the red x to close FF and the process ending was immediate (less than a second). I then started FF within a few seconds of it closing down and all 6 tabs loaded up and were responsive. </blockquote> Your not setup to 'Restore a Session' then if your clicking the X to Close-out? If so, you should be using 'Exit' instead of X. Or does X maintain the Session with just 1 browser window? I have 4 '''FireFox.exe''' Processes going. 22 browser windows (one window is over a Gig - over 1,300 Tabs). I have Multi-Processing off in the GUI (set to 1), but I'm wondering if I have to set this in '''About:Config'''. ~Pj
Σάς φάνηκε χρήσιμο;
Παράθεση
Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.