Αναζήτηση υποστήριξης

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox v66 not working with ublock origin

  • 25 απαντήσεις
  • 3 έχουν αυτό το πρόβλημα
  • 2354 προβολές
  • Τελευταία απάντηση από Mike109

more options

Ever since updating to Firefox v 66, the browser won't load webpages until I disable ublock origin in the add-ins page. It's very repeatable, I disable ublock and the page loads. Enable it again, and new pages won't load. I've also disabled all my other add-ins when doing this, so it's not some weird interaction between add-ins.

Normally I would consider this a ublock problem, but it didn't change. This started happening with the Firefox v 66 update. I've searched, but nobody else seems to have the same problem. What can I try (besides getting rid of ublock)?

Επιλεγμένη λύση

I just updated FF to 66.0.2 and it seems to have solved my problems with ublock even though I'm still running versions 1.18.6.

I'm going to consider this problem solved.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (5)

more options

Did some more searching & experimenting. This link seemed to indicate that Firefox was the culprit. https://github.com/uBlockOrigin/uBlock-issues/issues/416

I took a fresh profile & added uBlock Origin 1.18.16 to FF 66.0.3 and there was no delay opening the first web page.

I still have to work on getting my FF search history to show up as the search suggestions, but that's probably going to involve installing Tampermonkey.

I'd rather not start with a fresh FF profile because of changes & tweaks that were made. Maybe all that's need is to clean out a single file in the profile which would save some time.

Are there any suggestions what the problem might be in FF?

more options

Mike109 said

I went to "To install the developer build:" and below it was “Firefox: click uBlock0_1.18.17rc4.firefox.signed.xpi.” I did not see 1.18.17.11 or higher.

The 17.xxx Developer versions will soon follow and update ahead of the regular public release versions.

I ignored the FF warning & installed 1.18.17rc4, but it made no difference. The first web page still loads real slow and my search history suggestions only show up the first time Google.com is clicked on & run.

So far I changed Keyword.Enabled to false and Browser.URLbar.OneOffSearches to false. But the Google Search menu still shows up when I start typing in the search bar.

My Google searches used to look like the first picture which shows my search history. Now that only works the first time Google.com is loaded when FF is run. I have to close out FF and open it again if I want my search history to show up.

All the other times that Google is clicked on yields Google suggestions as shown in the second picture.

It would be OK if my search history showed up when I used the search bar, but so far that’s not happening.

The About:Config changes are for FireFox's Address Bar, not what happens on Google's Search / Website.


~Pj

more options

Pj said

Mike109 said
I went to "To install the developer build:" and below it was “Firefox: click uBlock0_1.18.17rc4.firefox.signed.xpi.” I did not see 1.18.17.11 or higher.

The 17.xxx Developer versions will soon follow and update ahead of the regular public release versions.

I ignored the FF warning & installed 1.18.17rc4, but it made no difference. The first web page still loads real slow and my search history suggestions only show up the first time Google.com is clicked on & run.

So far I changed Keyword.Enabled to false and Browser.URLbar.OneOffSearches to false. But the Google Search menu still shows up when I start typing in the search bar.

My Google searches used to look like the first picture which shows my search history. Now that only works the first time Google.com is loaded when FF is run. I have to close out FF and open it again if I want my search history to show up.

All the other times that Google is clicked on yields Google suggestions as shown in the second picture.

It would be OK if my search history showed up when I used the search bar, but so far that’s not happening.

The About:Config changes are for FireFox's Address Bar, not what happens on Google's Search / Website.


~Pj

I'm probably making things confusing because I'm looking at two different areas, the Google search bar & the Firefox search bar at the top of Firefox next to the address bar. I'm hoping one of these will display my search history as the search suggestions.

When I mentioned "So far I changed Keyword.Enabled to false and Browser.URLbar.OneOffSearches to false. But the Google Search menu still shows up when I start typing in the search bar" I was referring to the Firefox Search Bar.

"Google Search" still appeared under the Firefox Search Bar just like it did before.

more options

Mike109 said

When I mentioned "So far I changed

Keyword.Enabled

...to false and

Browser.URLbar.OneOffSearches

...to false. But, the Google Search menu still shows up when I start typing in the search bar". (I was referring to the Firefox Search Bar.)

"Google Search" still appeared under the Firefox Search Bar just like it did before.

Did you setup everything as in my Other Post?


~Pj

more options

I made all the changes you mentioned in your other post. Here's what my Firefox search bar looks like when I just entered the letter "o". I don't have "oil" in my FF search history & it seems unlikely that is the only suggestion that Google would come up with.

All these settings also disabled the FF address bar drop down suggestions.

  1. 1
  2. 2