X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Φόρουμ υποστήριξης

How to stop Firefox from making automatic requests on startup

Δημοσιεύτηκε

Every time I start Firefox with a new profile, despite trying in several ways to make this not happen, Firefox automatically makes a series of requests to URL's and will retry them repeatedly when those requests fail.

``` GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 POST https://shavar.services.mozilla.com/downloads?client=Firefox&appver=60.2&pver=2.2 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 POST https://shavar.services.mozilla.com/downloads?client=Firefox&appver=60.2&pver=2.2 ... (and so on) ```

I am trying to make this not happen. I'm ideally looking for a setup where Firefox will make no requests at all without me explicitly telling it to but just eliminating the two requests above would be a great start!

Here's what I've tried so far:

1. Uncheck "Provide search suggestions" in `about:preferences#search`

2. I've followed these instructions --- https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections

2. Here are a combination of select settings from my `user.js` preferences file that I put in to place before opening Firefox in my attempts to stop this. Some of these may or may not be relevant but I'm including them so you have some idea what I've tried: ``` user_pref("app.update.enabled", false); user_pref("browser.tabs.crashReporting.sendReport", false); user_pref("browser.crashReports.unsubmittedCheck.enabled", false) user_pref("browser.search.update", false); user_pref("browser.search.suggest.enabled", false); user_pref("extensions.systemAddon.update.enabled", false); user_pref("extensions.update.enabled", false); user_pref("browser.safebrowsing.downloads.remote.enabled", false); user_pref('browser.search.geoSpecificDefaults.url', ); user_pref('media.gmp-manager.url', ); user_pref('browser.safebrowsing.provider.mozilla.updateURL', ); user_pref('browser.safebrowsing.provider.mozilla.gethashURL', ) user_pref('browser.search.cohort', ); user_pref("services.sync.prefs.sync.browser.urlbar.suggest.searches", false); ``` Any ideas?

Every time I start Firefox with a new profile, despite trying in several ways to make this not happen, Firefox automatically makes a series of requests to URL's and will retry them repeatedly when those requests fail. ``` GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 POST https://shavar.services.mozilla.com/downloads?client=Firefox&appver=60.2&pver=2.2 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 GET https://search.services.mozilla.com/1/firefox/60.2.2/default/en-US/AU/default/default/nov17-1 POST https://shavar.services.mozilla.com/downloads?client=Firefox&appver=60.2&pver=2.2 ... (and so on) ``` I am trying to make this not happen. I'm ideally looking for a setup where Firefox will make no requests at all without me explicitly telling it to but just eliminating the two requests above would be a great start! Here's what I've tried so far: 1. Uncheck "Provide search suggestions" in `about:preferences#search` 2. I've followed these instructions --- https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections 2. Here are a combination of select settings from my `user.js` preferences file that I put in to place before opening Firefox in my attempts to stop this. Some of these may or may not be relevant but I'm including them so you have some idea what I've tried: ``` user_pref("app.update.enabled", false); user_pref("browser.tabs.crashReporting.sendReport", false); user_pref("browser.crashReports.unsubmittedCheck.enabled", false) user_pref("browser.search.update", false); user_pref("browser.search.suggest.enabled", false); user_pref("extensions.systemAddon.update.enabled", false); user_pref("extensions.update.enabled", false); user_pref("browser.safebrowsing.downloads.remote.enabled", false); user_pref('browser.search.geoSpecificDefaults.url', ''); user_pref('media.gmp-manager.url', ''); user_pref('browser.safebrowsing.provider.mozilla.updateURL', ''); user_pref('browser.safebrowsing.provider.mozilla.gethashURL', '') user_pref('browser.search.cohort', ''); user_pref("services.sync.prefs.sync.browser.urlbar.suggest.searches", false); ``` Any ideas?

Επιπρόσθετες λεπτομέρειες συστήματος

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Περισσότερες πληροφορίες

cor-el
  • Top 10 Contributor
  • Moderator
17845 λύσεις 161524 απαντήσεις
Δημοσιεύτηκε

These specific request seem to be about checking for updates of search engines. You shouldn't deliberately modify preferences on the about:config page.

  • Options/Preferences -> General -> Updates
These specific request seem to be about checking for updates of search engines. You shouldn't deliberately modify preferences on the <b>about:config</b> page. *Options/Preferences -> General -> Updates