Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

New tab does not have the options for displaying most visited anymore

  • 25 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 311 προβολές
  • Τελευταία απάντηση από gdchief

more options

On home page options, new tab only has the two options of firefox home page or blank. What happened to the other options?

Επιλεγμένη λύση

This is the header for a prefs.js file.

# Mozilla User Preferences

/* Do not edit this file.
 *
 * If you make changes to this file while the application is running,
 * the changes will be overwritten when the application exits.
 *
 * To make a manual change to preferences, you can visit the URL about:config
 */

It seems strange that a Quick JS Switcher extension would create such a lengthy user.js file; if in fact it even creates a user.js file at all. That would be beyond what the Quick JS Switcher extension is purported to do; which is toggling JavaScript off and on, from the description of that extension.

Are you sure that you didn't paste the contents of your prefs.js file instead of the user.js file?

Any pref set in user.js will end up in prefs.js - that's the way Firefox works.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (20)

more options

Hi gdchief, the "new tab page" has been renamed to "Firefox Home" and should have the same categories of data available -- these are listed on the same panel (Options > Home).

If you were replacing the new tab page with a different page using an add-on, the add-on should still be able to replace the page.

more options

That is my problem I change to either Firefox Home or blank page and all I get is a blank page. If you look at Firefox help it says there should be other options, such as most visited etc. But again new tabs only come up with a blank page.

more options

That selector changes a setting under the hood. Could you check it manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste newt and pause while the list is filtered; there are a lot of these, so you'll need to scroll down...

(3) If the browser.newtabpage.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

If that is true, the page shouldn't be blank. If it's still blank, and the Options > Home didn't mention an extension replacing the page, then we may need to enter the realm of "try this, try that"...

more options

This setting is set as true. This problem just showed up a couple of days ago, has firefox made any changes in the last few days?

more options

The last Firefox update was about 34 days ago: https://www.mozilla.org/firefox/61.0.1/releasenotes/

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Turns out there's an update available today(!). No idea if that would help:

https://www.mozilla.org/firefox/61.0.2/releasenotes/

more options

I am not home right now, but did try safe mode before I left. There is no difference in Firefox in safe mode. I will try the update when I get home this evening. Am I the only one reporting this problem?

more options

Hi, I only have 2 Options. Does fine for me as I use a Blank.


more options

gdchief said

Am I the only one reporting this problem?

I confess I can't read every thread. I think I've seen one or two other reports of a stubbornly blank new tab page with Firefox 61.

In case there is a problem with the program files or something that doesn't belong in the program files folder:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

more options

Try to delete the storage folder in the Firefox profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

cor-el said

Try to delete the storage folder in the Firefox profile folder. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.
Or rename it to storageOLD in case there is valuable add-on data in IndexedDB databases you might wish to recover later.
more options

I renamed the storage folder to storageold and restarted firefox. A new storage file was created with much less information but did not solve the problem. I have not yet installed the new update.

more options

I installed the new update this morning. It had no affect on the blank new tabs.

more options

Problem solved. My profile contained a user.js file that must have been created by an addon. I renamed the file so it isn't used and the problem has been resolved. I think it was caused by by the addon Quick JS Switcher. Thanks to all for your assistance!!

more options

gdchief said

Problem solved. My profile contained a user.js file that must have been created by an addon. I renamed the file so it isn't used and the problem has been resolved.

Oh... we should have asked you to share your Firefox data; that would have indicated there was a user.js file.

Did you notice what was set in the file to cause the problem?

more options

No, I couldn't tell which setting was the problem. I can send a copy of the file if that would help.

more options

If you like, you can post a copy of its contents here:

https://pastebin.mozilla.org/

The site will go down in a few weeks, but we won't need it very long.

more options

gdchief said

Done.

Did it give you a link you could share? I don't think the addresses are easily guessable.

  1. 1
  2. 2