Avatar for Username

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Videos in Firefox have skewed, "psychedelic" colors. Mozilla icon has strange, bright, high contrast colors, also. Any ideas?

more options

While playing bookmarked music videos in Firefox the colors are very bright, contrasting and look psychedelic. The same videos play in normal colors in Chrome. I'm using the same computer and monitor. Any ideas how to fix this in Mozilla?

While playing bookmarked music videos in Firefox the colors are very bright, contrasting and look psychedelic. The same videos play in normal colors in Chrome. I'm using the same computer and monitor. Any ideas how to fix this in Mozilla?

Όλες οι απαντήσεις (4)

more options

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

This did NOT solve the problem. The colors are very bright with high contrast and oversaturated. I've tried fixing it the usual way in Settings and Graphics but nothing has helped. It's only Mozilla...Chrome colors are fine. Even the Mozilla Firefox icon is color skewed.

more options

First, could you check for any "compatibility" settings that may be overriding normal settings?

To do that, find the icon you use the start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

You should clear all the boxes on the Compatibility tab for best results (giant screenshot below).

Any difference the next time you start Firefox?

more options

Second, do you notice any issues with the colors of JPEG and PNG images? In that case, you could experiment with Firefox's color management settings.

This is an old write-up, but I haven't heard about any changes since then:

By default, Firefox will try to color manage tagged images (JPEGs and PNGs). You can review and experiment with the following preferences to see whether one of them is causing the problem:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx.c and pause while the list is filtered

gfx.color_management.mode - governs application of color management to images

  • 0 = off
  • 1 = on for ALL images
  • 2 = on for TAGGED images (default)

I can't recall whether you need to quit/restart Firefox before this change, or changes to the below preferences, takes effect.

gfx.color_management.display_profile - if you have created a custom monitor profile and Firefox is not using it, you can enter the path to it here.

gfx.color_management.enablev4 - double-click to toggle to true if your custom monitor profile is an ICC v4 profile

gfx.color_management.rendering_intent - whether Firefox honors or overrides the intent flag in the ICC profile, by default, overrides to Perceptual

For details, see: https://developer.mozilla.org/Firefox/Releases/3.5/ICC_color_correction_in_Firefox

Can you find a combination of settings that gives you the colors you expect?