Search Support

Firefox doesnt have yahoo search engine anymore

  • 80 απαντήσεις
  • 16 έχουν αυτό το πρόβλημα
  • 1610 προβολές
  • Τελευταία απάντηση από jscher2000

more options

Since today the yahoo search engine option for firefox is gone and am being forced to use google.

Is this a bug?, i hate google search engine.

Επιλεγμένη λύση

s1raz1 said

You can use as band aid: On options go to Search then select ADD search bar on tool bar ( second option) Go to Yahoo.com then on the search box that was just added it will have a + sign on the magnifying glass, select add yahoo as search engine. So far its how i have been working around the issue. If you remove it it wont appear even if you hit restore engines tho, so you have to repeat if you remove it by mistake.

Based on the above I'll mark this question solved. For others reading, see the instructions I posted in my March 11, 2018 reply for details.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

All Replies (20)

more options

Try changing your default search engine on the Options page. The setting looks like this:

More info in this article: Change your default search settings in Firefox.

Does that work for you?

more options

If that drop-down control doesn't give you Yahoo as a choice, scroll down and check for the "Restore Default Search Engines" button below the large box and if it's enabled (text is black), click it. Here's what that looks like:

more options

Yahoo engine is gone from that tab, magically. Even when i hit restore it restore all the other engines but yahoo. Its the only engine i keep, now google default is there, this started when they rolled that pocket thing addition.

Τροποποιήθηκε στις από το χρήστη azy

more options

There are many Yahoo search engine options at http://mycroftproject.com/yahoo-search-plugins.html

Yahoo should still be a choice of search engines, just that it is not the default search engine (since Firefox 57.0 and later) for locales that changed to it as Mozilla parted ways with Yahoo.

https://blog.mozilla.org/blog/2017/11/14/firefox-features-google-as-default-search-provider-in-the-u-s-canada-hong-kong-and-taiwan/ https://blog.mozilla.org/blog/2017/12/05/mozilla-files-cross-complaint-against-yahoo-holdings-and-oath/

more options

Did you even read before posting a generic response or do you need to reach your daily posting quota?

The yahoo search engine option is GONE!!! , hitting restore doesnt bring it back, and this started today because i use it every EFFING day!!!

more options

@s1raz1, one should take some time out here and think before shooting off. This is a End user Help forum and help is what they provide without being paid or compensated. Going down this line is what causes one to loose access.

Τροποποιήθηκε στις από το χρήστη WestEnd

more options

s1raz1 said

Did you even read before posting a generic response or do you need to reach your daily posting quota? The yahoo search engine option is GONE!!! , hitting restore doesnt bring it back, and this started today because i use it every EFFING day!!!

No that was obviously not a generic response. I have no quota as pretty much everybody here are volunteers on this community forum. Would be nice if I got paid to help put up with such wonderful responses like yours though.

I did read, however just because the Yahoo search engine may be missing as one of the default choices for You for some reason at moment does not mean that is normal.

I gave you a option to still add one since you appear to really want a Yahoo search engine in the Search Bar.

Τροποποιήθηκε στις από το χρήστη James

more options

Would you please check this :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar browser.search

and look for the preference :

browser.search.defaultenginename

its value should of course be Yahoo ........ is it  ?

more options

@Happy

No, everything there says google but the option browser.search.order.2 that still says yahoo. And nothing has been modified there.


Is this all the support Firefox fox has? Only volunteers that have zero clue more worried about posting quotas while having zero knowledge.

Least i found how to force re-add it by going to yahoo.com and forcing a re add as engine but that still doesnt solve the issue that is gone with no explanation. And if i remove it from the engine options is back to OP.

So dont re open this topic by posting because your feelings got hurt.

Τροποποιήθηκε στις από το χρήστη azy

more options

I don't read every post here, but I've never heard of this in all of the posts I have read. Yahoo is built-in, and if you Restore Default Search Engines, it reappears.

Perhaps your Firefox program files have been modified somehow. Please try:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

more options

One other thing to consider: perhaps the settings file search.json.mozlz4 has become corrupted. You can remove the file and let Firefox regenerate it. This will unfortunately remove any custom search engines you have added to Firefox.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

If you see a file named search.json, rename that one to searchOLD.json.

Start Firefox back up again and it should rebuild search settings. Then if you return to the Options page, Search panel, you should find and be able to designate the Yahoo search plugin as default.

Success?

more options

It did not solve it, deleted both file and restarted FF, same as before all engines are restored but yahoo. This all started when they added the pockets suggestions that you can see when you create a new tab. I went to take a nap came back and pocket suggestions were added and yahoo engine was gone.

And am not going to reinstall Firefox because am the only one that uses this computer. Computer hasnt had any hard resets or FF random crashes. Am sure Pocket is the one causing this issue.

more options

s1raz1, Its not just you. Yahoo is gone for me too, I have tried what has been suggested but it isnt there. Everything was fine even earlier today btu then i did a search from the toolbar like I always do, which us yes how I have things set up, and it went to amazon for some reason. SO I tried again and again it went to amazon. SO I went and looked and restored the search engine settings and yahoo isnt there as an option. I had everything else deleted but YAHOO for search and it has been replaced but amazon wikipedia bing of all things and google. Its NOT just you

more options

James said

s1raz1 said
Did you even read before posting a generic response or do you need to reach your daily posting quota? The yahoo search engine option is GONE!!! , hitting restore doesnt bring it back, and this started today because i use it every EFFING day!!!

No that was obviously not a generic response. I have no quota as pretty much everybody here are volunteers on this community forum. Would be nice if I got paid to help put up with such wonderful responses like yours though.

I did read, however just because the Yahoo search engine may be missing as one of the default choices for You for some reason at moment does not mean that is normal.

I gave you a option to still add one since you appear to really want a Yahoo search engine in the Search Bar.

IT IS NOT JUST the person that started this question. Everything was fine for me earlier today but then i went to search afternoon and it went to amazon. So I tried again and again it went to amazon. So I checked my settings and yahoo is gone.

more options

jscher2000 said

One other thing to consider: perhaps the settings file search.json.mozlz4 has become corrupted. You can remove the file and let Firefox regenerate it. This will unfortunately remove any custom search engines you have added to Firefox. Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > Exit
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4. If you see a file named search.json, rename that one to searchOLD.json. Start Firefox back up again and it should rebuild search settings. Then if you return to the Options page, Search panel, you should find and be able to designate the Yahoo search plugin as default. Success?

DOESNT WORK I tried it just now and yahoo still gone as a choice under search options I use the address bar as search and have for years like many people. I know its just an inconvenience to have to go to yahoo.com to use the search but when you have no option besides duckduckgo whatever that and google or bing of all things and when something is forced to you without your knowledge such as a change as big as this, its more than an inconvenience, Thanks for trying though

more options

Just to let everyone know I did the refresh and nothing. And I have 3 computers and 2 phones in the house, YAHOO is GONE from all of them.

more options

You can use as band aid: On options go to Search then select ADD search bar on tool bar ( second option) Go to Yahoo.com then on the search box that was just added it will have a + sign on the magnifying glass, select add yahoo as search engine.

So far its how i have been working around the issue. If you remove it it wont appear even if you hit restore engines tho, so you have to repeat if you remove it by mistake.

more options

s1raz1 said

This all started when they added the pockets suggestions that you can see when you create a new tab. I went to take a nap came back and pocket suggestions were added and yahoo engine was gone.

It's normal to have a "Recommended by Pocket" section on the new tab page in Firefox 57 and later. Perhaps your update from Firefox 56 was delayed, or perhaps some settings were changed around the same time? Either way, Firefox 58.0.2 should still have Yahoo built in.

Could you paste this address to your Firefox address bar and press Enter to load it? This is an internal address of the XML definition of the Yahoo search plugin:

resource://search-plugins/yahoo.xml

Does that give you content or "page not found"?

more options

This is what I got when i did the resource link

This XML file does not appear to have any style information associated with it. The document tree is shown below.

     <SearchPlugin><ShortName>Yahoo</ShortName><Description>Yahoo Search</Description><InputEncoding>UTF-8</InputEncoding><Image width="16" height="16">resource://search-plugins/images/yahoo.ico</Image><Url type="application/x-suggestions+json" method="GET" template="https://search.yahoo.com/sugg/ff"><Param name="output" value="fxjson"/><Param name="appid" value="ffd"/><Param name="command" value="{searchTerms}"/></Url><Url type="text/html" method="GET" template="https://search.yahoo.com/yhs/search" resultdomain="yahoo.com" rel="searchform"><Param name="p" value="{searchTerms}"/><Param name="ei" value="UTF-8"/><Param name="hspart" value="mozilla"/><MozParam name="hsimp" condition="purpose" purpose="searchbar" value="yhs-001"/><MozParam name="hsimp" condition="purpose" purpose="keyword" value="yhs-002"/><MozParam name="hsimp" condition="purpose" purpose="homepage" value="yhs-003"/><MozParam name="hsimp" condition="purpose" purpose="newtab" value="yhs-004"/><MozParam name="hsimp" condition="purpose" purpose="contextmenu" value="yhs-005"/><MozParam name="hsimp" condition="purpose" purpose="system" value="yhs-007"/></Url></SearchPlugin>
more options

s1raz1 said

You can use as band aid: On options go to Search then select ADD search bar on tool bar ( second option) Go to Yahoo.com then on the search box that was just added it will have a + sign on the magnifying glass, select add yahoo as search engine. So far its how i have been working around the issue. If you remove it it wont appear even if you hit restore engines tho, so you have to repeat if you remove it by mistake.

I got it added back thanks

Τροποποιήθηκε στις από το χρήστη needyahoo

  1. 1
  2. 2
  3. 3
  4. 4