Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Why is Firefox Quantum using so much memory?

  • 15 απαντήσεις
  • 3 έχουν αυτό το πρόβλημα
  • 3 προβολές
  • Τελευταία απάντηση από cor-el

more options

I'm running Firefox Quantum 57.0.3. Windows 7, 64 bit. 8GB Ram. I followed the instructions to do a clean install, deleting the old program files first, doing a disk cleanup, etc. AdBlock Plus is the only add on at the time I took the attached screen shot. Had 6 tabs open at the time, and nothing special, three of them just being gmail accounts. As you can see, that's an insane amount of memory, and 7 processes also seems ridiculous, but the amount of memory is the craziest thing. I've got the low memory warning a couple times lately, and with 8GB of RAM, and doing nothing special, and having a half dozen browser tabs open, that is just ludicrous. At the time I did this screen capture, it was using 90% of memory. Seems like I'm not alone. Any suggestions, other than stop using Firefox?

Thanks, in advance.

Συνημμένα στιγμιότυπα

Τροποποιήθηκε στις από το χρήστη acillatem

Όλες οι απαντήσεις (15)

more options

I checked the Prevent accessibility services from accessing your browser checkbox, and it's a little better, and memory usage is at 60%, give or take.

more options

go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Please let us know if this solved your issue or if need further assistance.

more options

I already have the Accessibility Services box checked. Look at the post above yours, and the attached screen shot. It made a little improvement, as you can see. What is the disadvantage of checking that box?

more options

It will reduce the amount of ram/cpu use as post states Accessibility is for persons with disabilities that need specific programs to connect as well touch devices would use it also. So there is no disadvantage by checking the box.

Note : Extensions can use 20+/- megs each. https://www.howtogeek.com/332449/whats-new-in-firefox-quantum/

2nd part reduces the number of cores Firefox can access, reduces cpu usage and ram. TEST the 3rd part for Hardware Acceleration will use less ram also if do not need to use it. TEST

Please let us know if this solved your issue or if need further assistance.

more options

After checking the accessibility services box, it is still at 70% usage, and the amount being used by Firefox is still ridiculous, as you can see.

I have one add on enabled....AdBlock Plus. That isn't the cause.

Won't the other two suggestions you made, slow down Firefox? If that's the case, it defeats the entire purpose, and I might as well not use it, which I'm already considering.

more options

81% right now. The amount being used by Firefox processes is absurd.

more options

your system details that you've submitted originally shows that you have two adblockers ( AdBlock 3.8.0 + Adblock Plus 3.0.2 ) enabled at the same time, which is a not a good idea and can cause issues.

perhaps you can try to refresh firefoxas well and see if this can address the issue...

more options

Well, thanks for pointing that out, and the only reason I didn't think much of it was, the description for AdBlock said something about being for Chrome....can't remember now, exactly what it said, but for some stupid reason, I was thinking it was a Chrome add on, but I'm in the Firefox add on list....duh! I removed it, and am now just running AdBlock Plus. Attached is a screen shot of the processes at the time of this post. 50% memory being used, so an improvement, so far. Less memory per process being used, not sure if it still seems excessive, would you know? Accessibility services box still checked, 6 tabs open, nothing taxing on any of them.

more options

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.

more options

Why should I have to do all that? Doesn't all that defeat the purpose of using Quantum in the first place, as it is faster than the previous version. Serious question, not being sarcastic.

Τροποποιήθηκε στις από το χρήστη acillatem

more options

PKshadow,

I am running Windows 7, 64-bit, and I've tried your suggestion of going "to the 3 bar menu then Options-->General-->Performance and untick everything". However, I tried changing the number of processes to 1, but Firefox keeps using 4 or 5 anyways. How do I get it to go back to using just one process in the task manager? I've attached a screenshot of it for you.

more options

Use 1 or the other : AdBlock 3.8.0 (jid1-NIfFY2CA8fy1tg@jetpack) Adblock Plus 3.0.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) Not both.

If still sticking around then : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 57.0.4 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

@Pkshadow I am only using Adblock Plus now, and had already done everything else that was suggested in your above post.

At the time of this post, 75% of memory being used, six tabs open, and nothing taxing at all on any of them, and still have 6 processes, and more memory than normal being used. See screen shot.

more options
more options

If you use Adblock Plus then you can consider uBlock Origin as a replacement to see if that works better (lower memory footprint).