Avatar for Username

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Oculus Rift not working with Firefox 57 and WebVR

  • 4 απαντήσεις
  • 8 έχουν αυτό το πρόβλημα
  • 2 προβολές
  • Τελευταία απάντηση από superjose

more options

Hi! Title says it all.

First and foremost: https://stackoverflow.com/questions/46259385/how-do-i-troubleshoot-oculus-in-firefox-webvr https://stackoverflow.com/questions/47324959/oculus-rift-fails-to-load-firefox https://stackoverflow.com/questions/47527100/oculus-rift-can-not-work-fine-with-firefox https://support.mozilla.org/en-US/questions/1175900

None of the above seem to help. In fact, the last one, I can't find that config in Firefox 57. What happens is that the web app seems to detect all the motion from the headset, but the headset will get stuck in home.

If I downgrade to Firefox 56, it works flawlessly.

Hi! Title says it all. First and foremost: https://stackoverflow.com/questions/46259385/how-do-i-troubleshoot-oculus-in-firefox-webvr https://stackoverflow.com/questions/47324959/oculus-rift-fails-to-load-firefox https://stackoverflow.com/questions/47527100/oculus-rift-can-not-work-fine-with-firefox https://support.mozilla.org/en-US/questions/1175900 None of the above seem to help. In fact, the last one, I can't find that config in Firefox 57. What happens is that the web app seems to detect all the motion from the headset, but the headset will get stuck in home. If I downgrade to Firefox 56, it works flawlessly.

Όλες οι απαντήσεις (4)

more options

Try the Help then About and see if Firefox has updated to 57.0.1 please .

If it has not shut down Firefox and restart then go to Help then About again and see if it forces the update.

Tell me what version your on.

In your "about:support" is "Multiprocess windows" set to "Enabled"? and under "Compositing" does it say "Direct3D 11"? and on that page is your WebGL drivers loaded?


ok from the previous post of who ever.

Copy/paste about:config into the Address Bar then Enter.

then under the Heading Compositing" does it say "Direct3D 11"? and on that page is your WebGL drivers loaded?

So , what's going on ?

more options

Pkshadow, updating to 57.0.1 fixed the issue, thanks! :D

more options

superjose said

Pkshadow, updating to 57.0.1 fixed the issue, thanks! :D

Wait. It did not fix the issue. The issue seems to come in whenever the Oculus App appears.

Making the Rift work, requires the following: 1) Exit both Oculus and Firefox. 2) Launch Firefox, and go to WebVR app. 3) Oculus will launch its app, and you'll be able to see WebVR.

Problem starts when: a) You exit a WebVR app, there's no way for you to come back in. b) If the app is already running, you can't enter back.

I have checked all the settings: Enabled Multiprocess Compositing Enabled

more options
  • Sigh* I honestly don't know which seems to be the problem, but it creeps in in Firefox 56 as well.

Temporary solution is to close Oculus app, and let Firefox reopen it (Which it will do automatically) when you launch a VR content.

Current Oculus App Version:

1.20.0.474906 (1.20.0.501061)