Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How can I get Firefox to stop sending a different IP address to my online banking web site every day?

  • 12 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 12 προβολές
  • Τελευταία απάντηση από dennisedds

more options

For the last week, my credit union has received a different IP address from Firefox each day. They had a software problem recently which deleted their file of IP addresses. Every day I tell their system to remember me on the computer I log in on after I answer a security question. I can log in multiple times that day without having to answer a security question. But the following day, it tells me this is a new PC/IP address requires a security question the first time I log in. Their records confirm they are getting a different IP address every day. How can I change this so I don't have to enter a security question every day.

All Replies (12)

more options

It usually works like this:

  • When you load a page on a site, Firefox sends the cookies the site had previously set
  • The site assesses whether those cookies identify you sufficiently based on other information related to your request (e.g., IP address) and may either let you in or may require additional authentication
  • After you authenticate again, the site sets a new cookie

It sounds as though this was all working fine until recently. Hopefully it's not that your cookies are getting cleared...


One possibility is a proxy server, private VPN service, Hola (or other peer-to-peer network), or Tor, all of which could send your requests through other computers of their choice.

To check your internal Firefox setting, open the Preferences page using either:

  • "3-bar" menu button (or Firefox menu) > Preferences
  • type or paste about:preferences in the address bar and press Return

In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button.

The "Auto-detect" setting is particularly prone to changeability. Try "No proxy" to see whether that helps.


This page shows the public information associated with your current IP address, which may help "reality check" that you are connecting to the site through your expected service provider:

https://www.iplocation.net/

(You don't need to share detailed location data with the site to get that information. If you get a request like that, just ignore it.)

more options

I changed the settings you suggested from Use system proxy settings to No proxy and am getting the same results. I didn't understand the information on the iplocation link you sent. Thanks for trying. If you have any other suggestions, please let me know

more options

Maybe it varies, but for me the https://www.iplocation.net/ page shows what several different services report about my IP address. The question is whether those make sense to you -- they fit your location and service provider -- or they don't make sense to you, in which case your network connection may be routed in a suspicious way.

more options

Don't know what any of this means.

more options

Here's an example screenshot of the IP Location page. The part I'm interested in having you check is the city and the ISP. Different services may have slightly different information, but in general, does that match your actual connection?

more options

The cities are all in my geographical area. 3 of the 4 ISPs are either AT&T Services or AT&T Internet services, which makes sense since I have DSL with them. The first one is PLTN13 internal, which means nothing to me. It's from Geolocation IP2Location, organization Not Available. My wife, who uses our co-op's WiFi is having the same problem, if than tells you anything. Thanks for spending so much time with this.

more options

When I search for "PLTN13 internal" it also seems to be associated with AT&T.

I was thinking of a home internet service where you get one address and it's very stable. If you are sharing service with others, possibly you have a pool of addresses that people could be cycled through. Is there a network administrator or similar person who could look into that?

more options

I connect to the internet via DSL on my phone. My wife uses the Wi-Fi. We've been using this configuration for years and never had this problem before.

more options

Usually DSL has a stable IP address, so I'm not sure what to suggest next. Did your bank indicate the different IP addresses your computer sent them? If they are all AT&T addresses local to your same area, I suspect it's something about your service. If they are not all AT&T addresses, or not all local to your area, I would be suspicious about a hijacked connection.

The site to check the owner of IP addresses in North America is ARIN:

http://whois.arin.net/ui/

more options

dennisedds said

I connect to the internet via DSL on my phone. My wife uses the Wi-Fi. We've been using this configuration for years and never had this problem before.

It might be that your bank increased its security and just recently started keeping track of each users IP address.

more options

No. They had a software glitch that wiped out the file of IP addresses, but logins should rebuild it. This has been going on every day for 2 weeks. Also my wife has the same problem but apparently it isn't general. The credit union's records show that it is receiving a different IP address from me every day. It works fine the second and subsequent times I log in, but the first time every day I have to answer a security question.

more options

I tried logging in with a different browser. Got the same result. I deleted the bookmark and logged in directly from Google. Got the same result. So it's clearly nothing to do with Mozilla. I doubt if it's AT&T, since it seems to be specific to me, so I'm going to take it up with Apple, unless you can think of a better way to go. I really appreciate your effort.