Search Support

Since the FF43 update I can no longer open more than a few tabs; after that I just get a blank screen.

  • 25 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 243 προβολές
  • Τελευταία απάντηση από XPSP3

more options

Firefox 43.0.1 is practically unusable, so I have been forced to migrate to Chrome.

FF43 seems to have finally gotten the memory usage problem under control, but with the price that Firefox is now unable to open more than 2 or 3 tabs before becoming unable to open any more. This happens when restoring a previous set of tabs. The first few tabs viewed open without any problems, but when I click over to the third or fourth one I start to see blank screens. After that nothing happens.

(I am using WinXP SP3. I am not using "Nvidia Forceware Network Access Manager." The past 20 versions of FF have all had memory overflow issues when many tabs were open, but they all remained usable. This version 43 is the first one which is basically unusable.)

Επιλεγμένη λύση

Conclusion: I tried downgrading to FF42 and FF41. I was able to retain all my settings. However, this did not resolve the problem. This clarified that while the problem may have somehow been triggered by the upgrade to FF43, it was likely NOT a problem with the FF43 software itself.

After that I set up a new profile as suggested by cor-el, and moved over the files mentioned here plus the sessionstore.js file. After starting up the new profile with the transferred profile data (but without the extensions), the failure to load problem disappeared. Running FF43 build 4 I was able to open 35 tabs without a problem. As a bonus, memory management does seem to be somewhat improved.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

All Replies (20)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Τροποποιήθηκε στις από το χρήστη FredMcD

more options

When using SafeMode the issue crops up later. In other words, it still exists, but occurs much more slowly - only after viewing approximately 15 tabs.

Τροποποιήθηκε στις από το χρήστη XPSP3

more options

Correction: The issue DOES still exist, but occurs much more slowly - only after viewing approximately 15 tabs. I edited the previous post to reflect this.

Τροποποιήθηκε στις από το χρήστη XPSP3

more options

If I click on the dropdown list to show all the tabs, the system displays "Connecting...." next to all the tabs which it cannot open. Given the low amount of memory in use (only 442,048K) I am guessing that there is simply not enough memory available to open more tabs. Prior to version 43 Firefox typically used around 800-900K of memory, and on occasion even over 1G of memory when many tabs were open.

more options

You can try updating to v43.0.3 Is the problem still there? Download Firefox For All languages And Systems v43* {web link}


Install an older version of Firefox {web link}

more options

Thanks for the above suggestion. According to my browser, 43.0.1 is the latest available version. According to the link you supplied above, 43.0.3 is available in theory, but when you actually attempt to download the 32 bit Windows version, regardless of which language I select, it says that the name of the file is "Firefox Setup 43.0.1.exe". Is this just mislabeled?

Or should I give the v44 beta a try?

more options

The link I posted gives you the current Firefox. But some reported issues may have pulled v43.0.3

As to what version you should download, you have to decide that yourself.

more options

I installed v44 beta 1. The problem seems to be less severe but still present; in total I can open approximately 15 tabs before it stops working.

more options

What security software do you have?

It is possible that your firewall or other security software blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to install for Firefox and the plugin-container process and the updater process.

See:

more options

I am using Webroot v9.0.6.14. I can turn off the Web Shield function, but did not notice any difference when doing so. I do not see any particular references to Firefox. I have been using Webroot for approximately 6 months, but this problem did not start until Firefox 43. Moreover, if it were caused by security software, why would this problem only crop up after opening a bunch of tabs??

more options

Firewall/Security-related issue?

Logically it does not seem likely to be linked to a firewall issue, because there is no particular website or URL which will not load. All of them can be viewed just fine; the problem is that Firefox does not support very many tabs any more. Let's say that I have 30 preexisting tabs upon starting the browser. As I click on them one by one, they load. When I get to approximately the 15th one, they stop loading. Instead I see only a blank screen - there is not even an error message. If I look at the dropdown list of tabs, I see "Connecting...".

Τροποποιήθηκε στις από το χρήστη XPSP3

more options

This sounds like an extension issue.

Did you test this in Safe Mode?


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

As discussed above, I did try in Safe Mode, The phenomenon also happens, though somewhat later than without using Safe Mode, presumably because the extensions eat up some of the available memory.

Since the problem also occurs in Safe Mode, how could it be linked to extensions?

It looks to me like the new Firefox, at least as running on this instance, cannot use more than 500,000K in memory. It's almost as if it were a cap. This is very different from before. Doesn't that look suspiciously like the source of the inability to load multiple tabs at the same time?

more options

You can check the about:memory page for memory usage and possibly try to free some memory via the "Free Memory" feature.

How much physical memory do you have installed on your computer?

more options

Installed memory (RAM): 4G

I clicked on "minimize memory". We'll see if that makes any difference.

more options

It made no difference. The problem is still the same.

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

OK. Hard to imagine why this might help, but I'll try it tomorrow morning.

more options

I started the computer in Safe Mode with Networking, as directed above. However, unfortunately in this mode Firefox will not start at all. You can click on the program and the process will appear in the Task Manager List, but the program never actually opens up.

more options

In most computers, there are several type of Safe Mode. The primary ones used most are;

  • Safe Mode: Only programs that came with the computer are started. No other programs will be started unless the user starts them.
  • Safe Mode with Networking: Same as above but the network drivers (internet) will also be running.

This is a way to test if one of the other programs on the computer is causing the issue.


If there is no network detected, Firefox may not respond. Are you sure you selected "with networking?"

I've called the big guys to help you. Good luck.

  1. 1
  2. 2