Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

When I click on "Show History" I completely lose the Firefox menu bar, I can't even quit the application without using a keyboard shortcut.

  • 3 απαντήσεις
  • 5 έχουν αυτό το πρόβλημα
  • 1 προβολή
  • Τελευταία απάντηση από Vuxi

more options

The question describes it all: when I select "Show History" the menu bar vanishes, so I have no means of navigating, there's no back arrow, nothing. I can quit Firefox, but only by using the Mac's keyboard shortcut. I can return to a previous window only by moving the history window, and I can close that previous window - there's a button for that-- but there is NOTHING that will allow me to change, or close, the history window. My only option is to quit the program.

Επιλεγμένη λύση

Both of your fixes helped. The first reminded me that I could simply use Command-W to close that library window, since it didn't show a "close" button. But your second reply about renaming those two files really did the trick of getting Firefox back to its old self once more. Now everything is back to normal. Thank you.

Ανάγνωση απάντησης σε πλαίσιο 👍 3

Όλες οι απαντήσεις (3)

more options

The problem is with "Show All History"? Normally that opens the Library dialog in a new window, so probably the new window is opening full screen in front of your previous window.

You usually can change a full screen window back to a regular window by pressing Command+Shift+F. Does that work in this case?

To close the Library dialog window you can use Command+W (keyboard shortcut for Close Tab) or try Command+Shift+W (keyboard shortcut for closing a window).

Do any of those help for the moment?


If this problem keeps recurring, it may indicate a corrupted data file. I'll be back in a second reply about what to do in that case.

more options

Sometimes the file that stores window dimensions becomes corrupted and uses nonsense values. Since the file is hard to edit, we generally suggest renaming the file and letter Firefox generate a new one using default values.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show in Finder" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Quit ( or is it under Firefox > Quit ?)

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Do windows display normally again?


Note: In this thread, the poster said that doesn't seem to work for everyone: "show all bookmarks" opens full screen and cannot be closed again.

more options

Επιλεγμένη λύση

Both of your fixes helped. The first reminded me that I could simply use Command-W to close that library window, since it didn't show a "close" button. But your second reply about renaming those two files really did the trick of getting Firefox back to its old self once more. Now everything is back to normal. Thank you.