Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Why doesn't it open with blank page (as I have set in Options) any more?

  • 5 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 108 προβολές
  • Τελευταία απάντηση από sharzah

more options

I have had my options set to "show a blank page" when Firefox starts. This has always worked fine until just recently... now it always reopens with whatever tabs/pages I had open at the time I last closed it. I checked and the option is still set properly. There was a similar report from someone who had changed to Windows 10, but I'm still at Windows 7. The other person didn't get a solution either. I'm at FF 41.0.1.

Επιλεγμένη λύση

One strangely common reason for this is that you have acquired an optional settings file named user.js in your profile folder (personal settings folder). Firefox uses the settings in that file at startup to override your saved preferences from the previous session. Unless you created that file yourself, you may want to delete it. The following support article has a section on how to check for it (skip over the Refresh suggestion): How to fix preferences that won't save.

Note: By default, Windows hides the .js extension. To ensure that you can find any user.js file and distinguish it from other files, you may want to turn off that feature. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Any luck?

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (5)

more options

Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display. Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want displayed.

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

more options

Επιλεγμένη λύση

One strangely common reason for this is that you have acquired an optional settings file named user.js in your profile folder (personal settings folder). Firefox uses the settings in that file at startup to override your saved preferences from the previous session. Unless you created that file yourself, you may want to delete it. The following support article has a section on how to check for it (skip over the Refresh suggestion): How to fix preferences that won't save.

Note: By default, Windows hides the .js extension. To ensure that you can find any user.js file and distinguish it from other files, you may want to turn off that feature. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Any luck?

more options

Thank you, jscher2000! There was a user.js there (dated the 11th, no idea what happened then that was unusual). Renamed it, and voila, back to my preferred settings.

more options

Is there more in the user.js file apart from a line that sets browser.sessionstore.resume_session_once to true?

more options

There were some blank lines and this: user_pref("browser.sessionstore.resume_session_once", true);

That's all.