X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

Unable to enable dark mode in Firefox 39.0 with about:config.

Δημοσιεύτηκε

After installing the Firefox Beta 39.0, i was unable to enable the dark mode through about:config.

This is what i have changed: browser.devedition.theme.enabled: true devtools.theme: dark lightweightThemes.selectedThemeID: firefox-devedition@mozilla.org

I am using "The Fox, Only Better" plugin, and i have disable it without luck.

After installing the Firefox Beta 39.0, i was unable to enable the dark mode through about:config. This is what i have changed: browser.devedition.theme.enabled: true devtools.theme: dark lightweightThemes.selectedThemeID: firefox-devedition@mozilla.org I am using "The Fox, Only Better" plugin, and i have disable it without luck.

Επιλεγμένη λύση

guigs2 said

Hi CiRiX, I understand that you are using a dark theme and have changed the settings in about:config, this may change the way that the enable/disable button works in the themes section of about:addons.. It is possible to reinstalled the extension, or try these troubleshooting steps:

I managed to fix it by clicking on enable then disable on another theme.

Thanks for your help!

Ανάγνωση απάντησης σε πλαίσιο 0

Επιπρόσθετες λεπτομέρειες συστήματος

Εγκατεστημένα αρθρώματα

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0

Εφαρμογή

  • Firefox 39.0
  • Πλατφόρμα χρήστη: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
  • URL υποστήριξης: https://support.mozilla.org/1/firefox/39.0/WINNT/en-GB/

Επεκτάσεις

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Greasemonkey 3.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • LastPass 3.1.1.1-signed (support@lastpass.com)
  • Stylish 2.0.2.1-signed ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • The Fox, Only Better 1.1.13.1-signed (thefoxonlybetter@quicksaver)

Javascript

  • incrementalGCEnabled: True

Γραφικά

  • adapterDescription: NVIDIA GeForce GTX TITAN
  • adapterDescription2:
  • adapterDeviceID: 0x1005
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 4095
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 5-27-2015
  • driverDate2:
  • driverVersion: 9.18.13.5306
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX TITAN Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Τροποποιημένες προτιμήσεις

Διάφορα

  • JS Χρήστη: Όχι
  • Προσβασιμότητα: Όχι
guigs 1072 λύσεις 11697 απαντήσεις
Δημοσιεύτηκε

Χρήσιμη απάντηση

Hi CiRiX, I understand that you are using a dark theme and have changed the settings in about:config, this may change the way that the enable/disable button works in the themes section of about:addons..

It is possible to reinstalled the extension, or try these troubleshooting steps:

Hi CiRiX, I understand that you are using a dark theme and have changed the settings in about:config, this may change the way that the enable/disable button works in the themes section of about:addons.. It is possible to reinstalled the extension, or try these troubleshooting steps: *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]
cor-el
  • Top 10 Contributor
  • Moderator
17876 λύσεις 161752 απαντήσεις
Δημοσιεύτηκε

You can possibly do this in the Toolbox options of the Developer toolbar (Shift+F2).

You can possibly do this in the Toolbox options of the Developer toolbar (Shift+F2). *https://developer.mozilla.org/Tools/Tools_Toolbox#Settings
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

guigs2 said

Hi CiRiX, I understand that you are using a dark theme and have changed the settings in about:config, this may change the way that the enable/disable button works in the themes section of about:addons.. It is possible to reinstalled the extension, or try these troubleshooting steps:

You get the theme by changing the settings in about config. You cant get it by going to the extention page. This is the same look as the Firefox Developer Edition Theme.

I have made this work in previous releases.

Check this: http://techdows.com/2015/01/firefox-35-how-to-enable-developer-editions-dark-theme.html

''guigs2 [[#answer-743095|said]]'' <blockquote> Hi CiRiX, I understand that you are using a dark theme and have changed the settings in about:config, this may change the way that the enable/disable button works in the themes section of about:addons.. It is possible to reinstalled the extension, or try these troubleshooting steps: *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] </blockquote> You get the theme by changing the settings in about config. You cant get it by going to the extention page. This is the same look as the Firefox Developer Edition Theme. I have made this work in previous releases. Check this: http://techdows.com/2015/01/firefox-35-how-to-enable-developer-editions-dark-theme.html

Τροποποιήθηκε στις από το χρήστη CiRiX

Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

cor-el said

You can possibly do this in the Toolbox options of the Developer toolbar (Shift+F2).

This only changes the theme of the Toolbox :/

''cor-el [[#answer-743097|said]]'' <blockquote> You can possibly do this in the Toolbox options of the Developer toolbar (Shift+F2). *https://developer.mozilla.org/Tools/Tools_Toolbox#Settings </blockquote> This only changes the theme of the Toolbox :/
cor-el
  • Top 10 Contributor
  • Moderator
17876 λύσεις 161752 απαντήσεις
Δημοσιεύτηκε

That changes the theme in the user interface as well when I select the Developer Edition theme in the Customize palette.

That changes the theme in the user interface as well when I select the Developer Edition theme in the Customize palette.
Δημοσιεύτηκε

Επιλεγμένη λύση

guigs2 said

Hi CiRiX, I understand that you are using a dark theme and have changed the settings in about:config, this may change the way that the enable/disable button works in the themes section of about:addons.. It is possible to reinstalled the extension, or try these troubleshooting steps:

I managed to fix it by clicking on enable then disable on another theme.

Thanks for your help!

''guigs2 [[#answer-743095|said]]'' <blockquote> Hi CiRiX, I understand that you are using a dark theme and have changed the settings in about:config, this may change the way that the enable/disable button works in the themes section of about:addons.. It is possible to reinstalled the extension, or try these troubleshooting steps: *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] </blockquote> I managed to fix it by clicking on enable then disable on another theme. Thanks for your help!