Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

While in fullscreen mode, my bookmarks toolbar disappears. Not just autohide, but vanishes completely until I exit fullscreen. Can I change this behavior?

  • 2 απαντήσεις
  • 10 έχουν αυτό το πρόβλημα
  • 507 προβολές
  • Τελευταία απάντηση από cor-el

more options

I like using fullscreen mode, and I like that the navigation and tab bar autohides. What I don't like is that my bookmark bar vanishes completely until I exit fullscreen mode. I'm attaching a quick screenshot I put together to illustrate my problem. Can anyone help?

The autohiding isn't the problem here (eg., I don't mind hovering over the top of my screen to get my tabs and such back), I just want to be able to access my bookmarks quickly while in fullscreen mode, without having to click into a bookmark manager.

Thanks in advance!

Edit: I installed this add-on that seems to keep my bookmarks bar around even when I am in fullscreen mode. It autohides everything the way it should, but when I hover over the top I get to see my nav bar, tab bar, and bookmarks bar. https://addons.mozilla.org/en-US/firefox/addon/fullscreen-toolbar-hover/?src=search

I like using fullscreen mode, and I like that the navigation and tab bar autohides. What I don't like is that my bookmark bar vanishes completely until I exit fullscreen mode. I'm attaching a quick screenshot I put together to illustrate my problem. Can anyone help? The autohiding isn't the problem here (eg., I don't mind hovering over the top of my screen to get my tabs and such back), I just want to be able to access my bookmarks quickly while in fullscreen mode, without having to click into a bookmark manager. Thanks in advance! Edit: I installed this add-on that seems to keep my bookmarks bar around even when I am in fullscreen mode. It autohides everything the way it should, but when I hover over the top I get to see my nav bar, tab bar, and bookmarks bar. https://addons.mozilla.org/en-US/firefox/addon/fullscreen-toolbar-hover/?src=search
Συνημμένα στιγμιότυπα

Τροποποιήθηκε στις από το χρήστη weretoad

Επιλεγμένη λύση

So... the add-on solves your problem, or you are looking for another approach?

Firefox allows you to apply custom style rules to modify the interface. In a little test, this rule worked for me:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#navigator-toolbox[inFullscreen] #PersonalToolbar{
  visibility: visible !important;
}

You can apply custom style rules to the interface using either:

Ανάγνωση απάντησης σε πλαίσιο 👍 3

Όλες οι απαντήσεις (2)

more options

Επιλεγμένη λύση

So... the add-on solves your problem, or you are looking for another approach?

Firefox allows you to apply custom style rules to modify the interface. In a little test, this rule worked for me:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#navigator-toolbox[inFullscreen] #PersonalToolbar{
  visibility: visible !important;
}

You can apply custom style rules to the interface using either:

more options

Another possible code is this code to the toolbar visible that are enabled in normal mode.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* full screen toolbars */
#navigator-toolbox[inFullscreen] toolbar:not([collapsed="true"]) {
 visibility:visible!important;
}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

You can use this button to go to the currently used Firefox profile folder:

Τροποποιήθηκε στις από το χρήστη cor-el