Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

mailto app isn't working

  • 37 απαντήσεις
  • 5 έχουν αυτό το πρόβλημα
  • 1527 προβολές
  • Τελευταία απάντηση από jscher2000

more options

when i click on an email my email opens which is ATT but its on yahoo server so my yahoo mail after it opens the email address that i clicked on doesn't appear in the TO space when i had this problem last time i posted on here but those steps didn't work this time by going into about:config changing the email to http://compose.mail.yahoo.com/?To=%s

Επιλεγμένη λύση

Here is a URL that should work, but it needs to be customized for your particular Yahoo mail server:

https://us-mg4.mail.yahoo.com/neo/launch?action=compose&To=%s

The bolded part needs to be edited to match your mailbox. Please try this:

(1) Select and copy the following line of script

navigator.registerProtocolHandler('mailto','https://us-mg4.mail.yahoo.com/neo/launch?action=compose&To=%s','Yahoo 2014'); 

(2) Open your Yahoo mail and then in that tab, open the Web Console using one of these methods:

  • Ctrl+Shift+k
  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools menu > Web Developer > Web Console

A small area should open below the current page.

(3) Paste the script next to the caret (>>) and edit the server address to match your specific mail server. This must match or Firefox will block the script.

Then press the Enter key to execute the script.

An infobar should open at the top of the page. Click "Add Application". You now can close the Web Console using any of the same methods you used for opening it.

If instead of an infobar the Web Console displays "Not allowed to register a protocol handler for mailto" then you may need to switch a setting in the about:config preference editor. More below the break.

(4) Test, for example: mailto:person@example.com

I see a long delay of what seems like 5 seconds or so before Yahoo displays the compose screen with that address. I don't know why it takes so long.

Success?


(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste mailto and pause while the list is filtered

(3) If the network.protocol-handler.external.mailto preference is bolded and "user set" to false, double-click it to switch it to true.

Ανάγνωση απάντησης σε πλαίσιο 👍 2

Όλες οι απαντήσεις (20)

more options

It seems they changed the link. I have the same problem now.

Six months ago, Yahoo was pushing an updated mailto handler to you if you didn't already have it: an infobar would appear below the toolbar area with an "Add Application" button. I can't seem to trigger that to appear again even after deleting my Yahoo entry from the list of possible mailto handlers and clearing my Yahoo cookies. Perhaps I'll have to exit and start Firefox up again to get offered the latest handler (but I can't do that at the moment).

more options

I did the update to firefox and it closed an reopened that didn't fix it

more options

I poked around in Yahoo mail and help for half an hour and couldn't find the solution. It's just gotten very complicated the way they do compose now... hopefully I'll discover something else but can't work on it now.

more options

will firefox fix this for the mailto app

more options

Is there an update on this? i'm still having the issue

more options

is anyone going to fix this where d i report this?

Τροποποιήθηκε στις από το χρήστη la321

more options

Επιλεγμένη λύση

Here is a URL that should work, but it needs to be customized for your particular Yahoo mail server:

https://us-mg4.mail.yahoo.com/neo/launch?action=compose&To=%s

The bolded part needs to be edited to match your mailbox. Please try this:

(1) Select and copy the following line of script

navigator.registerProtocolHandler('mailto','https://us-mg4.mail.yahoo.com/neo/launch?action=compose&To=%s','Yahoo 2014'); 

(2) Open your Yahoo mail and then in that tab, open the Web Console using one of these methods:

  • Ctrl+Shift+k
  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools menu > Web Developer > Web Console

A small area should open below the current page.

(3) Paste the script next to the caret (>>) and edit the server address to match your specific mail server. This must match or Firefox will block the script.

Then press the Enter key to execute the script.

An infobar should open at the top of the page. Click "Add Application". You now can close the Web Console using any of the same methods you used for opening it.

If instead of an infobar the Web Console displays "Not allowed to register a protocol handler for mailto" then you may need to switch a setting in the about:config preference editor. More below the break.

(4) Test, for example: mailto:person@example.com

I see a long delay of what seems like 5 seconds or so before Yahoo displays the compose screen with that address. I don't know why it takes so long.

Success?


(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste mailto and pause while the list is filtered

(3) If the network.protocol-handler.external.mailto preference is bolded and "user set" to false, double-click it to switch it to true.

more options

this is my edited script navigator.registerProtocolHandler('mailto','https://us-mg205.mail.yahoo.com/neo/launch?action=compose&To=%s','Yahoo 2014');

do i paste that into filter output?

more options

That would go into the line at the bottom of the Web Console that has a blue » at the beginning. It might look like a status bar, but it is part of the console. (Screen shot attached)

more options

Thank you!! that fixed my problem but yahoo still has a little lag on when it appears for it to load

more options

well it seems that stopped working the issue is back do i need to re-enter the steps again?

more options

What happens now, if anything?

I think there's no harm in adding the handler again.

You might check your Yahoo mail server address in case it changed.

more options

I entered navigator.registerProtocolHandler('mailto','https://us-mg205.mail.yahoo.com/neo/launch?action=compose&To=%s','Yahoo 2014'); into caret it says undefined DARLA notice :510 no element found nothing pops up

more options

What the... I don't know what that means, sorry.

What if you modify the server name, for example change the 205 to 206. I would expect a cross-domain error saying that this site can't add a handler for a different site. Does Firefox respond that way? If not, something could be disabled or broken with this feature.

more options

i got this message after changing it to 206 [Exception... "Permission denied to add https://us-mg206.mail.yahoo.com/neo/launch?action=compose&To=%s as a content or protocol handler'Permission denied to add https://us-mg206.mail.yahoo.com/neo/launch?action=compose&To=%s as a content or protocol handler' when calling method: [nsIWebContentHandlerRegistrar::registerProtocolHandler]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "JS frame :: debugger eval code :: <TOP_LEVEL> :: line 1" data: no]"

more options

Okay, so Firefox recognizes when site 1 tries to add a handler for site 2 and rejects it. It's not completely broken.

Unfortunately, I still can't sort out the DARLA notice error. If you switch back to using your actual mailbox URL, does it make any difference if you change the description from 'Yahoo 2014' to something else, in case Firefox is objecting to it as a duplicate?

more options

i changed it to yahoo 2015 i got DARLA 510 no element found

more options

this still hasn't been fixed in the last 2 updates to firefox

more options

when i pressed crtl shift k this was in it

"DARLA notice: 427" combo:1 "DARLA notice: 414" combo:1 "DARLA notice: 404" combo:1 "DARLA notice: 501" combo:1 "DARLA notice: 510" combo:1 "DARLA notice: 501" combo:1 "DARLA notice: 510" combo:1 "DARLA notice: 501" combo:1 "DARLA notice: 525" combo:1 "DARLA notice: 510" combo:1 "caughterror:..-build-mail-ui-mailpane-conv-convpaneread:4" combo:8 "caughterror:..-build-mail-ui-mailcompose-rte-rteview:1" combo:1 "DARLA notice: 510"

more options

I think the DARLA is a Yahoo script issue and not related to the email compose problem.

My more recent Yahoo broke too, but now an older one is working for me after a very long delay, like 7 seconds.

In order to add this, you'll have to temporarily relax the restriction on adding cross-domain applications. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste hand and pause while the list is filtered

(3) Double-click the gecko.handlerService.allowRegisterFromDifferentHost preference to temporarily switch it to true

(4) In your mail tab, add the new application using the web console as usual

navigator.registerProtocolHandler('mailto', 'https://compose.mail.yahoo.com/?To=%s', 'Yahoo Compose'); 

(5) Finally, back in about:config, double-click the gecko.handlerService.allowRegisterFromDifferentHost preference to switch it to false

  1. 1
  2. 2