Search Support

How do I totally remove Shockwave Flash 15.0.0152 from my Addons in Ubuntu 12.04?

  • 24 απαντήσεις
  • 12 έχουν αυτό το πρόβλημα
  • 22227 προβολές
  • Τελευταία απάντηση από benaround3

more options

How do I totally remove Shockwave Flash 15.0.0152. Using Ubuntu 12.04, FF 32.0.3. It seems that I have Shockwave Flash 11.2.202.406 installed also...How ???. When I disable SWF 15.xxx, it disables SWF 11.xxx also.

This was happening before I installed Chrome browser. Chrome is the only way I can use my computer without throwing thing about the room.

When I enable SWF 11.xxx, and leave SWF 15.xxx disabled, SWF turns on SWF 15.xxx. Seems these two versions are screwing up everything on my computer. Can't watch videos, FF goes gray screen and stuck, for 30 seconds, then recovers, then goes gray screen, then a message comes up "bad script -- Stop?", etc.,etc.

Lately when I am using T-bird email the screen goes gray and stops working.

Please help

Thanks SB

Επιλεγμένη λύση

The wrapper package is called 'freshplayerplugin' (without the quotes). That's all you need to get rid of.

Forget about uninstalling the Pepper Flash plugin itself, Chrome, or Chromium. None of that is relevant for Firefox without the wrapper being installed.

The article below describes very nicely how to install the Pepper Flash plugin support for Firefox. Basically do the steps in reverse order.

Last but not least, learn how to use the package management mechanism of your distribution to install or uninstall software packages. This can be either using CLI commands or via a graphical tool.

http://www.makeuseof.com/tag/how-to-get-chromes-latest-flash-player-to-work-in-firefox-on-linux/

Ανάγνωση απάντησης σε πλαίσιο 👍 2

All Replies (20)

more options

Hello,

It is pretty suspicious that you have Flash 15 in Ubuntu (unless I am misunderstanding you) - on Adobe's website (http://get.adobe.com/flashplayer/): NOTE: Adobe Flash Player 11.2 will be the last version to target Linux as a supported platform. Adobe will continue to provide security backports to Flash Player 11.2 for Linux.

Can you check your /usr/lib/mozilla/plugins/ folder to see if you have duplicate Flash plugins there? Another location to check is /usr/lib/adobe-flashplugin/

As for your Thunderbird question, try asking in that forum:

more options

Hello, thanks for the quick reply.

Where do I go to find " /usr/lib/mozilla/plugins/"? I did a search for that in my home folder and it just keeks running.

Thanks

more options

Sorry, a faster way of checking is by going into Firefox and entering about:plugins into the address bar:

It will show you the path of your plugins and you can find out where version 15 is coming from.

more options

Do you have a package 'freshplayerplugin' installed? If so, that most likely means you're using the latest Flash plugin built into Chrome also in Firefox.

In that case I'd just uninstall the Flash Player 11.2 package. If you have no clue how to do that, ask in an Ubuntu forum.

more options

Found something. here is a screenshot of pluginreg.dat.

It says do not edit at the top of page. I see SWF 15.xxx and SWF 11.xxx in there..

Thanks

more options

As expected. Uninstall Flash Player 11.2.

more options

I get the same info I think as my last message:

Thanks

more options

Both Flash plugin have a different installation path as you can see on the about:plugins page.

It is likely that both are installed via the software installation of your Ubuntu Linux distribution, so you need to check there.

more options

Based on your plugin directory and if you installed in the repositories, the package to remove is flashplugin-installer. As christ1 posted earlier, if you are unsure how to uninstall packages its better to ask the Ubuntu Forums how to do that.

more options

Firefox does not use the Pepper-based Flash Player Plugin that Google Chrome uses. Firefox uses the 11.2.202.406 flash plugin.

http://www.adobe.com/software/flash/about/

However it appears you have the libfreshwrapper-pepperflash.so which allows you to use the Pepper Flash which comes with Chrome on Firefox.

Τροποποιήθηκε στις από το χρήστη James

more options

Hi James,

I just removed "flashplugin-installer" via the terminal in Ubuntu. When I went to my plugins, the SWF 11.2.202.404 was gone, and SWF 15.0.0.152 is still there. Do I need to remove Chrome browser? I'm getting real lost in this...

What should I do to remove SWF 15.xxx and retrieve SWF 11.xxx?

Thanks

more options

Keeping Chrome should be fine - please see James' post again. Going back to your original post, does removing Flash 11.2 fix your problem with your browser stability and playing Flash videos? If it does, keep these settings and you're good to go!

more options

Hello.

Removing SWF 11.2 let's me play nothing if it is not on Youtube. On Youtube the videos are using HTML 5, it says when it can. See screen shot.

I'm trying to use all the messages I get from you in order. I'm older and sometimes it is hard to follow. Getting old ain't for sissy's.

Also I am enclosing another screenshot of my "pluginreg.dat" file.

So, I'm going to try cor-el's suggestion now.

Thanks to all for your help...

more options

I just looked at cor-el's suggestion, "http://www.webupd8.org/2014/05/fresh-player-plugin-pepper-flash.html." It says that it is alpha but not very good yet.

Is the above link the same thing I removed earlier, with "flashplugin-installer" ?

Thanks

more options

Can you check if that plugin is enabled in your about:addons > Plugins page?

The flashplugin-installer is maintained in the repositories and I believe that it just installs the latest Flash plugin from Adobe.

If pepperflash is enabled and not working for Firefox, you may need to ask in the Ubuntu forums how to disable it without affecting Chrome (may be as simple as just moving/renaming the file in Mozilla plugin directory, which you have from the plugin.reg file/about:plugins page). After doing so, you can reinstall flashplugin-installer to take care of your Flash videos again and hopefully then there won't be anymore conflicts.

more options

Been experimenting...

This morning I enabled SWF 15.x and went to different sites from my bookmarks. Almost immediately on my first bookmark stop the browser went gray and froze for almost 30 seconds. When that cleared a Warning message showed "Unresponsive Script". I clicked "Stop Script". Right after that the screen went gray again. When I was able to USE my computer, I went and disabled SWF 15.x.

Unubtu 12.04 runs great! Fast and responsive. No gray screens, and of course and no videos that are not run with HTML 5.

I believe I need to get rid of SWF 15.x and reinstall SWF 11.x...

Sound right?

Thanks for the help

more options

How do I purge Shockwave Flash 15.0.0.152 from my Firefox Plugins in Unubtu 12.04? Adobe forums have not answered this question in 3 days.

Thank You

more options

Did you install it from the repositories? It may be better to ask the Ubuntu Forums: http://ubuntuforums.org/

Try looking for packages such as "libfreshwrapper-pepperflash". However, ask in the Ubuntu Forums first whether you should remove it - if Chrome depends on it then you might accidentally uninstall Chrome as well.

more options

Hi coryMH,

I didn't install it from the repositories. I looked and there is no PPA for it. Ubuntu forums isn't working for me. Seems no one knows. I don't care if Chrome is removed, I only installed it so I could see the videos I couldn't see with flash 15.0.

This is what my pluginreg.dat looks like now.

What can I do??

Thanks

  1. 1
  2. 2