Αναζήτηση στην υποστήριξη

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Disable add-ons making web requests in the add-ons dialog

  • 1 απάντηση
  • 1 έχει αυτό το πρόβλημα
  • 5 προβολές
  • Τελευταία απάντηση από Gingerbread Man

more options

I found that when configuring add-on options in Firefox's add-ons dialog, many add-ons have a tendency to dynamically make HTTP web requests to fetch images and icons that are shown in the dialog. In most cases the fetches occur when looking at an add-on's options window, which will typically display logos or advertising images for the add-on. However, in some cases such as for the "Tilt 3D" add-on (https://addons.mozilla.org/en-US/firefox/addon/tilt/), the web requests occur even when merely viewing the list of add-ons.

This is a major privacy issue because a user should not be forced to make web requests every time he/she configures a program's options. This creates unnecessary web traffic and essentially allows add-on authors and websites to track each and every time a user configures his/her Firefox add-ons.

I didn't immediately find a relevant preference by looking at the list of about:config preferences. Is there a preference that would allow disabling an add-on from dynamically loading remote content just by the user making changes to their add-on settings?

If not, I would like to request on Bugzilla that this be disabled or "pref-guarded" (a user preference to be added). Every time Firefox makes involuntary web requests that the user can't control, user privacy is at stake. Doing this simply in the course of changing one's browser settings is a bad idea.

To be clear, I know that clicking on the "Get Add-ons" tab makes lots of web requests. But we should be able to simply avoid that tab and change settings of installed add-ons without being forced to make web requests.

Όλες οι απαντήσεις (1)

more options

a012 wrote:

I didn't immediately find a relevant preference by looking at the list of about:config preferences.
  1. Type about:config into the address bar and press Enter.
  2. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  3. In the search box, paste extensions.getAddons.cache.enabled
  4. In the search results, double-click extensions.getAddons.cache.enabled to set its value to false.

The following blog post has more details.

Τροποποιήθηκε στις από το χρήστη Gingerbread Man