Προβολή αρχείων PDF στο Firefox χωρίς να τα κατεβάσετε

Για να προβάλλετε αρχεία PDF μέσα στον περιηγητή Firefox, μπορείτε να χρησιμοποιήσετε το ενσωματωμένο Πρόγραμμα Προβολής Αρχείων PDF ή ένα πρόσθετο προγράμματος ανάγνωσης αρχείων PDF. Αυτό το άρθρο παραθέτει και τις δύο μεθόδους καθώς και τρόπους επίλυσης συνηθισμένων προβλημάτων που ίσως αντιμετωπίσετε.

Για να προβάλλετε αρχεία PDF μέσα στον περιηγητή Firefox, μπορείτε να χρησιμοποιήσετε το ενσωματωμένο Πρόγραμμα Προβολής PDF ή ένα πρόσθετο προγράμματος ανάγνωσης αρχείων PDF. Αυτό το άρθρο παραθέτει και τις δύο μεθόδους καθώς και τρόπους επίλυσης συνηθισμένων προβλημάτων που ίσως αντιμετωπίσετε.

Σημείωση: Η δυνατότητα προβολής αρχείων PDF είναι πλέον ενσωματωμένη στο Firefox. Ενημερώστε το Firefox για να αποκτήσετε τη δυνατότητα αυτή.

Χρήση του ενσωματωμένου Προγράμματος Προβολής Αρχείων PDF

Ο Firefox περιέχει, πλέον, ένα πρόγραμμα προβολής αρχείων PDF που σας επιτρέπει την προβολή σχεδόν όλων των αρχείων PDF που βρίσκονται στο Διαδίκτυο χωρίς την ανάγκη για ένα πρόσθετο. Η δυνατότητα αυτή είναι ενεργοποιημένη από προεπιλογή.

Χρήση της επέκτασης Προβολής Αρχείων PDF

Το PDF Viewer (γνωστό και ως pdf.js) είναι μια νέα, επαναστατική επέκταση που χρησιμοποιεί τις τυπικές τεχνολογίες του Διαδικτύου, επιτρέποντάς σας την προβολή σχεδόν όλων των αρχείων PDF που βρίσκονται στο Διαδίκτυο μέσα στο Firefox χωρίς κανένα πρόσθετο.

PDF JS

Αν έχετε εγκαταστήσει κάποιο πρόσθετο για ανάγνωση αρχείων PDF όπως το Adobe Reader, θα πρέπει να το απενεργοποιήσετε (όπως και κάθε άλλο παρόμοιο πρόσθετο) προκειμένου να λειτουργήσει η επέκταση προβολής αρχείων PDF.

  1. Στην κορυφή του παραθύρου του Firefox, κάντε κλικ στο κουμπί FirefoxΣτη γραμμή μενού, κάντε κλικ στο μενού ΕργαλείαΣτην κορυφή του παραθύρου του Firefox, κάντε κλικ στο μενού Εργαλεία, και έπειτα κάντε κλικ στο μενού Πρόσθετα. Η καρτέλα Διαχείριση προσθέτων θα ανοίξει. Κάντε κλικ στο κουμπί menu New Fx Menu και επιλέξτε Πρόσθετα. Η καρτέλα Διαχείριση προσθέτων θα ανοίξει.

  2. Στην καρτέλα Διαχείριση προσθέτων, επιλέξτε το πλαίσιο Plugins.
  3. Επιλέξτε κάθε πρόσθετο ανάγνωσης αρχείων PDF και κάντε κλικ στο κουμπί Απενεργοποίηση που βρίσκεται κοντά τους.

Λειτουργίες γραμμής εργαλείων του Προγράμματος Προβολής Αρχείων PDF

  • Προβολή μικρογραφιών ή περιγράμματος εγγράφου - Το κουμπί πλευρικής στήλης στα αριστερά θα ανοίξει μια πλευρική στήλη με μικρογραφίες των σελίδων του εγγράφου. Για κάποια έγγραφα, μια προβολή περιγράμματος θα είναι διαθέσιμη. Έτσι, η πλοήγηση μεταξύ των σελίδων ενός πολυσέλιδου εγγράφου γίνεται πιο εύκολη.

    PDF Thumbnails
  • Μετάβαση στην προηγούμενη/επόμενη σελίδα ή άμεση μετάβαση σε συγκεκριμένη σελίδα - Μπορείτε να χρησιμοποιήσετε τα βελάκια "πάνω" και "κάτω" για να πλοηγηθείτε μέσα σε ένα έγγραφο ή εισάγετε τον αριθμό της σελίδας στην οποία θέλετε να μεταβείτε.

    PDF Pager
  • Αλλαγή μεγέθους του εγγράφου - Χρησιμοποιήστε τα κουμπί + και - για μεγέθυνση και σμίκρυνση ή επιλέξτε μια ρύθμιση μεγέθους από την αναδιπλούμενη λίστα.

    PDF Zoom
  • Λειτουργία Πλήρους Οθόνης ή Λειτουργία Παρουσίασης - Κάντε κλικ στο κουμπί πλήρους οθόνης έτσι ώστε το αρχείο PDF να καλύψει όλη την οθόνη. Πατήστε το πλήκτρο ESC για βγείτε από τη λειτουργία πλήρους οθόνης.

    PDF Fullscreen
  • Εκτύπωση - Κάντε κλικ στο κουμπί Εκτύπωσης για ξεκινήσετε τη διαδικασία εκτύπωσης.

    PDF Print
  • Λήψη - Κάντε κλικ στο κουμπί Λήψης για να αποθηκεύσετε το αρχείο PDF στον υπολογιστή σας ή για να το ανοίξετε με ένα άλλο πρόγραμμα ανάγνωσης αρχείων PDF.

    PDF Download
  • Αντιγραφή τρέχουσας προβολής - Κάνετε δεξί κλικΚρατήστε πατημένο το πλήκτρο Ctrl ενώ κάνετε κλικ στο κουμπί Τρέχουσας Προβολής για να ανοίξετε το τρέχον έγγραφο σε μια άλλη καρτέλα ή παράθυρο.

    PDF Copy

Συντομεύσεις πληκτρολογίου για το Πρόγραμμα Προβολής Αρχείων PDF

Εντολή Συντόμευση
Επόμενη σελίδα n ή k ή
Προηγούμενη σελίδα p ή j ή
Μεγέθυνση Ctrl + +command + +
Σμίκρυνση Ctrl + -command + -
Αυτόματο Μέγεθος Ctrl + 0command + 0
Περιστροφή εγγράφου δεξιόστροφα r
Περιστροφή εγγράφου αριστερόστροφα Shift + r

Αντιμετώπιση προβλημάτων με το πρόγραμμα προβολής αρχείων PDF

Κάποια αρχεία PDF δεν απεικονίζονται σωστά ή είναι κενά

Με ορισμένους τύπους αρχείων PDF, το Πρόγραμμα Προβολής Αρχείων PDF ενδέχεται να αντιμετωπίσει προβλήματα με την απεικόνιση γραμματοσειρών, χρωμάτων ή ακόμη και όλου του εγγράφου. Για να προβάλλετε αυτά τα αρχεία:

  • Κάντε κλικ στο κουμπί λήψης στη δεξιά πλευρά, στο επάνω μέρος του εγγράφου για να το ανοίξετε με το προεπιλεγμένο πρόγραμμα προβολής PDF στον υπολογιστή σας.

Αδυναμία ανοίγματος οποιουδήποτε αρχείου PDF

Κάποιες επεκτάσεις που αποκλείουν το JavaScript ίσως εμποδίσουν τη λειτουργία του Προγράμματος Προβολής Αρχείων PDF. Μπορείτε να τις απενεργοποιήσετε για να επιτρέψετε τη λειτουργία του Προγράμματος Προβολής Αρχείων PDF:

  1. Στην κορυφή του παραθύρου του Firefox, κάντε κλικ στο κουμπί FirefoxΣτη γραμμή μενού, κάντε κλικ στο μενού ΕργαλείαΣτην κορυφή του παραθύρου του Firefox, κάντε κλικ στο μενού Εργαλεία, και έπειτα κάντε κλικ στο μενού Πρόσθετα. Η καρτέλα Διαχείριση προσθέτων θα ανοίξει. Κάντε κλικ στο κουμπί menu New Fx Menu και επιλέξτε Πρόσθετα. Η καρτέλα Διαχείριση προσθέτων θα ανοίξει.

  2. Στην καρτέλα Διαχείριση προσθέτων, επιλέξτε το πλαίσιο Extensions.
  3. Επιλέξτε κάθε επέκταση που αποκλείει το πρόγραμμα και κάντε κλικ στο κουμπί Απενεργοποίηση που βρίσκεται κοντά σε αυτές.

Για περισσότερες πληροφορίες, δείτε το Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.

Χρήση ενός προσθέτου ανάγνωσης αρχείων PDF

Αν δεν επιθυμείτε να χρησιμοποιήσετε το ενσωματωμένο Πρόγραμμα Προβολής Αρχείων PDF, μπορείτε να χρησιμοποιήσετε ένα πρόσθετο ανάγνωσης αρχείων PDF όπως το Adobe Reader, το Nitro PDF Reader ή το Sumatra PDFAdobe Reader, το MozPlugger, ή το πρόσθετο KPartsSchubert|it PDF Browser Plugin σε Mac OS X 10.6 ή νεότερο.

Για να αλλάξετε την επιλογή από το ενσωματωμένο πρόγραμμα προβολής αρχείων PDF στο πρόσθετο ανάγνωσης αρχείων PDF της επιλογής σας:

  1. Στην κορυφή του παραθύρου του Firefox, κάντε κλικ στο κουμπί Firefox και επιλέξτε ΕπιλογέςΣτην κορυφή του παραθύρου του Firefox, κάντε κλικ στο μενού Εργαλεία και επιλέξτε ΕπιλογέςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε Προτιμήσεις...Στην κορυφή του παραθύρου του Firefox, κάντε κλικ στο μενού Επεξεργασία και επιλέξτε Προτιμήσεις

    Κάντε κλικ στο κουμπί μενού New Fx Menu και επιλέξτε ΕπιλογέςΠροτιμήσεις

  2. Επιλέξτε την καρτέλα Εφαρμογές (Applications).
  3. Βρείτε το Portable Document Format (PDF) στη λίστα και κάντε κλικ σε αυτό για το επιλέξετε.
  4. Κάντε κλικ στο βελάκι στη στήλη Ενέργεια (Action) για την παραπάνω καταχώρηση και επιλέξτε Χρήση -Όνομα προγράμματος ανάγνωσης αρχείων PDF- (στο Firefox) (Use -Όνομα προγράμματος ανάγνωσης αρχείων PDF- (in Firefox)).

    Opening PDF - Win v2

Αν γίνεται λήψη των αρχείων PDF αντί για άνοιγμα, δοκιμάστε τα εξής

Αν γίνεται λήψη των αρχείων PDF αντί για προβολή, ελέγξτε τις ρυθμίσεις σας

  1. Στην κορυφή του παραθύρου του Firefox, κάντε κλικ στο κουμπί Firefox και επιλέξτε ΕπιλογέςΣτην κορυφή του παραθύρου του Firefox, κάντε κλικ στο μενού Εργαλεία και επιλέξτε ΕπιλογέςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε Προτιμήσεις...Στην κορυφή του παραθύρου του Firefox, κάντε κλικ στο μενού Επεξεργασία και επιλέξτε Προτιμήσεις

    Κάντε κλικ στο κουμπί μενού New Fx Menu και επιλέξτε ΕπιλογέςΠροτιμήσεις

  2. Επιλέξτε την καρτέλα Εφαρμογές (Applications).
  3. Βρείτε το Έγγραφο Adobe Acrobat (Adobe Acrobat Document) (αν χρησιμοποιείτε το Adobe Reader) ή Αρχεία PDF (PDF files) (για άλλα προγράμματα ανάγνωσης αρχείων PDF) στη λίστα και κάντε κλικ σε αυτό για το επιλέξετε.
  4. Κάντε κλικ στο βελάκι στη στήλη Ενέργεια (Action) για την παραπάνω καταχώρηση και επιλέξτε Χρήση -Όνομα προγράμματος ανάγνωσης αρχείων PDF- (στο Firefox) (Use -Όνομα προγράμματος ανάγνωσης αρχείων PDF- (in Firefox)).

    Opening PDF - Win
    • Αν το Χρήση -Όνομα προγράμματος ανάγνωσης αρχείων PDF- (στο Firefox) (Use -Όνομα προγράμματος ανάγνωσης αρχείων PDF- (in Firefox)) δεν βρίσκεται εκεί ως Επιλογή, δείτε το Επαναφορά ενεργειών λήψης παρακάτω και έπειτα, επαναλάβετε τη διαδικασία αυτή.
  5. Κάντε κλικ στο κουμπί OK για να κλείσετε το παράθυρο Επιλογές.Κάντε κλικ στο κουμπί Κλείσιμο για να κλείσετε το παράθυρο Προτιμήσεις.Κλείστε το παράθυρο Προτιμήσεις. Κλείστε την σελίδα about:preferences. Εάν έχετε κάνει αλλαγές θα αποθηκευτούν αυτόματα.

Επιπρόσθετες λύσεις

Επαναφορά ενεργειών λήψης

  1. Ανοίξτε τον φάκελο του προφίλ σας:

    Στο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο κουμπί Firefox , πηγαίνετε στο υπο-μενού ΒοήθειαΣτη γραμμή μενού, κάνετε κλικ στο μενού ΒοήθειαΣτο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο μενούΒοήθεια και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.Κάντε κλικ στο κουμπί μενού New Fx Menu , κάντε κλικ στο Βοήθεια Help-29 και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.

  2. Στην ενότητα Βασικά εφαρμογής κάνετε κλικ στο κουμπί Προβολή φακέλουShow in FinderΆνοιγμα καταλόγου. Ένα παράθυρο με τους φακέλουςφακέλους του προφίλ σας θα ανοίξει.
  3. Σημείωση: Εάν δεν μπορείτε να ανοίξετε ή να χρησιμοποιήσετε τον Firefox, ακολουθήστε τις οδηγίες στο Πως να βρείτε το φάκελο του προφίλ σας χωρίς να ανοίξετε το Firefox.

  4. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε το υπο-μενού ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε το υπο-μενού ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε το υπο-μενού Quit FirefoxΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος

    Κάντε κλικ στο κουμπί μενού New Fx Menu και μετά κάντε κλικ στο ΈξοδοςΈξοδος Close 29

  5. Διαγράψτε το αρχείο mimetypes.rdf.

Έλεγχος ρυθμίσεων εφαρμογής

Αν το πρόσθετο ανάγνωσης αρχείων PDF συνοδεύεται από μια εφαρμογή ανάγνωσης, ελέγξτε τις ρυθμίσεις του προσθέτου εφαρμογής, εάν υπάρχουν.

  • Adobe Reader:
    1. Ανοίξτε το Adobe Reader.
    2. Μόλις ανοίξει το Adobe Reader, κάντε κλικ στο μενού Επεξεργασία (Edit) στη γραμμή μενού και έπειτα, κάντε κλικ στο Προτιμήσεις... (Preferences...). Το παράθυρο Προτιμήσεις θα ανοίξει.
    3. Στην ενότητα Κατηγορίες (Categories), κάντε κλικ στο Διαδίκτυο (Internet).
    4. Βεβαιωθείτε ότι το πρώτο κουτάκι, Προβολή αρχείων PDF στον περιηγητή (Display PDF in browser), είναι επιλεγμένο.
    5. Κάντε κλικ στο OK για να κλείσετε το παράθυρο Προτιμήσεις και έπειτα, κλείστε το Adobe Reader.

Αν ακόμη δεν μπορείτε να προβάλλετε ένα αρχείο PDF στο Firefox, συνεχίστε με τις ακόλουθες οδηγίες.

Επανεκκίνηση της βάσης δεδομένων προσθέτων

Ακολουθήστε τις οδηγίες στο Επανεκκίνηση της βάσης δεδομένων προσθέτων.

Αυτό θα αναγκάσει το Firefox να δημιουργήσει εκ νέου την βάση δεδομένων των προσθέτων του. Αν ακόμη δεν μπορείτε να προβάλλετε ένα αρχείο PDF στο Firefox, συνεχίστε με τις ακόλουθες οδηγίες.

Επανεγκατάσταση της εφαρμογής

Αν το πρόσθετο ανάγνωσης αρχείων PDF συνοδεύεται από μια εφαρμογή ανάγνωσης και οι παραπάνω μέθοδοι αντιμετώπισης προβλημάτων για το Firefox δε λειτούργησαν, απεγκαταστήστε και εγκαταστήστε εκ νέου την εφαρμογή.

Αν ακόμη δεν μπορείτε να προβάλλετε ένα αρχείο PDF στο Firefox, συνεχίστε με τις ακόλουθες οδηγίες.

Περισσότερες πληροφορίες για το Adobe Reader

Αν δε λειτούργησε καμία από τις παραπάνω μεθόδους αντιμετώπισης προβλημάτων, δείτε το Αδυναμία προβολής αρχείων PDF στον Διαδίκτυο από το Adobe.com για περισσότερες οδηγίες.

 


Share this article: http://mzl.la/1BAQIvG

Was this article helpful? Please wait...

These fine people helped write this article: JimSp472. You can help too - find out how.