Το πρόσθετο Adobe Flash κατέρρευσε - Πώς να μην ξανασυμβεί | Troubleshooting

Το πρόσθετο Adobe Flash κατέρρευσε - Πώς να μην ξανασυμβεί

Το μήνυμα "Το πρόσθετο Adobe Flash κατέρρευσε", εμφανίζεται όταν το πρόσθετο Flash σταματά να λειτουργεί απροσδόκητα. Η επαναφόρτωση της σελίδας συνήθως θα κάνει το βίντεο, το παιχνίδι ή τα εφέ κίνησης (animation) να λειτουργήσουν ξανά.

Plugin crash notification Fx21

Εάν το πρόσθετο Flash συνεχίζει να καταρρέει, η ενημέρωση στην πιο πρόσφατη έκδοση του Flash ίσως λύσει το ζήτημα. Αυτό το άρθρο εξηγεί πως να ενημερώσετε το Flash και άλλες πιθανές λύσεις.

Ενημέρωση Flash

Η πιο πρόσφατη έκδοση του πρόσθετου Flash θα πρέπει να έχει καλύτερη απόδοση και να καταρρέει λιγότερο συχνά. Για να ελέγξετε αν το Flash είναι ενημερωμένο, επισκεφθείτε τη σελίδα Έλεγχος πρόσθετων λειτουργιών της Mozilla. Αν λέει ότι το Flash απαιτεί ενημέρωση, εγκαταστήστε την πιο πρόσφατη έκδοση χειροκίνητα ακολουθώντας τα παρακάτω βήματα.

  1. Μεταβείτε στη σελίδα λήψης του Flash Player της Adobe και κατεβάστε το πρόγραμμα εγκατάστασης του Flash.
    Προσοχή: Η σελίδα λήψεων της Adobe ενδέχεται να περιέχει ένα κουτί επιλογής για προαιρετικό λογισμικό (όπως το Google Chrome ή το McAfee Security Scan) που είναι ήδη επιλεγμένο. Αν δεν από-επιλέξετε το κουτί επιλογής πριν τη λήψη, αυτό το λογισμικό θα εγκατασταθεί στον υπολογιστή σας όταν ανοίξετε το πρόγραμμα εγκατάστασης του Flash.
  2. Όταν ολοκληρωθεί η λήψη, κλείστε το Firefox.

    Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε Quit Firefox (Έξοδος από το Firefox)Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος.

    Κάντε κλικ στο κουμπί του μενού New Fx Menu και, έπειτα, κάντε κλικ στο ΈξοδοςΈξοδος Close 29 .

  3. Ανοίξτε το αρχείο του προγράμματος εγκατάστασης του Flash που κατεβάσατε και ακολουθήστε τις οδηγίες.
Σημείωση: Αν αντιμετωπίζετε προβλήματα με το πρόγραμμα εγκατάστασης του Flash από τη σελίδα λήψεων της Adobe, μπορείτε να χρησιμοποιήσετε αυτό το σύνδεσμο για το πρόγραμμα εγκατάστασης του Flash Player για άμεση λήψη του πλήρους προγράμματος εγκατάστασης.
  1. Μεταβείτε στη σελίδα λήψης του Flash Player της Adobe και κατεβάστε το πρόγραμμα εγκατάστασης του Flash.
  2. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε Quit Firefox (Έξοδος από το Firefox)Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος.

    Κάντε κλικ στο κουμπί του μενού New Fx Menu και, έπειτα, κάντε κλικ στο ΈξοδοςΈξοδος Close 29 .

  3. Ανοίξτε το αρχείο που κατεβάσατε (π.χ. install_flash_player_osx_intel.dmg).
  4. Στο Finder, ανοίξτε το Install Adobe Flash Player.app για να εκτελέσετε το πρόγραμμα εγκατάστασης και έπειτα, ακολουθήστε τις οδηγίες του προγράμματος εγκατάστασης.
  1. Μεταβείτε στη σελίδα λήψης του Flash Player της Adobe.
  2. Όταν σας ζητηθεί, αποθηκεύστε το αρχείο (π.χ. install_flash_player_"version"_linux."processor".tar.gz).
  3. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε Quit Firefox (Έξοδος από το Firefox)Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος.

    Κάντε κλικ στο κουμπί του μενού New Fx Menu και, έπειτα, κάντε κλικ στο ΈξοδοςΈξοδος Close 29 .

  4. Ανοίξτε ένα παράθυρο Τερματικού (στο Gnome, κάντε κλικ στο μενού Εφαρμογές (Applications), επιλέξτε Βοηθήματα (Accessories) και, τέλος, επιλέξτε Τερματικό (Terminal.)
  5. Στο παράθυρο Τερματικού, αλλάξτε τον κατάλογο στην τοποθεσία όπου αποθηκεύσατε το αρχείο που κατεβάσατε (π.χ. cd /home/user/Λήψεις).
  6. Κάντε εξαγωγή του libflashplayer.so από το αρχείο που κατεβάσατε με την εντολή tar -zxvf install_flash_player_"version"_linux."processor".tar.gz.
  7. Ως υπέρ-χρήστης (super user), αντιγράψτε το εξαγόμενο αρχείο, libflashplayer.so, στον υπό-κατάλογο plugins του καταλόγου εγκατάστασης του Firefox. Για παράδειγμα, αν το Firefox είναι εγκατεστημένο στο /usr/lib/mozilla, χρησιμοποιήστε την εντολή sudo cp libflashplayer.so /usr/lib/mozilla/plugins και έπειτα, εισάγετε τον κωδικό πρόσβασης υπέρ-χρήστη (super user) όταν σας ζητηθεί.

    0a85171f1802a3b0d9f46ffb997ddc02-1260326970-447-1.png

Απενεργοποίηση επιτάχυνσης υλικού (hardware acceleration) στο Flash

Πολλά προβλήματα στο Flash μπορούν να λυθούν απενεργοποιώντας την επιτάχυνση υλικού στις ρυθμίσεις του Flash Player (η σελίδα Flash Player Help - Display Settings της Adobe έχει λεπτομέρειες). Για να απενεργοποιήσετε την επιτάχυνση υλικού στο Flash:

  1. Πηγαίνετε στη σελίδα βοήθειας του Adobe Flash Player.
  2. Κάνετε δεξί κλικΚρατήστε πατημένο το πλήκτρο Ctrl ενώ κάνετε κλικ πάνω στο λογότυπο του Flash Player, κάντε κλικ στο Settings στο πλαίσιο που θα ανοίξει. Η οθόνη-παράθυρο Settings του Adobe Flash Player θα ανοίξει στη οθόνη σας.
  3. Κάντε κλικ στο κάτω-αριστερό εικονίδιο του Adobe Flash Player Settings παραθύρου για να ανοίξετε το πίνακα Display.
  4. Αφαιρέστε το σημάδι [ν] από το Enable hardware acceleration.

    fpSettings1.PNG
  5. Κάντε κλικ στο Close για να κλείσετε το παράθυρο του Adobe Flash Player Settings.
  6. Επανεκκινήστε το Firefox.

Απενεργοποίηση προστατευμένης λειτουργίας Flash

Σημαντικό: Η ακόλουθη λύση δεν ισχύει για τη νέα έκδοση 64-bit του Firefox για τα λειτουργικά συστήματα Windows 64-bit.

Η προστατευμένη λειτουργία της Adobe μπορεί να προκαλέσει "παγώματα" ή καταρρεύσεις του προσθέτου για μερικούς χρήστες. Για να την απενεργοποιήσετε, δείτε τις οδηγίες της Adobe κάτω από την επικεφαλίδα "Last Resort" ("Έσχατη Λύση"): Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Η προστατευμένη λειτουργία του Flash μπορεί να προκαλέσει "παγώματα" ή καταρρεύσεις του προσθέτου για μερικούς χρήστες. Για να την απενεργοποιήσετε, ακολουθήστε αυτά τα βήματα:
Προειδοποίηση: Η προστατευμένη λειτουργία είναι μια λειτουργία ασφαλείας του Adobe Flash που είναι ενεργοποιημένη από προεπιλογή. Η απενεργοποίηση της προστατευμένης λειτουργίας του Flash απενεργοποιεί μια προστασία ασφαλείας.
  1. Στη γραμμή διευθύνσεων, πληκτρολογήστε το about:config και πατήστε EnterReturn.

    • Ενδέχεται να εμφανιστεί η σελίδα προειδοποίησης του about:config "Προσοχή! Μπορεί να ακυρώσετε την εγγύηση του προϊόντος". Κάντε κλικ στο Θα προσέχω, Το υπόσχομαι!I accept the risk! (Αποδέχομαι τον κίνδυνο!) για συνέχεια στη σελίδα about:config.
  2. Αναζητήστε το dom.ipc.plugins.flash.disable-protected-mode στη λίστα προτιμήσεων.
  3. Κάντε διπλό κλικ στην προτίμηση για να αλλάξετε την τιμή της από false σε true. (Αν η ρύθμιση είναι ήδη στο true, σημαίνει ότι η προστατευμένη λειτουργία του Flash είναι απενεργοποιημένη αυτή τη στιγμή.)
  4. Κάντε κλικ στο κουμπί του μενού New Fx Menu και έπειτα, κάντε κλικ στο Έξοδος Close 29 για πλήρες κλείσιμο του Firefox, ώστε να εφαρμοστεί η αλλαγή.
  5. Επανεκκινήστε το Firefox.

Η προστατευμένη λειτουργία του Flash μπορεί να προκαλέσει "παγώματα" ή καταρρεύσεις του προσθέτου για μερικούς χρήστες. Για να την απενεργοποιήσετε, δείτε τις οδηγίες της Adobe κάτω από την επικεφαλίδα "Last Resort" ("Έσχατη Λύση"): Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Η προστατευμένη λειτουργία του Flash της Adobe μπορεί να προκαλέσει "παγώματα" ή καταρρεύσεις του προσθέτου για μερικούς χρήστες. Για να την απενεργοποιήσετε, ακολουθήστε αυτά τα βήματα:
Προειδοποίηση: Η προστατευμένη λειτουργία είναι μια λειτουργία ασφαλείας του Adobe Flash που είναι ενεργοποιημένη από προεπιλογή. Η απενεργοποίηση της προστατευμένης λειτουργίας του Flash απενεργοποιεί μια προστασία ασφαλείας.
  1. Στη γραμμή διευθύνσεων, πληκτρολογήστε το about:config και πατήστε EnterReturn.

    • Ενδέχεται να εμφανιστεί η σελίδα προειδοποίησης του about:config "Προσοχή! Μπορεί να ακυρώσετε την εγγύηση του προϊόντος". Κάντε κλικ στο Θα προσέχω, Το υπόσχομαι!I accept the risk! (Αποδέχομαι τον κίνδυνο!) για συνέχεια στη σελίδα about:config.
  2. Αναζητήστε το dom.ipc.plugins.flash.disable-protected-mode στη λίστα προτιμήσεων.
  3. Κάντε διπλό κλικ στην προτίμηση για να αλλάξετε την τιμή της από false σε true. (Αν η ρύθμιση είναι ήδη στο true, σημαίνει ότι η προστατευμένη λειτουργία του Flash είναι απενεργοποιημένη αυτή τη στιγμή.)
  4. Κάντε κλικ στο κουμπί του μενού New Fx Menu και έπειτα, κάντε κλικ στο Έξοδος Close 29 για πλήρες κλείσιμο του Firefox, ώστε να εφαρμοστεί η αλλαγή.
  5. Επανεκκινήστε το Firefox.
Η προστατευμένη λειτουργία του Flash της Adobe μπορεί να προκαλέσει "παγώματα" ή καταρρεύσεις του προσθέτου για μερικούς χρήστες. Για να την απενεργοποιήσετε, ακολουθήστε αυτά τα βήματα:
Προειδοποίηση: Η προστατευμένη λειτουργία είναι μια λειτουργία ασφαλείας του Adobe Flash που είναι ενεργοποιημένη από προεπιλογή. Η απενεργοποίηση της προστατευμένης λειτουργίας του Flash απενεργοποιεί μια προστασία ασφαλείας.
  1. Στην κορυφή του παραθύρου του Firefox, κάντε κλικ στο κουμπί FirefoxΣτη γραμμή μενού, κάντε κλικ στο μενού ΕργαλείαΣτην κορυφή του παραθύρου του Firefox, κάντε κλικ στο μενού Εργαλεία, και έπειτα κάντε κλικ στο μενού Πρόσθετα. Η καρτέλα Διαχείριση προσθέτων θα ανοίξει. Κάντε κλικ στο κουμπί menu New Fx Menu και επιλέξτε Πρόσθετα. Η καρτέλα Διαχείριση προσθέτων θα ανοίξει.

  2. Στην καρτέλα Διαχείριση προσθέτων, επιλέξτε το πλαίσιο Πρόσθετες λειτουργίες.
  3. Βρείτε το Shockwave Flash στη λίστα προσθέτων και κάντε κλικ στο κουμπί Επιλογές.
  4. Αφαιρέστε το τικ από το Enable Adobe Flash protected mode (Ενεργοποίηση προστατευμένης λειτουργίας του Adobe Flash).
    Fx38-UI-AdobeFlash-protected-mode
    Σημείωση: Για να μάθετε περισσότερα, δείτε το άρθρο Προστατευόμενη λειτουργία του Adobe Flash στο Firefox.
  5. Κάντε κλικ στο κουμπί του μενού New Fx Menu και έπειτα, κάντε κλικ στο Έξοδος Close 29 για πλήρες κλείσιμο του Firefox, ώστε να εφαρμοστεί η αλλαγή.
  6. Επανεκκινήστε το Firefox.

Άλλες λύσεις

Was this article helpful?

Please wait...

These fine people helped write this article: AnonymousUser, ideato, user832823, JimSp472. You can help too - find out how.

Last Update: 2016-06-11

Get support for another platform:
Customize this article

Firefox