Wo le biabia siwo wotag la fiam: Fia biabiawo katã

ServiceWorker won't register and crash with TypeError when using import

Hello all, I'm building a website which uses a `ServiceWorker`. This worker uses `import` to load another JS module. As far as I understand, this should be possible star… (xle nububuwo)

Hello all,

I'm building a website which uses a `ServiceWorker`. This worker uses `import` to load another JS module. As far as I understand, this should be possible starting Firefox 114 (https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Statements/import#browser_compatibility). However, it's crashing with an `TypeError: ServiceWorker script at https://localhost:9292/sw.js for scope https://localhost:9292/ threw an exception during script evaluation`. The worker script is loaded as module using `navigator.serviceWorker.register('./sw.js', { type: "module" })`, and working on Safari and Chrome as expected. When I remove the `import`, the worker loads and works. Tested on Firefox 118, 119, 120.

Here is a full sample: https://gist.github.com/fnordfish/9b38b90fba54093ee601887a3bd3e11e

I can't find any related bug in Bugzilla or anywhere else. Which makes me wonder what I am missing.

PS: Non module `importScripts` work.

Asked by Robert 1 ŋkeke si va yi

Requesting access to the memory dump from my Firefox Nightly crash.

Very recently, I was typing a ton of content into a website textarea, when my Firefox Nightly install crashed. I lost all of this work from hours. Is there any way to g… (xle nububuwo)

Very recently, I was typing a ton of content into a website textarea, when my Firefox Nightly install crashed. I lost all of this work from hours. Is there any way to get access to this data?

Asked by michaelfgarofalo 1 ŋkeke si va yi

Firefox can't apply update!

Since 117(Beta)I have an issue with Firefox refusing to apply the update it downloaded. I've tried searching left and right on the internet for a solution and one does wo… (xle nububuwo)

Since 117(Beta)I have an issue with Firefox refusing to apply the update it downloaded. I've tried searching left and right on the internet for a solution and one does work which is installing the newer version of the browser each time myself. But this is ofcourse not a solution in the long run.

It tries now to apply the update 118b9 to stable version 118 and it did downloaded just fine and asked me if I wanted to close the program to let it update which always worked. I've tried different DNS to see if that could be the problem, tried a clean default profile to see if that helped, I haven't tried uninstalling it and reinstalling it, due to me losing my passwords and what not.

I also tried to run the stable version to see if the issue was still there and it is still there, so me using the beta channel isn't the issue here.

Asked by TSVStriFe 1 kwasiɖa si va yi

Last reply by TSVStriFe 3 ŋkeke siwo va yi