Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On loading, Firefox no longer takes me to iGoogle (signed in) as my homepage - how do I fix this.

  • 3 ŋuɖoɖowo
  • 11 masɔmasɔ sia le wosi
  • 6 views
  • Nuɖoɖo mlɔetɔ cor-el

more options

I use two browsers, Safari for my iGoogle homepage and GMail and Firefox for my wife's iGoogle and Gmail. Both used to come up signed in to the specified homepage and Gmail accounts (except for an infrequent request to sign in again). Now Firefox has stopped doing so, always requiring signing in.

All Replies (3)

more options
  • Websites remembering you and automatically log you in is stored in a cookie.
  • You need an allow cookie exception (Firefox > Preferences > Privacy > Cookies: Exceptions) to keep that cookie, especially for secure websites and if you let cookies expire when Firefox closes
  • Make sure that you do not use Delete browsing, search and download history on Firefox to clear the "Cookies" and the "Site Preferences"
  • Make sure that you not run Firefox in (permanent) Private Browsing - Use Firefox without saving history mode
  • You enter Private Browsing mode if you select: Firefox > Preferences > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Firefox > Preferences > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"
more options

I have tried all of this. I have cleared my browsing history, and it will work once or twice, but then stops. I have set it to allow all Google cookies. I still have the problem. The odd thing is that, while Firefox asks me to log into iGoogle, it remembers my cookies for Gmail. If I go to Gmail, and then click on my home button, it takes me to iGoogle logged in. This must have something to do with Firefox's start up, right? All of my browsing history and cookies are present for my new browsing history except that one- for the start up only. In addition, I was just having trouble with it on my computer with XP and not my netbook with W7. But all of a sudden, I am having the problem with my netbook as well. I just don't understand it and would love a solution to it. If I downloaded Firefox 4 beta, would the problem stop?

more options

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.
Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete cookies.sqlite-journal and cookies.txt, if they exist, in the Profile Folder in case the file cookies.sqlite got corrupted.