Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address bar suggestions suddenly wrong

  • 4 ŋuɖoɖowo
  • 1 masɔmasɔ sia le esi
  • Nuɖoɖo mlɔetɔ zeroknight

more options

As of an hour ago suddenly all of the usual suggestions and autofill with bookmarks in my address bar are wrong and out of order. I didn't close out of or update Firefox, I was just browsing online. I didn't change anything in my settings or have opened that up in days at the minimum. I cannot figure out how to either revert back or tell Firefox to not show me these choices so I can get my old ones.

I'll give an example: When I typed in "ma" it would show me mangadex.com, which I often go to. Now when I do it not only is 5th on the list it shows up and fills in "https://www.manticgames.com/", which I don't have that specific page bookmarked. I have "https://www.manticgames.com/games/kings-of-war/" bookmarked, but not that homepage. But now all of a sudden it is showing me the homepage of that site when I begin to type in "ma".

This is incredibly irritating and I have no idea why it's doing this at me out of nowhere. I don't want about anything showing up besides my bookmarks and specifically only the pages I bookmarked.

As of an hour ago suddenly all of the usual suggestions and autofill with bookmarks in my address bar are wrong and out of order. I didn't close out of or update Firefox, I was just browsing online. I didn't change anything in my settings or have opened that up in days at the minimum. I cannot figure out how to either revert back or tell Firefox to not show me these choices so I can get my old ones. I'll give an example: When I typed in "ma" it would show me mangadex.com, which I often go to. Now when I do it not only is 5th on the list it shows up and fills in "https://www.manticgames.com/", which I don't have that specific page bookmarked. I have "https://www.manticgames.com/games/kings-of-war/" bookmarked, but not that homepage. But now all of a sudden it is showing me the homepage of that site when I begin to type in "ma". This is incredibly irritating and I have no idea why it's doing this at me out of nowhere. I don't want about anything showing up besides my bookmarks and ''specifically'' only the pages I bookmarked.

Ŋuɖoɖo si wotia

Make sure you don't clear history if you want autofill to work better.

Autofill is expected to fill the base domain for bookmarks rather than the full URL. Changing browser.urlbar.autoFill.adaptiveHistory.enabled to true in about:config may fill full URLs in some cases.

Prioritize bookmarks by changing places.frecency.bookmarkVisitBonus and places.frecency.unvisitedBookmarkBonus to 2000.

Add "ma" as a keyword for the bookmark to guarantee the full URL autofills when "ma" is typed in the address bar.

Xle ŋuɖoɖo sia le goya me 👍 1

All Replies (4)

more options

Ɖɔɖɔɖo si wotia

Make sure you don't clear history if you want autofill to work better.

Autofill is expected to fill the base domain for bookmarks rather than the full URL. Changing browser.urlbar.autoFill.adaptiveHistory.enabled to true in about:config may fill full URLs in some cases.

Prioritize bookmarks by changing places.frecency.bookmarkVisitBonus and places.frecency.unvisitedBookmarkBonus to 2000.

Add "ma" as a keyword for the bookmark to guarantee the full URL autofills when "ma" is typed in the address bar.

more options

I didn't touch my history from how I had it set up however long ago but this seemed to fix most of it, thank you.

more options

Unfortunately, following the steps above did not work for me. The only work around I've found is to delete old bookmarks that are similar to the one I want to autocomplete, but that is time consuming and I may not want to delete all of those bookmarks. Unless my bookmarks file is too big or the file used to prioritize certain things to autocomplete over others is corrupt (no clue how to check either of those theories other than re-installing), I've no clue what would cause this issue all of a sudden. It's very odd and annoying.

more options

kevin.g.greenhaw said

old bookmarks that are similar to the one I want to autocomplete

I only see this when there is no browser history, make sure it is not being cleared or the browser is not in private browsing mode (aka "Never Remember History").

You can always assign bookmarks a keyword to guarantee autofill.