Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Middle mouse opens pdf

  • 3 ŋuɖoɖowo
  • 0 masɔmasɔ sia le wosi
  • 8 views
  • Nuɖoɖo mlɔetɔ josef.benes

more options

Hello, when I click on link with middle mouse button it will open that link on next tab but doesn't "jump" there, which is fine. But when I do the same with pdf links, it will automaticly "jumps" on the pfd file. And I don't want to. I want to open it like normal link (on next tab in background), because I have a lot of pdf files to open, and this makes it difficult to do it qucikly. Before some weeks this wasn't a probem, it started now.

Bes Regard, Josef

Hello, when I click on link with middle mouse button it will open that link on next tab but doesn't "jump" there, which is fine. But when I do the same with pdf links, it will automaticly "jumps" on the pfd file. And I don't want to. I want to open it like normal link (on next tab in background), because I have a lot of pdf files to open, and this makes it difficult to do it qucikly. Before some weeks this wasn't a probem, it started now. Bes Regard, Josef

Ŋuɖoɖo si wotia

You probably have Firefox set to its default action for PDFs, which is "Open in Firefox." With this setting, Firefox 98+ automatically loads downloaded PDFs in a new tab.

Could you confirm that the ones that switch are downloads? To do that, check the address bar for the PDF: is it a web address (http:// or https://) or a downloaded file address (file:///) ? In the downloaded file case, Firefox definitely will switch to the new tab.

Firefox 103 has a hidden setting which further changes PDF downloading so that more of the downloads open on their web address. Maybe this will help? Here's how to try it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.open_pdf_attachments_inline and pause while the list is filtered

(3) Double-click the preference (or click the "toggle" button on the right end) to switch the value from false to true

Does that help with the PDFs you're viewing?

Xle ŋuɖoɖo sia le goya me 👍 2

All Replies (3)

more options

That would be something related to your mouse driver assigning buttons. Did you check to make sure it wasn't changed.

Helpful?

more options

Ɖɔɖɔɖo si wotia

You probably have Firefox set to its default action for PDFs, which is "Open in Firefox." With this setting, Firefox 98+ automatically loads downloaded PDFs in a new tab.

Could you confirm that the ones that switch are downloads? To do that, check the address bar for the PDF: is it a web address (http:// or https://) or a downloaded file address (file:///) ? In the downloaded file case, Firefox definitely will switch to the new tab.

Firefox 103 has a hidden setting which further changes PDF downloading so that more of the downloads open on their web address. Maybe this will help? Here's how to try it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.open_pdf_attachments_inline and pause while the list is filtered

(3) Double-click the preference (or click the "toggle" button on the right end) to switch the value from false to true

Does that help with the PDFs you're viewing?

Helpful?

more options

Thank you. It was that hidden setting thing. I had my pdfs to be opend in tab but they were still doqloading. Changing that line from fals to true helped. Thank you again :)

Helpful?

Bia biabia

Ehia be na log in to your account be na ɖo post ŋu. Medekuku start a new question, ne nye be account mele asiwo haɖe o.