Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 96.0 - "Forced" dark mode

  • 53 ŋuɖoɖowo
  • 10 masɔmasɔ sia le wosi
  • 1018 views
  • Nuɖoɖo mlɔetɔ Paul

more options

I have been a "light theme" user for 15+ years. Since updating to 96.0 today, a dark mode spreading across Firefox has been forced onto me, including:

  • New tab background
  • Background of any tab waiting to load a page
  • Google/Youtube background
  • Settings/add-ons/password menu backgrounds
  • Automatic username/password drop-down background
  • Background of the little box that appears on the bottom-left (the one which shows the URL when you mouse over a link)

I am unhappy with this and wish to have my usual theme back. Can anyone please assist?

(In addition, there is some sort of white border around the current tab, which I do not like)

I have been a "light theme" user for 15+ years. Since updating to 96.0 today, a dark mode spreading across Firefox has been forced onto me, including: * New tab background * Background of any tab waiting to load a page * Google/Youtube background * Settings/add-ons/password menu backgrounds * Automatic username/password drop-down background * Background of the little box that appears on the bottom-left (the one which shows the URL when you mouse over a link) I am unhappy with this and wish to have my usual theme back. Can anyone please assist? (In addition, there is some sort of white border around the current tab, which I do not like)

hevinroyal trɔe

All Replies (20)

more options

Hi, as a preliminary question, do you a "High Contrast" dark theme on Windows? Normally that bleeds over to how pages are styled unless you disconnect it. This article has the info on that issue: Disable high contrast mode in Firefox.

Otherwise, what theme do you use on your toolbars?

In Firefox 94, Firefox would inform pages that you preferred a light/dark theme based on your system theme.

In Firefox 95, Firefox would inform pages that you preferred a light/dark theme based on your Firefox toolbar theme.

I think Firefox 96 works the same as Firefox 95, but I don't have a lot of experience with it yet.

There is a way to decouple your page (content) theme preference from your toolbar theme. At this point, it's only available through the back door...

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95)

Any improvement?

more options

(1) I do not use any high-contrast Windows theme, I use the default Windows theme. In addition, "High Contrast" setting (under Ease of access > High contrast) is OFF (2) I have been using the Blue Mozilla Firefox custom theme (https://addons.mozilla.org/en-GB/firefox/addon/blue-mozilla-firefox) for years, without any visual issue. 96.0 is what seems to have bugged everything (3) Changing the value of "layout.css.prefers-color-scheme.content-override" to 1 or 2 did the following:

  • New tab background (SOLVED)
  • Background of any tab waiting to load a page (NOT SOLVED)
  • Google/Youtube background (SOLVED)
  • Settings/add-ons/password menu backgrounds (SOLVED)
  • Automatic username/password drop-down background (NOT SOLVED)
  • Background of the little box that appears on the bottom-left (the one which shows the URL when you mouse over a link) (NOT SOLVED)

hevinroyal trɔe

more options

hevinroyal said

(2) I have been using the Blue Mozilla Firefox custom theme (https://addons.mozilla.org/en-GB/firefox/addon/blue-mozilla-firefox) for years, without any visual issue. 96.0 is what seems to have bugged everything

Things have been changing for a while now. You probably noticed in Firefox 89-95 (Proton redesign) that your right-click context menus have a dark background. This is linked to the use of light-colored text on the inactive tabs in your theme. The logic behind that design has now been extended to more dialogs and panels like these in Firefox 96:

  • Automatic username/password drop-down background (NOT SOLVED)
  • Background of the little box that appears on the bottom-left (the one which shows the URL when you mouse over a link) (NOT SOLVED)
I think the fastest workaround for that issue would be to choose a new theme that has dark text on the background tabs. There are hackier (not officially supported) approaches if you want to keep your theme.
more options

I'm having this issue too. I changed the "layout.css.prefers-color-scheme.content-override" setting suggested to "1" for light mode and it changed everything except the "Manage Bookmarks" window and the "Confirm before quitting with ⌘-Q" dialogue box. Oh, and when I just inserted that command symbol, the "Emoji & Symbols" insert bubble was also still in dark mode!

I also tried setting "layout.css.prefers-color-scheme.content-override" to "2" to match my system (which is set to light mode only) but the elements mentioned above continue to be dark.

This just started after the update to version 96.

Here's a picture:

more options

Here's a picture comparing what Firefox considers to be dark (light text) and light (dark text) themes, without and without a change in about:config.

more options

I too have been using the "Blue Mozilla Firefox" theme for years (it's one of the best)!

Over on Reddit in the Firefox subreddit, others are complaining about this same issue with other non-built-in themes.

What a bummer we have to give up our beloved custom themes to fix these visual inconsistencies. Especially considering most of the built-in themes and "colorways" are pretty ugly - at least to my eyes!

more options

Hi Eric, you can still use a custom theme, but those with white/light text on the inactive/background tabs are going to have this problem.

more options
  • This is linked to the use of light-colored text on the inactive tabs in your theme
  • I think the fastest workaround for that issue would be to choose a new theme that has dark text on the background tabs

I keep reading this over and over again, but cannot understand what you mean

more options

I mean switch to a theme that has black text on the tabs such as:

https://addons.mozilla.org/firefox/addon/firefox-b/

more options

I understand your point, and am okay to try this temporarily. However, I expect such a shortcoming to be fixed at the earliest. It makes no sense to block this "freedom of style" from users, specially when everything has been working fine for so many years.

more options

@jscher2000, can you please take a look at the following link?

https://www.reddit.com/r/firefox/comments/s1j2jn/comment/hs9myh3/?utm_source=share&utm_medium=web2x&context=3

If, as recommended, I set:

  • browser.theme.content-theme to 2
  • "browser.theme.toolbar-theme" to 2

Then the issue appears to be solved.

However', the problem is that next time I use Firefox, it only appears to permanently save "content" as 2, whereas "toolbar" always get reset to 0.

Can you please advise? The "Autoconfig" method does not work.

hevinroyal trɔe

more options

hevinroyal said

  • "browser.theme.toolbar-theme" to 2
... whereas "toolbar" always get reset to 0. Can you please advise? The "Autoconfig" method does not work.

Firefox recomputes the value of the preference every time you open a new window. If locking the preference did not work, perhaps there was some additional step that Reddit commenter took. I have not tested it myself.

more options

Would you be able to take this to the Firefox team to get it fixed? If they do not wish to do anything to solve this bug, at least it would be nice for me to have control over the "toolbar" value.

more options

hevinroyal said

Would you be able to take this to the Firefox team to get it fixed? If they do not wish to do anything to solve this bug, at least it would be nice for me to have control over the "toolbar" value.

In the Firefox 95 days when we first started talking about the layout.css.prefers-color-scheme.content-override preference, a bug was filed to add a control into the user interface for those choices. However, UI changes then to go through a long process and I don't know where that stands. Hopefully it will come in Firefox 97-98. And hopefully it will be linked to the new theming changes in Firefox 96.

more options

I have been trying to solve this "Forced Dark Mode" for a few days now. I have tried everything I could find about this to no avail. Some things it might work with, overall, no dice. Lots of web sites are broken with this "Forced Dark Mode". I can't access my bank, issues on youtube and other video platforms. Not to mention that close to 50 percent of the web sites I use either have serious issues or do not work at all because of this "Forced Dark Mode". On top of all that, I can not use dark mode and still be able to read the content on the screen without severe issues because of my eyes. I have to have light background with black or very dark text. I have used firefox pretty much since it's inception and have now decided that I will no longer be using firefox and will be telling everyone to just forget about it if they are looking for a browser. Almost everyone I know and several businesses locally, where I know the owners, have already decided to not even deal with these issues and switched to another browser. I have already installed a new browser and it works as needed and as a browser should. How dare you firefox, telling us all how our browser has to look. You had no thought of how many sites this would make nonfunctional in firefox. And to top it off, you have made ZERO consideration for those of us with vision issues that would prevent us from using a "dark mode". Here is the solution to this for everyone with the issues with "Forced Dark Mode". Use another browser. I did. Firefox is out of my life because of this "FORCED DARK MODE"

more options

z_and_tiger said

Lots of web sites are broken with this "Forced Dark Mode". I can't access my bank, issues on youtube and other video platforms. Not to mention that close to 50 percent of the web sites I use either have serious issues or do not work at all because of this "Forced Dark Mode". On top of all that, I can not use dark mode and still be able to read the content on the screen without severe issues because of my eyes. I have to have light background with black or very dark text.

Hi, you can change your toolbar theme to one that has dark text to switch Firefox to using light mode (examples below). However, the website problems probably are caused by a different issue.

If you can't find buttons because background colors are missing, try disabling Firefox from using high contrast themes: Disable high contrast mode in Firefox.

Please start a new thread -- if you care to use Firefox again -- about problems accessing sites and please include any error messages you are getting from the sites. Here's a link for that:

https://support.mozilla.org/questions/new/desktop/form


Examples of themes with dark text on the toolbars:

more options

@jscher2000 I contacted my bank and they said that they have been getting a lot of calls about their site not working suddenly. Their IT has determined that the people calling about this are in fact using firefox and the issues started up with the v96 update on firefox. They have been telling everyone to dump firefox and install chrome or any other browser and it solves the issues on their site. Today I have installed and tested nine other browsers and every single one of them works with my bank's web site. Firefox DOES NOT work since the v96 update with the "forced dark mode" even when I set it to the default theme, the setting you mentioned (which I had already done), along with the config edits recommended by several people, resetting everything to defaults and a complete uninstall and reinstall. I have already found the browser that I will be using (NOT firefox). The fact that firefox is forcing users to have a dark mode (including those of us with dark mode issues due to our eyes) is the only reason I am dumping firefox after all these years.

more options

z_and_tiger said

I contacted my bank and they said that they have been getting a lot of calls about their site not working suddenly. Their IT has determined that the people calling about this are in fact using firefox and the issues started up with the v96 update on firefox.

Firefox 96 changed some cookie-related behaviors. These are not related to your theme, and there are other threads about bank cookie issues. However, I will mention the changes here, too:

Firefox 96 made three changes related to cookies that affect when they will be served to third party servers. Most likely it is #1 on the following list, and it's pretty quick to change a setting to test that.

(1) More restrictions on serving cookies as "third party" cookies

If the server does not specify the SameSite setting for its cookies, Firefox changed from treating it as SameSite=None (allow serving as a third party cookie) to SameSite=Lax (partially restricts serving as a third party cookie).

Users have confirmed two different servers with this issue so far:

(i) iCloud: https://support.mozilla.org/questions/1364242 (ii) Canvas/Kaltura

In case this problem is caused by older cookies you stored for the site, you can try clearing them. Otherwise there's a workaround below the line below.

(2) If the cookie was set on an HTTPS page, it is not automatically passed to HTTP pages on the same server

In other words, SameSite consider the protocol (scheme) as well as the host name. This is a problem for older sites that use HTTP for most pages but do the login over HTTPS. Example: https://www.reddit.com/r/firefox/comments/s3iych/south_korea_cant_sign_in_to_some_websites_after/

Note: a hotfix was released Friday to revert change #2.

(3) If the server specifies that third party cookies are okay by setting SameSite=None, this is only honored for HTTPS pages, not HTTP pages.

I don't know whether this is causing problems on any sites.


How to test whether this is issue #1:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

(C) Double-click the network.cookie.sameSite.laxByDefault preference to switch the value from true to false

I don't know whether that takes effect immediately or whether you need to quit Firefox and start it up again.

Hopefully we will get a better understanding of how to set site exceptions in the future so you can benefit from this change while using other sites.

more options

This is silly. Things were working fine and now it's like the update has caused some mysterious problem that can't be solved by Firefox, who broke it in the first place?...

I use GLASS - BLACK theme. I don't want to change it.

I've tried changing that: "layout.css.prefers-color-scheme.content-override" to 1, but now when opening a new tab it flashes black and white really fast, and then goes to white...

Video of flicker

Other people have reported the same flashing thing. Please fix it.

S.B.T.L. trɔe

more options

orgonotic-9 said

This is ridiculous. Things were working fine and now it's like the update has caused some mysterious problem that can't be solved by Firefox, who broke it in the first place?

It is working as (re)designed.

I've tried changing that: "layout.css.prefers-color-scheme.content-override" to 1, but now when opening a new tab it flashes black and white really fast, and then goes to white... Video of flicker Other people have reported the same flashing thing. Please fix it.

I wonder whether anyone has filed a bug report: https://bugzilla.mozilla.org/

The video is small, so I can't tell for sure what you are clicking, but I think it's the new tab button.

Does the flicker appear for every page, or is it specific to the new tab and/or your new tab replacement add-on?

  1. 1
  2. 2
  3. 3