Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After upgrading to 66.0.2 I can't access billpay at BoA online banking

more options

I can login to my bank of america online banking but cannot access any bill pay pages, I was able to before the upgrade and can still access using other browsers. I have disabled all firewalls as well as anti virus apps. Below is the error msg:

Hmm. We’re having trouble finding that site.

We can’t connect to the server at sso-fi.bankofamerica.com.

If that address is correct, here are three other things you can try:

   Try again later.
   Check your network connection.
   If you are connected but behind a firewall, check that Firefox has permission to access the Web.
I can login to my bank of america online banking but cannot access any bill pay pages, I was able to before the upgrade and can still access using other browsers. I have disabled all firewalls as well as anti virus apps. Below is the error msg: Hmm. We’re having trouble finding that site. We can’t connect to the server at sso-fi.bankofamerica.com. If that address is correct, here are three other things you can try: Try again later. Check your network connection. If you are connected but behind a firewall, check that Firefox has permission to access the Web.

All Replies (2)

more options

So what does those other browser display anything different from what you see that happens in firefox.

WestEnd trɔe

more options

If you try to hit the home page (I get an error page), will Firefox connect?

https://sso-fi.bankofamerica.com/

Are your Firefox connection settings customized? You could check here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?