Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SInce I installed update, Firefox is not working properly on TDameritrade site.

  • 8 ŋuɖoɖowo
  • 4 masɔmasɔ sia le wosi
  • 38 views
  • Nuɖoɖo mlɔetɔ ronsnider

more options

When I seek to open a link to an option chain on TDAmeritrade, the popup will not open even though I have allowed popups for that site. I have tried disabling the popup feature and get the same results. It works fine in IE :( but I dont want to use IE or I would not have firefox. I get an open full window in Firefox with the following address https://invest.ameritrade.com/grid/p/null

Not sure what has changed but it needs to be repaired.

When I seek to open a link to an option chain on TDAmeritrade, the popup will not open even though I have allowed popups for that site. I have tried disabling the popup feature and get the same results. It works fine in IE :( but I dont want to use IE or I would not have firefox. I get an open full window in Firefox with the following address https://invest.ameritrade.com/grid/p/null Not sure what has changed but it needs to be repaired.

All Replies (8)

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Tried it, nothing changed.

more options

What bit version of FF did you have before the update?

more options

64 bit I presume. I am going to roll back to 55.0 and see if that makes a difference

more options

I tried rolling back to 55.0 32 bit version and same results.

more options

Clicked on link and got to the login page. FF58x64 is what I am using now.

more options

I updated to 58.0 and it is now working properly...I have the new layout, classic theme restorer cannot be used and while mozilla is sure they are moving in the right direction, changing the look and feel has not been something for which I care. Why can't you make all the changes and leave the theme alone?

more options

Here we go again...within three usages the same behavior occurred, seek to open option chain and receive following address.

https://invest.ameritrade.com/grid/p/null

what the hell is mozilla doing? Problem has not been resolved.