Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I want to stop new toolbar showing up after favoriting webpage to "bookmarks toolbar"

  • 9 ŋuɖoɖowo
  • 1 masɔmasɔ sia le esi
  • 168 views
  • Nuɖoɖo mlɔetɔ Charles555nc

more options

When i add a webpage, using the star add bookmark, to my bookmarks toolbar, a new toolbar pops up under my webpage address bar. It is very fking annoying and everytime I add something I then have to remove the stupid toolbar under my address bar. I could not find a setting under options or customize that would fix this.

Ŋuɖoɖo si wotia

Try to remove Bookmarks Toolbar Items" from the Bookmarks Toolbar and drag it to the Customize palette if you aren't using this toolbar. That prevents Firefox from displaying the Bookmarks Toolbar for me. Make sure to hide the Bookmarks Toolbar before closing the customize window.

Xle ŋuɖoɖo sia le goya me 👍 1

All Replies (9)

more options

Hi  !

Stab in the dark, but this could be caused by a Mozilla experiment : 'Shield Studies'. Would you please check to see if that's the case :

Type about:studies in the address bar and press Enter. If you are enrolled in an experiment, the name of the extension that's causing the problem will be listed there and you should be able to disable or remove it (it will be disabled at the end of the experiment anyway).

See for more information : https://support.mozilla.org/en-US/kb/shield

more options

I'm pretty sure what you're seeing is the Bookmarks Toolbar. And you likely turn it off by displaying the toolbars list and unchecking it.

I think this started earlier in the year: When you add a bookmark to the Bookmarks Toolbar, Firefox displays the bar.

If you do not want the Bookmarks Toolbar displayed, perhaps there's a better place to save the bookmarks? Are you using the toolbar because the folder is the most easily accessible on the Bookmarks Menu?

more options

Yes, Jscher2000 I use it because it is the first one on the list. I HATE that when I add something the toolbar pops up, but I guess I could open all my favorites, add them to another fking listing, and then delete the bookmarks tool bar listing. I cant believe that there is no other solution to this though.

more options

I don't know for sure that there's no way to disable the default behavior. Maybe someone knows a way.

Many aspects of Firefox's user interface can be hidden or modified using custom style rules. So...

  • If you never ever want to use the actual horizontal Bookmarks Toolbar, you could apply a custom style rule that hides it at all time. (I haven't seen one discussed in past threads but it sounds feasible.)
  • Alternately, if you want to move the entire contents of your Bookmarks Toolbar to a new folder at the top of the Bookmarks Menu, you can use custom style rules to hide Bookmarks Toolbar on the menu so your folder is a shorter distance to mouse down to. (Hiding items on this menu came up this past week.)
more options

How would I apply a custom rule that would hide the horizonal toolbars all the time? As in step by step instructions...Thank you for your help so far.

more options

Instead of this approach, see cor-el's reply: https://support.mozilla.org/questions/1179796#answer-1017465


Charles555nc said

How would I apply a custom rule that would hide the horizonal toolbars all the time? As in step by step instructions...

Okay, here goes.

Open your current Firefox profile folder -- either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Turn on display of file extensions

By default, Windows hides the .txt and .css file extensions. It is important to show them to make sure the files are named correctly. See this article for more info: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

chrome folder

The userChrome.css file needs to be created in a folder named chrome in your profile folder. Firefox doesn't create this folder, so you most likely need to create it yourself.

If you have the folder already, double-click into it.

If you do not have the folder, either

  • right-click a blank area and choose New then Folder
  • click the New Folder button on the Windows Explorer toolbar

Name the new folder chrome (all lower case). After the folder appears (usually at the bottom of the list), double-click into it.

userChrome.css file

The userChrome.css file is a plain text file you can create as follows:

right-click a blank area of the chrome folder, choose New, then Text Document, then change the name to userChrome.css. Make sure Windows doesn't sneak the .txt file extension on there. If it does, right-click Rename until the file name is precisely userChrome.css (with that capitalized C and all else lower case).

Editing userChrome.css

Unless you've created a web page before, your system may not have any program set to open .css files. You can assign them to Notepad or to your preferred text editor. Right-click userChrome.css and choose Open With. Then choose to find a program on your computer and select Notepad, for example.

AVOID using a word processor for this purpose, as it may inject formatting codes that corrupt the file. If you want a better text editor, consider:

https://notepad-plus-plus.org/

It does color coding of know file types which makes it a bit easier to read them.

Once the file is open, you can paste in your custom style rule:

@-moz-document url(chrome://browser/content/browser.xul){
    /* Hide Bookmarks Toolbar */
    #PersonalToolbar {display: none !important;}
}

Then save the file.

Firefox only reads userChrome.css at startup, so in order to test your change, you need to exit out of Firefox and start it up again.

Success?

jscher2000 trɔe

more options

Ɖɔɖɔɖo si wotia

Try to remove Bookmarks Toolbar Items" from the Bookmarks Toolbar and drag it to the Customize palette if you aren't using this toolbar. That prevents Firefox from displaying the Bookmarks Toolbar for me. Make sure to hide the Bookmarks Toolbar before closing the customize window.

more options

cor-el said

Try to remove Bookmarks Toolbar Items" from the Bookmarks Toolbar and drag it to the Customize palette if you aren't using this toolbar. That prevents Firefox from displaying the Bookmarks Toolbar for me. Make sure to hide the Bookmarks Toolbar before closing the customize window.

Oh, this is a much easier suggestion (easier to implement, easier to reverse) than a custom style rule. Illustration attached for reference.

more options

Great work Cor-el, can I plus one you or something?