Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ESR version 52.2.0 has created printing issues in Zimbra. Help?

  • 5 ŋuɖoɖowo
  • 2 masɔmasɔ sia le wosi
  • 15 views
  • Nuɖoɖo mlɔetɔ cor-el

more options

I work in the ITS Department for Aurora University and we are getting calls from faculty who are finding that once Firefox updates to ESR 52.2.0, they can no longer print from our web based Campus email service Zimbra. If we instruct them to try another browser they are fine.

When submitted via Firefox ESR 52.2.0 the emails print as blank pages with a few lines interspersed on the page.

We are using ESR because we need continued support for Silverlight for another few months.

I work in the ITS Department for Aurora University and we are getting calls from faculty who are finding that once Firefox updates to ESR 52.2.0, they can no longer print from our web based Campus email service Zimbra. If we instruct them to try another browser they are fine. When submitted via Firefox ESR 52.2.0 the emails print as blank pages with a few lines interspersed on the page. We are using ESR because we need continued support for Silverlight for another few months.

Ŋuɖoɖo si wotia

Try to set security.sandbox.content.level = 0 on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Xle ŋuɖoɖo sia le goya me 👍 0

All Replies (5)

more options

hi, perhaps the same issue as raised in https://bugzilla.mozilla.org/show_bug.cgi?id=1373363 ?

maybe it is caused by the new multi-process architecture in firefox (codename "e10s"): https://blog.mozilla.org/futurereleases/2016/08/02/whats-next-for-multi-process-firefox/ please try if disabling e10s makes a difference: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.tabs.remote.autostart.2. double-click it and change its value to false and restart the browser.

more options

Thanks for your quick response! Unfortunately setting browser.tabs.remote.autostart.2 to false and restarting the browser did not help. Same as before

more options

Ɖɔɖɔɖo si wotia

Try to set security.sandbox.content.level = 0 on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Setting security.sandbox.content.level=0 did the trick.

Our only remaining problem is now ..how do we efficiently change this setting across our entire installed user base. :(

more options

I'm curious, does setting the pref to 1 work as well?

There are some bug reports that deal with sandboxing and I'm not sure what the current state is and if there are plans to uplift any changes to ESR 52.

  • bug 1358223 - Hard code the lowest allowable content process sandbox at level 1 for Windows/OSX

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)


You can use a mozilla.cfg file to set new default value.

The mozilla.cfg file needs to be in the main Firefox program folder. These functions can be used in the mozilla.cfg file:

defaultPref(); 	// set new default value
pref();		// set pref, allow changes in current session
lockPref(); 	// lock pref, disallow changes

This also requires a local-settings.js file placed in the "defaults/pref" folder where also the channel-prefs.js file is located to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);

The mozilla.cfg file and possibly local-settings.js need to start with a comment line (//).

See Configuration:

See also: