Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I set new windows to be maximized by default in Firefox 42?

  • 2 ŋuɖoɖowo
  • 2 masɔmasɔ sia le wosi
  • 96 views
  • Nuɖoɖo mlɔetɔ modhatter

more options

For instance, I get eBay emails with daily search results. When I click on them using my computer upstairs, they open a new window, as desired, maximized, as desired. When I use a newer computer downstairs, I get a new window as desired, but it is always some ridiculously small window that I then have to maximize.

I have tried right-clicking the Firefox shortcut and setting Maximized. Nothing. I have maximized manually, and then closed the window. Does not maximize the next new window. I am currently using the shift+click workaround, but it is irritating and unnecessary.

If there is a permanent way to fix this, please let me know.

For instance, I get eBay emails with daily search results. When I click on them using my computer upstairs, they open a new window, as desired, maximized, as desired. When I use a newer computer downstairs, I get a new window as desired, but it is always some ridiculously small window that I then have to maximize. I have tried right-clicking the Firefox shortcut and setting Maximized. Nothing. I have maximized manually, and then closed the window. Does not maximize the next new window. I am currently using the shift+click workaround, but it is irritating and unnecessary. If there is a permanent way to fix this, please let me know.

Ŋuɖoɖo si wotia

Try to rename (or delete) the xulstore.json file in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
Xle ŋuɖoɖo sia le goya me 👍 0

All Replies (2)

more options

Ɖɔɖɔɖo si wotia

Try to rename (or delete) the xulstore.json file in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

My mistake... I tried this solution, and it seemed to work, so I went to click the "Mark It Solved" button, and the result was another minimized window!