Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

How can I set a custom file as home page for new tabs in Firefox Desktop 107?

  • 7 wótegrona
  • 0 ma toś ten problem
  • 700 naglědow
  • Slědne wótegrono wót cor-el

more options

Hello, in past versions of Firefox, I was able to follow the steps on this page to set a custom HTML file on my PC as my home page for new tabs: https://peterries.net/blog/firefox-ubuntu-local-file/

I have Firefox 107.0.1 now and it's not happening. When I open the browser from scratch, I see my custom home page file. But when I open a new tab, I just see a blank screen. If I then click the Home icon on the toolbar, I do see my custom HTML page, but I don't want to have to click that button for each new tab.

Right now, in my settings, I have the URL to the page set as the custom URL for the HTML fiile, like this:

file:///home/peter/Documents/homepage/peter-home-homepage.html

That works. And I also have followed the steps on that blog post to customize my /usr/lib/firefox/autoconfig.cfg and my ../firefox/defalults/pref/autoconfig.js files. That's no longer working.

Did something in a recent version change? Is this no longer supported? Thanks for any ideas!

Hello, in past versions of Firefox, I was able to follow the steps on this page to set a custom HTML file on my PC as my home page for new tabs: https://peterries.net/blog/firefox-ubuntu-local-file/ I have Firefox 107.0.1 now and it's not happening. When I open the browser from scratch, I see my custom home page file. But when I open a new tab, I just see a blank screen. If I then click the Home icon on the toolbar, I do see my custom HTML page, but I don't want to have to click that button for each new tab. Right now, in my settings, I have the URL to the page set as the custom URL for the HTML fiile, like this: file:///home/peter/Documents/homepage/peter-home-homepage.html That works. And I also have followed the steps on that blog post to customize my /usr/lib/firefox/autoconfig.cfg and my ../firefox/defalults/pref/autoconfig.js files. That's no longer working. Did something in a recent version change? Is this no longer supported? Thanks for any ideas!

Wubrane rozwězanje

Note that if you use the Snap Firefox version that you may not have permission to access this local file and you need to check this.

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Toś to wótegrono w konteksće cytaś 👍 1

Wšykne wótegrona (7)

more options

Have you look here for homepage settings?

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page#:~:text=page%20is%20set.-,Set%20your%20home%20page%20through%20Firefox%20Settings,URLs%20or%20a%20blank%20page.

I know from Windows Firefox you must set the open tab new page as there is a section for that part as well to set when you open a new tab with the page. Otherwise it just a blank new tab that opens up by default.

Wót Dropa změnjony

more options

Hi thanks. Yes, I have set those settings as I think should work, but Firefox has never had a setting which allows a custom file to be used for new tabs. That's why I've used the custom instructions in the past and that worked, until about October 2022.

I am attaching an image showing what I have now in those settings.

more options

I always used a URL for new tab and homepage setup. Maybe something was changed in later Browser version.

more options

Those steps should still work.

You can check the Browser Console for possible error messages. You can possibly add this line at the top of autoconfig.cfg:

// autoconfig.cfg starts with a blank line
Components.utils.reportError("TESTING autoconfig.cfg");
more options

Wubrane rozwězanje

Note that if you use the Snap Firefox version that you may not have permission to access this local file and you need to check this.

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

more options

Thanks, cor-el. I switched from the Snap version to the version you linked me to and now this is working as I need again. New tabs open my custom HTML file now.

more options

See also: