Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

Firefox slow on a brand new machine

  • 5 wótegrona
  • 1 ma toś ten problem
  • 32 naglědow
  • Slědne wótegrono wót FredMcD

more options

I use Firefox on all of my devices. On a new Windows Surface Laptop 3 (Ryzen 5 3580U, 8GB RAM) the speed is unbearable. Competitor product is fine as a workaround. Firefox in safe mode works great. Behaviour is observed on a brand new install (no extensions, etc.). Firefox is updated to latest version (74.0). Any help would be appreciated.

Thanks

Edit 1: - Confirmed that no performance decrease when not using an external dock (Dell Universal Dock). - Performance decrease most notable when displaying Firefox on 4K monitor connected to DP in dock. Performance better when displaying on 1080P monitor connected through HDMI (but still not as smooth as no Dock). - Dock or monitor has no impact on Firefox behaviour with other laptops.

Edit 2 - Resolved: Disabling Hardware Acceleration in 'Firefox Options > General' resolved this issue.

I use Firefox on all of my devices. On a new Windows Surface Laptop 3 (Ryzen 5 3580U, 8GB RAM) the speed is unbearable. Competitor product is fine as a workaround. Firefox in safe mode works great. Behaviour is observed on a brand new install (no extensions, etc.). Firefox is updated to latest version (74.0). Any help would be appreciated. Thanks Edit 1: - Confirmed that no performance decrease when not using an external dock (Dell Universal Dock). - Performance decrease most notable when displaying Firefox on 4K monitor connected to DP in dock. Performance better when displaying on 1080P monitor connected through HDMI (but still not as smooth as no Dock). - Dock or monitor has no impact on Firefox behaviour with other laptops. Edit 2 - Resolved: Disabling Hardware Acceleration in 'Firefox Options > General' resolved this issue.

Wót That_Guy změnjony

Wubrane rozwězanje

That_Guy said

Firefox in safe mode works great.

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Toś to wótegrono w konteksće cytaś 👍 0

Wšykne wótegrona (5)

more options

Hello, That_Guy

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. I believe this could solve your problem since you said, "Firefox in safe mode works great."

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you!

child_duckling

more options

Wubrane rozwězanje

That_Guy said

Firefox in safe mode works great.

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

child_duckling said

Hello, That_Guy The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. I believe this could solve your problem since you said, "Firefox in safe mode works great." Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information. To Refresh Firefox:
  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.
Did this fix the problem? Please report back to us! Thank you! child_duckling

This unfortunately did not work. But thank you!

more options

FredMcD said

That_Guy said
Firefox in safe mode works great.

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

I had no extensions or add-ons, as this was a fresh install (that I was using without logging-in to import my standard set).

However, disabling hardware acceleration resolved this! So thank you! :)

more options

Glad to help. Safe Surfing.