Fragen mit folgendem Schlagwort anzeigen: Alle Fragen anzeigen
  • Archiviert

place:type=6&sort=14&maxResults=10/ Why this appear when I type" t"?

When I type "t", the address bar automatically show" place:type=6&sort=14&maxResults=10/". Since this is not really an address, I can't delete this from history. … (Lesen Sie mehr)

When I type "t", the address bar automatically show" place:type=6&sort=14&maxResults=10/". Since this is not really an address, I can't delete this from history. When I hit return, it only brings out a google page. It never happened before and it is very annoying. I have deleted all the history but it still shows up each time.

Gefragt von annoyingFF vor 1 Jahr

Letzte Antwort von annoyingFF vor 1 Jahr

  • Archiviert

How do you get rid of all types of auto completion when typing in an address in the address bar?

The search bar setting is set to "Use the address bar for search and navigation", I don't want to use "Add search bar in toolbar", because I don't want to have the extra … (Lesen Sie mehr)

The search bar setting is set to "Use the address bar for search and navigation", I don't want to use "Add search bar in toolbar", because I don't want to have the extra search field in the top part of the browser, and if I go to customize, and remove it, it just changes the setting back to "Use the address bar for search and navigation".

I've already disabled the default search engine: "Provide search suggestions", and Address Bar: "Browsing history", "Bookmarks", and "Open tabs" options.

I want to be able to type an address in the address bar, without having any kind of auto completion options, but right now when I try to type and address like google for example, it still shows two lines with visit and search options, and it says "search for google with:", then shows icons for a bunch of different search engines.

I used to use firefox but stopped using it a while ago when they made ridiculous changes to it, and I'd like to use it again, but I don't know how to disable the address bar auto completion settings completely. Is there a way to fix that? Thanks.

Gefragt von ip02 vor 1 Jahr

Letzte Antwort von cor-el vor 1 Jahr

  • Gelöst
  • Archiviert

search suggestions no longer work like before

Today the search suggestions on the Google search page stopped working in Firefox (safe mode too) after Firefox update 62.0.2 (64-bit). Regardless of what settings I cho… (Lesen Sie mehr)

Today the search suggestions on the Google search page stopped working in Firefox (safe mode too) after Firefox update 62.0.2 (64-bit). Regardless of what settings I choose in about:preferences#search I can't make the search suggestions work as before which is showing in the Google page search bar and not in the address or Firefox search toolbar. This is extremely annoying that is making me use Chrome instead of Firefox. My home page is Google search and opening a new window comes with the insertion point for typing text in the Google search bar in the middle of the page not the address bar. I'm using latest version of Firefox today which is Sep 23 2018 and I'm using Windows 7 64bit

Please help!

Gefragt von Startup123 vor 1 Jahr

Beantwortet von FFus3r vor 1 Jahr

  • Archiviert

autocomplete-richlistitem order no longer works

For a few months I have been using a userChrome.css customisation which displayed a URL at the beginning of each drop down autocomplete result for the URL Bar (normally a… (Lesen Sie mehr)

For a few months I have been using a userChrome.css customisation which displayed a URL at the beginning of each drop down autocomplete result for the URL Bar (normally a useless page title is displayed).

Here is the thread where I got the script from (thanks for your help, jscher2000): https://support.mozilla.org/en-US/questions/1256581

Today I upgraded to Firefox 68 and it stopped working. Autocomplete results now display website title first, which is completely unreadable and pointless.

My userChrome.css definitely works, because if I add the following line at the end:

  • { color: red !important; }

then the text becomes red.

Unfortunately changing the order of autocomplete results so that the URL is first, has no effect.


Here is the entire content of my userChrome.css

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.ac-url-text  { color: black !important; font-size: 12px !important; }
.ac-url-text[selected="true"]  { color: white !important; }
.ac-site-icon { display: none !important; }

/* Site Identity Button, EV: hide label */
#identity-box #identity-icon-labels {display:none !important}
#identity-box:hover #identity-icon-labels {display:-moz-box !important}

/* Squash tab bar to 1px tall and hide the tabs */
#TabsToolbar
{
  height: 1px !important;
  min-height: 1px !important;
  max-height: 1px !important;
} 
#TabsToolbar .tabbrowser-tab
{
  display: none !important;
}

#PopupAutoCompleteRichResult {
  margin-left: -9px !important;
    }

#PopupAutoCompleteRichResult .autocomplete-richlistbox {
  width: auto !important;
  max-width: 78vw !important;
}



/* Oldbar flex layout based on 
     https://userstyles.org/styles/131235/firefox-autocomplete-prioritize-url 
     used with permission, new errors my own */

    .autocomplete-richlistitem[type="favicon"],
    .autocomplete-richlistitem[type="bookmark"],
    .autocomplete-richlistitem[type="switchtab"] {
      display: flex;
    }

    .autocomplete-richlistitem[type="favicon"] .ac-url,
    .autocomplete-richlistitem[type="bookmark"] .ac-url,
    .autocomplete-richlistitem[type="switchtab"] .ac-url {
      order: 1;
      display: block !important; /* Force URL for Switch to Tab */
    }

    .autocomplete-richlistitem[type="favicon"] .ac-separator,
    .autocomplete-richlistitem[type="bookmark"] .ac-separator,
    .autocomplete-richlistitem[type="switchtab"] .ac-separator {
      order: 2;
      -moz-margin-start: 2px;
      -moz-margin-end: 4px;
    }
    .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-separator {
      visibility: hidden !important;
      -moz-margin-start: 0;
      -moz-margin-end: 0;
    }

    .autocomplete-richlistitem[type="favicon"] .ac-title,
    .autocomplete-richlistitem[type="bookmark"] .ac-title,
    .autocomplete-richlistitem[type="switchtab"] .ac-title {
      order: 3;
    }

    .autocomplete-richlistitem[type="switchtab"] .ac-action,
    .autocomplete-richlistitem .ac-tags {
      order: 4;
    }


  /* Overall Layout of the "Oldbar" style at 65/35 */
    /* Drop-down width */
    #PopupAutoCompleteRichResult {
      max-width: 1000px !important;
    }
    /* Space allocated to URL and title */
    #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-url-text {
      min-width: calc(0.65 * (1000px - 200px)) !important;
      max-width: calc(0.65 * (1000px - 200px)) !important;
    }
    #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-title-text {
      min-width: calc(0.35 * (1000px - 200px)) !important;
      max-width: calc(0.35 * (1000px - 200px)) !important;
    }

    .autocomplete-richlistitem .ac-type-icon, 
    .autocomplete-richlistitem .ac-site-icon,
    .autocomplete-richlistitem .ac-tags {
      margin-top: 6px;
    }
    
    /* Font-sizes */
    #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-url,
    #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-title,
    #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-action {
      font-size: 14px !important;
    }
    .autocomplete-richlistitem .ac-url,
    .autocomplete-richlistitem .ac-action {
        margin-top: 4px;
    }



 /* Remove Page Actions Menu */
    #pageActionButton 
    {
      display: none !important;
    }


/* Reduce height of URL Bar drop down */
    #PopupAutoCompleteRichResult .autocomplete-richlistitem
    {
      height: 26px !important;
      min-height: 26px !important;
    }

Gefragt von ralphos vor 1 Jahr

Letzte Antwort von jscher2000 vor 1 Jahr

  • Gelöst
  • Archiviert

Autocomplete from bookmarks doesn't work when I delete all history, until I delete places.sqlite, but then stops working again next time the history is cleared.

I've noticed that with the latest update (62.0, I think), autocomplete won't work for bookmarks when the browsing and download history is deleted. I discovered this by l… (Lesen Sie mehr)

I've noticed that with the latest update (62.0, I think), autocomplete won't work for bookmarks when the browsing and download history is deleted. I discovered this by looking into why autocomplete wouldn't work and finding this https://support.mozilla.org/en-US/questions/1180019, so I deleted the places.sqlite file and that fixed it. That is, until the next time I deleted the browsing and download history. So I guess for now I could try to automate the process of deleting places.sqlite every time I clear the history, but I would like to find some internal Firefox setting or something that would fix this permanently.

Gefragt von pafirefox vor 1 Jahr

Beantwortet von Roland Tanglao vor 1 Jahr

  • Archiviert

bookmarks appear as globe

Before installing Firefox version 62, all my bookmarks had icons from their sites. Also, on the search bar, when I type a letter, a drop down of possible sites I have boo… (Lesen Sie mehr)

Before installing Firefox version 62, all my bookmarks had icons from their sites. Also, on the search bar, when I type a letter, a drop down of possible sites I have bookmarked would appear and I can pick and choose. Now, after updating to version 62, all my bookmarks appear as gray globe. I've tried every solution posted on your site to no avail. I want a solution to this problem a.s.a.p. I should've never updated to version 62.

Gefragt von nun808 vor 1 Jahr

Letzte Antwort von Roland Tanglao vor 1 Jahr

  • Gelöst
  • Archiviert

Can't remove url autocomplete suggestions from Firefox

Firefox often suggests sites I've never visited nor know when I type in the address bar. For instance, typing "ga" will suggest game-saga.com, typing "ka" suggests some t… (Lesen Sie mehr)

Firefox often suggests sites I've never visited nor know when I type in the address bar. For instance, typing "ga" will suggest game-saga.com, typing "ka" suggests some tumblr page etc. I have kept trying Shift-Delete, but it is completely useless, the same sites keep appearing. These sites are not in my history, nor bookmarks. How do I remove these sites?

Gefragt von jk192564 vor 1 Jahr

Beantwortet von McCoy vor 1 Jahr

  • Archiviert

How can I get old FF settings back ?

Long story short, before the latest FF update 62.0, when I started typing an letter or two in the address bar, I used to get my desired website link on the top of it. Now… (Lesen Sie mehr)

Long story short, before the latest FF update 62.0, when I started typing an letter or two in the address bar, I used to get my desired website link on the top of it.

Now, I'm not sure what happened but now I'm getting probably the most visited website link rather than the preference given as earlier. I have to type nearly half the website address or sometimes even the complete one to get the actual web address I'm trying to access, this is getting irritating. Even bookmarks aren't give the top preference over the most/latest visited link.

for example, when I typed - mo, I used to get mozilla links in the address bar drop down list - I just had to open the link I was interested in, now I have to type nearly the entire word, to even get the list related to that specific website.

Gefragt von regs vor 1 Jahr

Letzte Antwort von FFus3r vor 1 Jahr

  • Archiviert

My Firefox just updated to 62.0 and now my URL bar doesn't automatically fill in site names like it did. "Fox" would become "FOXNEWS" but not now.

I would begin an address bar/URL entry like "FAC" and it would autocomplete as "FACEBOOK.COM" and I would just hit [ENTER] or "FOX" would become "FOXNEWS.COM", then I wou… (Lesen Sie mehr)

I would begin an address bar/URL entry like "FAC" and it would autocomplete as "FACEBOOK.COM" and I would just hit [ENTER] or "FOX" would become "FOXNEWS.COM", then I would have to hit [ENTER]. Those choices still appear in a drop-down list but it was faster when the URL automatically filled. I had this functionality until the update to 62.0 this week. Can I restore this function in the configs?

Gefragt von Jal Anopi vor 1 Jahr

Letzte Antwort von philipp vor 1 Jahr

  • Gelöst
  • Archiviert

Are you guys going to conform your address bar autocomplete to best-practices?

I find the autocomplete experience just awful. I type the first few letters of a site I've visited for the past few days and it's only the 5th match down, requiring me to… (Lesen Sie mehr)

I find the autocomplete experience just awful. I type the first few letters of a site I've visited for the past few days and it's only the 5th match down, requiring me to arrow down to it or use my mouse (tsk tsk). Instead, sites I used to visit a lot appear near the top, or search suggestions. I read this list of autocomplete best-practices and thought you guys might find it inspiring: http://jeremymikkola.com/posts/2019_03_19_ru

Gefragt von jaredgorski vor 1 Jahr

Beantwortet von jscher2000 vor 1 Jahr

  • Gelöst
  • Archiviert

Firefox URL Autocomplete Not Working - Have Tried Everything

I'm having a lot of trouble with the URL autocomplete function not working. I have been trying to solve this for a couple days and nothing is working to enable the URL au… (Lesen Sie mehr)

I'm having a lot of trouble with the URL autocomplete function not working. I have been trying to solve this for a couple days and nothing is working to enable the URL autocomplete. Here are some of the things I have tried - does anyone have any ideas?

Thanks so much!

-Made sure the browser.urlbar.autoFill item is set to 'true' -Adjusted Firefox History settings to 'Remember History' -Adjusted Firefox Address Bar settings (Browsing History, Bookmarks, and Open Tabs are checked) -Cleared cache and cookies -Reset Firefox several times -Reinstalled Firefox (without deleting profile and Firefox data)

I have attached screenshots of how my 'about:config' looks, as well as the 'Important Modified Preferences,' in case there's an error that someone else can catch.

(I am running Firefox 68.0.2 on macOS Mojave Version 10.14.5)

Gefragt von Kenton vor 11 Monaten

Beantwortet von cor-el vor 11 Monaten

  • Archiviert

Auto suggest previously visited and bokmarked url does not work since the latest update.

Firefox used to suggest a bookmarked url and I was able to type in 3 or 4 letters and press enter to go directly to the bookmarked url. This function no longer works sin… (Lesen Sie mehr)

Firefox used to suggest a bookmarked url and I was able to type in 3 or 4 letters and press enter to go directly to the bookmarked url. This function no longer works since the latest FF update.

Gefragt von lkswan747 vor 1 Jahr

Letzte Antwort von FFus3r vor 1 Jahr

Why is autocomplete.js slow only in Firefox

A jquery autocomplete.js with 72,000 items takes about 4 seconds to run in Safari and Chrome. On Firefox it takes about 40 seconds, making it unusable. Why would Firefox … (Lesen Sie mehr)

A jquery autocomplete.js with 72,000 items takes about 4 seconds to run in Safari and Chrome. On Firefox it takes about 40 seconds, making it unusable. Why would Firefox be so much slower?

I have restarted in Safe Mode and Reset Firefox to no avail.

Gefragt von James.Jim.Cook vor 4 Monaten

Letzte Antwort von TyDraniu vor 4 Monaten