Fragen mit folgendem Schlagwort anzeigen: Alle Fragen anzeigen

Can't install BitWarden extension for TOR

Hi, Im trying to install BitWarden extension for TOR. I tried using the direct download button on BitWarden website, and also tried installing from the add-ons section in… (Lesen Sie mehr)

Hi, Im trying to install BitWarden extension for TOR. I tried using the direct download button on BitWarden website, and also tried installing from the add-ons section in firefox-tor. When i click the blue "add to firefox" button, i just get "page loading" type waiting dots in the tab of the page. The extension doesnt get installed. Any ideas? Ps im not super tech savvy Kindly Mark

Gefragt von markmith vor 2 Monaten

Fingerprinting with Media Devices

I apologize if this has already been brought up. It seems that the browser has access to a list of my media devices, without needing any special permissions. On Am I Uniq… (Lesen Sie mehr)

I apologize if this has already been brought up.

It seems that the browser has access to a list of my media devices, without needing any special permissions. On Am I Unique, they can grab the unique ID of my builtin macbook camera & microphone. I believe the culprit is MediaDevices.enumerateDevices(). I do have privacy.resistFingerprinting set to True.

Perhaps you could put it behind a permission request, like MediaDevices.getUserMedia()?

Thank you for your time.

Gefragt von life.rider09 vor 2 Monaten

Opinion wanted

I am using Opensuse 15.0 and also 15.1. Haven't made a complete move over yet. There is a recurring situation when 4GB rx and 4GB tx movement that I cannot account for hi… (Lesen Sie mehr)

I am using Opensuse 15.0 and also 15.1. Haven't made a complete move over yet. There is a recurring situation when 4GB rx and 4GB tx movement that I cannot account for hits my 15.0 about once a month. Today it happened again. Using vnstat, I found it happened between 10.00 - 11.00. :

h  rx (MiB)   tx (MiB)      h  rx (MiB)   tx (MiB)      h  rx (MiB)   tx (MiB) 

13 0.00 0.00 21 3.67 0.57 05 0.00 0.00 14 0.00 0.00 22 24.49 2.24 06 0.00 0.00 15 34.60 1.85 23 0.00 0.00 07 0.00 0.00 16 175.23 9.05 00 0.00 0.00 08 193.93 9.07 17 0.00 0.00 01 0.00 0.00 09 0.00 0.00 18 0.00 0.00 02 0.00 0.00 10 3,939.97 4,090.57 19 0.00 0.00 03 0.00 0.00 11 31.14 2.34 20 0.00 0.00 04 0.00 0.00 12 7.60 1.06 I was merely surfing, no download. Searched the cookies, one site i cannot recognize came out; "consensu.org". Did a search, there were several, example: https://cmp.teads.mgr.consensu.org/index.html, that served blank pages in firefox. Is there anything odd here? Is there a way I can extract all the cookies with date & time so that I can check against previous occurrences of the 4GB data movements (I have a few records).

Gefragt von lims3148 vor 2 Monaten

Display entire extension name in address bar

Unlike some people who don't want to see the extension name in the address bar, I want to see the *entire* extension name. Threat model: one of my extensions gets a rogu… (Lesen Sie mehr)

Unlike some people who don't want to see the extension name in the address bar, I want to see the *entire* extension name. Threat model: one of my extensions gets a rogue update and puts up a screen that looks just like a screen (e.g., the login page) of another extension (e.g., my password manager).

When the extension name is too long, Firefox currently displays: Extension... <last word of extension name>

To be secure I currently need to click on the above so that it expands, in order to verify it's the correct extension.

Can this be done in CSS, or would a feature change be needed to Firefox?

Gefragt von garland1 vor 2 Monaten

CSP issue in firefox

Hi Team, We are facing issue while exporting documents from our portal which is embedded into an iframe of some external portal. We see the following error in the console… (Lesen Sie mehr)

Hi Team,

We are facing issue while exporting documents from our portal which is embedded into an iframe of some external portal.

We see the following error in the console :

Content Security Policy: The page’s settings blocked the loading of a resource at blob:https://abc.def.com/1gg3810-ae25-42ae-ghghb-123456789 (“frame-src”).

This issue comes only in firefox. We are able to export documents in other browsers. We think that the problem comes due to the portal is embedded into an iframe. when we execute the download URL in a separate tab, it allows to download the document.

We are using below CSP policy :

default-src * blob: 'self' 'unsafe-eval' 'unsafe-inline'; font-src * data:; img-src * data:; frame-src * blob: data: 'self'; object-src *

Thanks

Gefragt von gupta.harish2624 vor 2 Monaten

how to check for dependencies on Linux/BSD?

Hi, so i found this excellent article https://support.mozilla.org/en-US/kb/install-firefox-linux and I unzipped/extracted the firefox-77.0.1.tar.bz2 file. By the way, am … (Lesen Sie mehr)

Hi, so i found this excellent article https://support.mozilla.org/en-US/kb/install-firefox-linux and I unzipped/extracted the firefox-77.0.1.tar.bz2 file.

By the way, am glad to know I don't have to compile it. Tis a relief :)

So the article above says to check this list @ https://www.mozilla.org/en-US/firefox/77.0.1/system-requirements/#software-requirements for "required libraries". I am really good at the command line except for checking library dependencies. :/

Last link shows these 5:

  • Bulleted list item GTK+ 3.4 or higher
   * Bulleted list item    GLib 2.22 or higher
   * Bulleted list item    Pango 1.22 or higher
   * Bulleted list item    X.Org 1.0 or higher (1.7 or higher is recommended)
  • Bulleted list item libstdc++ 4.7 or higher

My fear is i'll have to search around a while for the exact package name since sometimes capitalization and dashes matter when using apt, aptitude, or synaptic.

Here's what I am trying so far. I started with libstdc++ since that's all lower case. ++++++++++++++++++++++++++++ $ apt list | grep libstdc++ | grep -v unstable ... ... (super long list of lots of different libstdc++) ... libstdc++6/stable 8.3.0-6 i386 ++++++++++++++++++++++++++++ So since that ends with version 8.3 and that's higher than the "4.7 or higher" in the official list above, then I'm good. (By the way, just a plain `apt list libstdc++` returned no results.)

And substituting the word 'pango' in the above command gives a similarly long list that looks good, i think. Same with 'gtk3', 'glib2', and 'xorg'.

Oh, i think i've answered my own question :) but maybe went the scenic route with my command since i did not know the exact package names.

Anybody have a faster way of checking for these? Pretty please? :)

P.S. By the way, I'm using Debian but in my experience it wouldn't matter if i was using Arch or even one of the BSD's right now. Yes, tools are slightly different like apt/dpkg, or ports but am mostly curious for what exact package names to search for to save me time. :)

Thanks, you all rock. Love the community here though,

Roger Brown

Gefragt von Roger vor 1 Monat

Do not cache an excel file while opening it

Hello, We have recently changed our default browser, from IE to Firefox. We have an issue with it : before when we opened a file with IE (excel file) every relative link … (Lesen Sie mehr)

Hello, We have recently changed our default browser, from IE to Firefox. We have an issue with it : before when we opened a file with IE (excel file) every relative link inside follow the source URL of the file (that we need). Now, firefox download the file in his cache when we just open it, the result is all links are broken (C:\users\myuser\appdata\...).

Is the an option we can manage to disable the file caching when we just open it ?

Thanks a lot by advance,

Best regards

Gefragt von b.desbois vor 1 Monat

OpenH264 add-in is not automatically installing and has a message of "will be installed shortly"

I am trying to install the OpenH264 Add-in from the Add-ins section on a Firefox 68.9.0-esr.1 version running Raspbian "Buster" which is up to date. Even though the Firef… (Lesen Sie mehr)

I am trying to install the OpenH264 Add-in from the Add-ins section on a Firefox 68.9.0-esr.1 version running Raspbian "Buster" which is up to date. Even though the Firefox is installed correctly and connected to the internet this add-in keeps displaying a warning or info sticker saying "OpenH264 Video CODEC is provided by Cisco Systems, Inc - Will be installed shortly.

I have waited hours for it to start to download, tried restarting Firefox, even rebooted the entire system will no success.

Even tried to download it manually from the OpenH264 site but could not find a .xpi or .jar file to plug in.

Can anyone help as to how I can make this Add-in download happen inside Firefox please?

Gefragt von support68 vor 1 Monat

OpenGL and WebGL hardware acceleration not working on Debian Firefox with Intel 915GM

Dear Mozilla Supporters, I am having issues with OpenGL and WebGL support on an older 32 bit Pentium M machine using the latest Firefox 77.0.1 and Debian 10.4 on LXQt. - … (Lesen Sie mehr)

Dear Mozilla Supporters,

I am having issues with OpenGL and WebGL support on an older 32 bit Pentium M machine using the latest Firefox 77.0.1 and Debian 10.4 on LXQt. - GPU is Intel 915GM - kernel support is enabled - correct firmware and mesa drivers available for OpenGL 1.4, OpenGL ES 2.0 - X11 correctly initialises DRI and DRI2 with kms and SNA

Firefox about:support shows: - blacklisted OPenGL and WebGL with FEATURE_FAILURE_OPENGL_1 - WebGL 1 Driver Renderer WebGL creation failed:

  • Refused to create native OpenGL context because of blacklist entry: FEATURE_FAILURE_OPENGL_1
  • Exhausted GL driver options.

WebGL 2 Driver Renderer WebGL creation failed:

  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OPENGL_1

HW_COMPOSITING blocked by env: Acceleration blocked by platform OPENGL_COMPOSITIFNG unavailable by default: Hardware compositing is disabled GPU_PROCESS unavailable by env: Hardware compositing is unavailable. WEBRENDER opt-in by default: WebRender is an opt-in feature WEBRENDER_QUALIFIED blacklisted by env: No qualified hardware WEBRENDER_COMPOSITOR disabled by default: Disabled by default blacklisted by env: Blacklisted by gfxInfo unavailable by runtime: No DirectComposition usage WEBRENDER_ANGLE opt-in by default: WebRender ANGLE is an opt-in feature WEBRENDER_DCOMP_PRESENT opt-in by default: WebRender DirectComposition is an opt-in feature OMTP broken by runtime: OMTP is not supported on 32-bit with <= 2 cores WEBGPU disabled by default: Disabled by default blocked by runtime: WebGPU can only be enabled in nightly

I tried many different Firefox config combinations with force_acceleration, as well as X11 with UXA, without success. I tested OpenGL support in native X11 with glxinfo and glxdemo, and hardware accelleration does work.

I believe this worked in the past without issues, I have been using the same machine on older Lubuntu and recently decided to upgrade to the latest Debian eqivalent.

Any ideas why Firefox does not see and use the OpenGL accelleration available in X11?

Gefragt von brainsurf vor 1 Monat

Graphic Tablet Incompatible?

I recently bought a graphic tablet (https://www.trust.com/en/product/21794-panora-widescreen-graphic-tablet), and it works flawlessly outside of firefox. However, when ho… (Lesen Sie mehr)

I recently bought a graphic tablet (https://www.trust.com/en/product/21794-panora-widescreen-graphic-tablet), and it works flawlessly outside of firefox. However, when holding BigBlueButton lectuers, I need to use it within firefox, which doesn't seem to work. At first I thought it was an issue with BigBlueButton, but now I tried other websites (limnu, cocreate, etc.), and they all have the same problem:

Whenever I move the pen on my graphic tablet, only the first and last 'points' are recognized. Is there a way to increase firefox's refresh rate for mouse clicks? Or is there any other solution?

I'm using firefox 68.9.0esr, 64-bit on windows 10.

Gefragt von tablet vor 1 Monat

  • Gesperrt

Lost all bookmarks, etc switching to eos version 68

duplicate of /questions/1292796 thread. i did check all boxes during the switch from one firefox version to eos but no bookmarks or anything were synched over. Is this r… (Lesen Sie mehr)

duplicate of /questions/1292796 thread.

i did check all boxes during the switch from one firefox version to eos but no bookmarks or anything were synched over. Is this repairable? Either way - keeping this version or going back to the previous one?

Gefragt von sertifiedjeenious vor 1 Monat

Firefox sync not working after signing in. Can not disconnect the account now.

Hi folks, I have endured the sync problem for months. Today I struggled for solving it. I have a Firefox 68.0.1 esr manual installation on Ubuntu 16.04. The sync worke… (Lesen Sie mehr)

Hi folks,

I have endured the sync problem for months. Today I struggled for solving it.

I have a Firefox 68.0.1 esr manual installation on Ubuntu 16.04. The sync worked when I signed in the first time. But the bookmark can not longer be updated afterwards.

If I add or delete a bookmark on my Firefox 68.0.1 esr on Windows 10, the change will not be updated to the Linux version. And vice versa.

On the Linux, I tried to disconnect my account (in the preference about:preferences?entrypoint=fxa_app_menu#sync ). I click "Disconnect" and "Just Disconnect" in the prompt, but the account is still logged in.

Another way I tried is to have a fresh new installation of Firefox 68.9 esr. Then I was asked to sign in again. After typing the password, the new bookmarks were updated. But If I make further changes on the other devices, these changes will not be sync to Linux. And I can't disconnect the account on Linux.

It looks like a new install, which resetting the login process can temporarily solve the problem.

Here is the content of the sync-log file. Can you see what is broken? Thanks in advance.


1593396039810 Sync.LogManager DEBUG Flushing file log

1593396039810 FirefoxAccounts TRACE not checking freshness of profile as it remains recent

1593396039815 Sync.LogManager DEBUG Log cleanup threshold time: 1592532039815

1593396039824 Sync.LogManager DEBUG Done deleting files.

1593396177546 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:fxa_status

1593396177546 FirefoxAccounts DEBUG fxa_status received

1593396177546 FirefoxAccounts DEBUG service: 30b11ae57025e70b

1593396177546 FirefoxAccounts DEBUG is private browsing: false

1593396771684 Sync.RemoteTabs INFO Generating tab list with filter

1593396771684 Sync.RemoteTabs INFO Final tab list has 0 clients with 0 tabs.

1593396939808 Sync.Service DEBUG User-Agent: Firefox/68.9.0 (Linux x86_64) FxSync/1.70.0.20200527211442.desktop

1593396939808 Sync.Service INFO Starting sync at 2020-06-28 19:15:39 in browser session hnIS9YAkhTxS

1593396939808 Sync.Service DEBUG In sync: should login.

1593396939808 Sync.Service INFO User logged in successfully - verifying login.

1593396939809 Sync.BrowserIDManager DEBUG unlockAndVerifyAuthState: user declined to unlock master-password

1593396939809 Sync.Status DEBUG Status.login: service.master_password_locked => service.master_password_locked

1593396939809 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed

1593396939809 Sync.Service DEBUG Fetching unlocked auth state returned service.master_password_locked

1593396939809 Sync.ErrorHandler ERROR Sync encountered a login error

1593396939809 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score.

1593396939810 Sync.SyncScheduler DEBUG Couldn't log in: master password is locked.

1593396939810 Sync.SyncScheduler DEBUG Starting client-initiated backoff. Next sync in 900000 ms.

1593396939810 Sync.SyncScheduler DEBUG Next sync in 900000 ms. (why=client-backoff-schedule)

1593396939811 Sync.Service DEBUG Exception calling WrappedLock: Error: Login failed: service.master_password_locked(resource://services-sync/service.js:984:15) JS Stack trace: onNotify@service.js:984:15

Gefragt von tianci.zju+firefox vor 1 Monat

Install hangs

Was having trouble with Firefox (not connecting to web sites). Tried refresh did not fix did search and deleting all Mozilla files. Now when I launch Firefox exe. get me… (Lesen Sie mehr)

Was having trouble with Firefox (not connecting to web sites). Tried refresh did not fix did search and deleting all Mozilla files. Now when I launch Firefox exe. get message "for some reason we could not install Firefox try again " takes about 30 min. or longer to get this message

Gefragt von uscple4mc vor 1 Monat

Pop up appears in 1st Display when the firefox is in second display

Hello, I am using SAP CRM using Firefox. I always open my Firefox in second display and always i need the pop up to appear on the second display where my Firefox is opene… (Lesen Sie mehr)

Hello,

I am using SAP CRM using Firefox. I always open my Firefox in second display and always i need the pop up to appear on the second display where my Firefox is opened.

But the pop up just shifts to the first screen each time

I don't have this issue in Chrome or the edge

Gefragt von sudheerkrishnan85 vor 1 Monat

nothing loads

Firefox won't load any pages at all, the home page is blank and I've tried several things to try and fix it such as restarting my laptop and reinstalling Firefox. I've tr… (Lesen Sie mehr)

Firefox won't load any pages at all, the home page is blank and I've tried several things to try and fix it such as restarting my laptop and reinstalling Firefox. I've tried safe mode but everything's still blank on there so I know it isn't my addons. Any help is appreciated!

Gefragt von crammitjammit vor 1 Monat

WebRTC with Janus Websockets and Asterisk no sound, 78esr

We have a server running Debian Buster with Janus and Asterisk installed using the standard Debian packages. Using the standard Janus test page to make calls through our … (Lesen Sie mehr)

We have a server running Debian Buster with Janus and Asterisk installed using the standard Debian packages. Using the standard Janus test page to make calls through our server via the Websockets interface, we have no problems with any of the Firefox 68esr browsers, but after upgrading to the latest 78esr browser, we have no audio after the call connects if we initiate the call from Windows 10. Using Linux or Mac 78esr (or any OS with Chrome) to initiate the call audio is working, even if the answering browser is 78esr on Windows 10.

Looking in the Asterisk and Janus logs for working and silent calls, they appear identical (opus codec selected in all cases), and there are no errors in the Web Console after upgrading adapter.js to 7.4.0.

Is there a known problem with websockets and 78esr?

Gefragt von raymond.field vor 1 Monat

Firefox will system prevent to hibernate

I am using Windows 7 64bit. For some time I have noticed that in about 50% of cases Firefox prevents the system from shutting down in hibernate mode. Instead, the Windows… (Lesen Sie mehr)

I am using Windows 7 64bit. For some time I have noticed that in about 50% of cases Firefox prevents the system from shutting down in hibernate mode. Instead, the Windows login dialog appears again. If I terminate Firefox before shutting down the system, the system will shut down correctly in hibernate mode. Any idea what that could be?

Best regards,

Walter Hahn

Gefragt von walter.hahn vor 4 Wochen

Problems when printing online articles, consisting of more than one page.

When I try to print online describtions or articles, consisting of more than one page by using my Epson WF-2510 the change from one page to the following page does not ap… (Lesen Sie mehr)

When I try to print online describtions or articles, consisting of more than one page by using my Epson WF-2510 the change from one page to the following page does not appear at the right position, so that I loose parts of the articles. What can I do ? What is wrong ?

Gefragt von ivm.muenstedt vor 2 Wochen

userChrome.css to set menu backgrund and highlight color

Hi All, What's the userChrome.css setting to change menu bar background and highlight color? See image. Esp. the highlight color is too dark making the underlying menu un… (Lesen Sie mehr)

Hi All,

What's the userChrome.css setting to change menu bar background and highlight color? See image. Esp. the highlight color is too dark making the underlying menu unreadable.

Help is appreciated.

Cheers, Gert

Gefragt von drgert1 vor 2 Wochen