Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens all tabs that were open when last closed

  • 15 Antworten
  • 4 haben dieses Problem
  • 2008 Aufrufe
  • Letzte Antwort von cor-el

more options

I am running Linux Mint 16 with FF 28.0. FF sometimes opens all the previous tabs I had open, rather than the tabs I have set to open as my home page.

I have tried all the solutions I can find here or elsewhere on the web, including the about:config settings, resetting FF, uninstalling FF and re-installing, checking four user.js (could it be something different in Linux?) file, etc.


I did this:

(3) Double-click browser.sessionstore.max_resumed_crashes and change the 1 to a 0 (a zero) and OK that. 

from this thread with the same problem:

https://support.mozilla.org/en-US/questions/976041

and FF just re-starts with all the previous tabs open.

Ausgewählte Lösung

Installing Firefox V29.0 fixed the problem of FF opening all my previous tabs.

But now all the addresses in my URL are blanked out by various colours, mostly grey and black. Sigh. FF has been a lot of work lately, and now that it looks like Chrome, I might as juts well use Chrome.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (15)

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

   https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
   http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues 

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

   http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox 

You can also try to reset Firefox:

   https://support.mozilla.org/kb/Basic+Troubleshooting
more options

This can happen if Firefox didn't close properly the previous time.

Does this still happen with browser.sessionstore.max_resumed_crashes set to 0 as that should bring up the about:sessionrestore page to choose which tabs and windows to restore?


You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.

Rename (or delete) the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox profile folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

more options

When I uninstalled and re-installed FF, I only imported my bookmarks from an html file into the new user, so I thought that should have been a pretty clean new user file. I had previously tried re-setting FF as I mentioned.

Having browser.sessionstore.max_resumed_crashes set to 0 does not bring up the session restore page. FF just starts with all my previous tabs.

If I shut FF manually (click the x) before re-starting, I think it behaves OK. It seems to just open my home page tabs. Shutting down Linux with FF open seems to be when it opens the previous tabs, but I don't get the session restore page like it shut down improperly, even with browser.sessionstore.max_resumed_crashes set to 0.

more options

Oh, forgot to say I tried deleting the sessionstore files, with no change.

And this time when I tried closing FF before re-booting, it came up with all the tabs anyway, so my theory it was having it open when shutting down Linux isn't right.

And I did delete the whole user file when I uninstalled/re-installed, so I was hoping that would would clean things out.

more options

You should always close Firefox via "Firefox/File > Quit" (preferred) or by clicking the close X on the title bar before you run down the computer because otherwise Firefox may not get enough time to close properly and that will likely be the cause of your issue that Firefox shows the tabs from the previous time.

more options

I hardly ever close Thunderbird or Firefox before shutting down, I've never had issues on XP, and TB works fine doing it that way on Linux. I'll probably continue doing it that way at this point.

It makes no difference to FF on Linux i n any case. It still opens all my previous tabs on the next start up, even if I close FF before shutting down. FF gives no indication it was shut down improperly even if I just shut down the computer - it just doesn't work right either way.

more options

Did you check in the System monitor that the Firefox process is gone?

Can you always restart Firefox after you have closed Firefox?

more options

I've just discovered when it does work right - I thought it occasionally did, but couldn't re-create it.

If I close FF (click the X), and don't re-start the computer, it opens only my Home Page tabs. If I close FF by clicking the X, and then re-start the computer it re-opens all the previous tabs.

Geändert am von kcaldwel9

more options

Thanks!

Some FF process remains running even after shutting it down by clicking the X, or by right clicking in the bar and closing. It holds 231 to 234MB of memory.

I can always restart FF fine, even though it it is still in the Task Manager. It also opens correctly, with only my home tabs, as long as I haven't shut the computer down.

So it appears FF isn't shutting down completely, and when the computer shuts down all the tabs get stuck somewhere.

more options

I've tried it a few more times, and it is inconsistent. Sometimes all the FF processes disappear from the task manager, and sometimes they don't.

The only thing that does seem consistent, is that it starts fine whether it is shut down entirely or not, and gives no indication of any problem.

more options

I just tried FF on two other computers with Linux Mint, one XFCE, one Cinnamon. They both behave the same. These are clean installs of Linux, and one has never been used for anything but Skype so far.

This seems to be a FF behaviour - even with it set to open only my home page tabs, it opens all the previous session tabs - most of the time!

All V28.0 of FF for Linux.

Geändert am von kcaldwel9

more options

Ausgewählte Lösung

Installing Firefox V29.0 fixed the problem of FF opening all my previous tabs.

But now all the addresses in my URL are blanked out by various colours, mostly grey and black. Sigh. FF has been a lot of work lately, and now that it looks like Chrome, I might as juts well use Chrome.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

This is back now with V29. I have 3 computers that all do this running Linux Mint 16.

If I shut-down FF, and restart FF without restarting the computer, it only brings up my home page tabs as it is set to do.

If I shut-down the computer, when it re-starts FF opens all the tabs from the last session, even though I have it set to show my home pages.

I have tried deleting sessionstore files. There does seem to be a FF process that hangs up after FF is supposedly closed in the system monitor.

Geändert am von kcaldwel9

more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

See also: