X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How do I stop Firefox from accesing web pages when I mouse over the link?

Veröffentlicht

I disable link prefetching yet Firefox version 29.0 beta for OSX still tries to access a web page when I move the mouse over a link on a webpage.

I disable link prefetching yet Firefox version 29.0 beta for OSX still tries to access a web page when I move the mouse over a link on a webpage.

Ausgewählte Lösung

OK , SORRY FOR YOUR HASSEL ,

LET ME HELP YOU :)

I WILL TELL YOU SOMETHING TO DO FOR YOUR SAKE , PLEASE DO THOSE THINGS .

1. I THINK YOU HAVE ANOTHER BROWSER . SO PLEASE CHECK THAT THIS PROBLEM ALSO EXISTS WITH YOUR ANOTHER BROWSER ALSO ( IF IT REMAINS , THEN THE PROBLEM IS IN YOUR COMPUTER'S HARDWARE . I AM HOPING THAT THIS IS THE CAUSE FOR YOUR PROBLEM . THE SOLUTION FOR THIS ,

GO TO CONTROL PANEL OF YOUR WINDOWS , THEN

Mouse Properties > Device Settings (Tab) > Settings (button) > Tapping (menu item) > then uncheck "Enable Tapping"

)

IF NOT , THEN YOU CAN TRY THIS

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste specu and pause while the list is filtered

(3) Double-click the network.http.speculative-parallel-limit and set it to 0 (zero).

Does that work?

I HOPE , YOUR PROBLEM IS FIXED. :)
Diese Antwort im Kontext lesen 2

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0

Weitere Informationen

iamjayakumars 489 Lösungen 5951 Antworten
Veröffentlicht

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Mac: Hold the option key while starting Firefox.

Once you get the pop-up, just select "'Start in Safe Mode"


If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes). ''(If you're using an added theme, switch to the Default theme.)'' If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the '''Restart with Add-ons Disabled...''' menu item:<br> If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Mac: Hold the '''option''' key while starting Firefox. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you.

Fragesteller

Hello thank you for the reply but that did not fix it. In safe mode it also happens. This only started yesterday when I upgraded from Beta 28 to Beta 29

Hello thank you for the reply but that did not fix it. In safe mode it also happens. This only started yesterday when I upgraded from Beta 28 to Beta 29
jscher2000
  • Top 10 Contributor
8699 Lösungen 71102 Antworten
Veröffentlicht

Could you describe this in a little more detail: does mousing over behave like a click, or is it requesting the page in the background (predictively) but continuing to display the current page until you actually click?

Does this happen on all sites or just some sites? If it's only a few sites, there may be some new HTML feature that got turned on, and taking a look at the link may provide a clue to how to turn it off.

Could you describe this in a little more detail: does mousing over behave like a click, or is it requesting the page in the background (predictively) but continuing to display the current page until you actually click? Does this happen on all sites or just some sites? If it's only a few sites, there may be some new HTML feature that got turned on, and taking a look at the link may provide a clue to how to turn it off.

Fragesteller

It is requesting the page in the background I can see it on my Firewall connection request program as soon as I mouse over any html link on any webpage. If I go to google news for example and mouse over a link, it requests that web page.

It is requesting the page in the background I can see it on my Firewall connection request program as soon as I mouse over any html link on any webpage. If I go to google news for example and mouse over a link, it requests that web page.

Fragesteller

Nothing else?

Nothing else?
Robert Wright 2 Lösungen 9 Antworten
Veröffentlicht

Hi!

Here is a article I found about stopping Firefox from prefetching content.

http://mzl.la/Mxv856

Let me know if that helps!

Thanks!

Hi! Here is a article I found about stopping Firefox from prefetching content. http://mzl.la/Mxv856 Let me know if that helps! Thanks!
jscher2000
  • Top 10 Contributor
8699 Lösungen 71102 Antworten
Veröffentlicht

Hopefully some beta users can try to replicate this. I'm running Firefox 28.

Hopefully some beta users can try to replicate this. I'm running Firefox 28.

Fragesteller

Unfortunately that link just gives the same routine, disable prefetch in the config options. This does nothing in Beta 29

Unfortunately that link just gives the same routine, disable prefetch in the config options. This does nothing in Beta 29

Fragesteller

Beta 29 v2 still same issue. Sigh

Beta 29 v2 still same issue. Sigh
cor-el
  • Top 10 Contributor
  • Moderator
17482 Lösungen 157978 Antworten
Veröffentlicht

In what way is Firefox accessing a web page when you hover a link?

Do you see network traffic in some application?

What does the Live Http Headers show?

In what way is Firefox accessing a web page when you hover a link? Do you see network traffic in some application? What does the Live Http Headers show? *https://addons.mozilla.org/firefox/addon/live-http-headers/

Fragesteller

Hello thank you for your help. Yes as I said in a previous post

It is requesting the page in the background I can see it on my Firewall connection request program as soon as I mouse over any html link on any webpage. If I go to google news for example and mouse over a link, it requests that web page.

Hello thank you for your help. Yes as I said in a previous post It is requesting the page in the background I can see it on my Firewall connection request program as soon as I mouse over any html link on any webpage. If I go to google news for example and mouse over a link, it requests that web page.

Fragesteller

What am I looking for with Live Headers?

What am I looking for with Live Headers?
cor-el
  • Top 10 Contributor
  • Moderator
17482 Lösungen 157978 Antworten
Veröffentlicht

You can check if there are files being fetched or requested from the location of the link that you hover.
Make sure to check off all boxes on the Generator tab of the Live Http Headers extension.

You can check if there are files being fetched or requested from the location of the link that you hover.<br /> Make sure to check off all boxes on the Generator tab of the Live Http Headers extension.

Fragesteller

They are outbound requests.

As I said before I had this same problem previously and turned prefetch off, and it fixed it. But the same does not work with the new beta.

They are outbound requests. As I said before I had this same problem previously and turned prefetch off, and it fixed it. But the same does not work with the new beta.

Geändert am von davidalexander12

cor-el
  • Top 10 Contributor
  • Moderator
17482 Lösungen 157978 Antworten
Veröffentlicht

If those prefs are user set then you can check if they are still supported by resetting the pref via the right-click context menu to the default value.
If you get an empty string value then that means that the pref is no longer supported.

If those prefs are user set then you can check if they are still supported by resetting the pref via the right-click context menu to the default value.<br /> If you get an empty string value then that means that the pref is no longer supported.

Fragesteller

Reset to default no difference. Beta 3 still same problem.

network.prefetch-next

set as true or false, does not matter, FF 29 beta 3 still tries to access any webpage my mouse clicks over.

Reset to default no difference. Beta 3 still same problem. network.prefetch-next set as true or false, does not matter, FF 29 beta 3 still tries to access any webpage my mouse clicks over.

Geändert am von davidalexander12

rats 1 Lösungen 16 Antworten
Veröffentlicht

Is Mozilla seriously ignore this problem?

Is Mozilla seriously ignore this problem?

Fragesteller

It appears so. Release candidate 2 still has this issue, it ignores the network prefetch setting.

It appears so. Release candidate 2 still has this issue, it ignores the network prefetch setting.
jscher2000
  • Top 10 Contributor
8699 Lösungen 71102 Antworten
Veröffentlicht

I tried to replicate this behavior in the release of Firefox 29 for Windows 7, and I am not getting any network requests when I mouse over the titles of results. I was testing using Fidder2 with HTTPS decryption enabled (and Firefox set to temporarily trust the fake certificate). I am logged out of Google and using a new profile created for testing.

I tried to replicate this behavior in the release of Firefox 29 for Windows 7, and I am not getting any network requests when I mouse over the titles of results. I was testing using Fidder2 with HTTPS decryption enabled (and Firefox set to temporarily trust the fake certificate). I am logged out of Google and using a new profile created for testing.

Hilfreiche Antwort

Might be only on OSX.

Might be only on OSX.