Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

I need to 'enable download pictures/graphics' in my Comcast email.

  • 10 Antworten
  • 8 haben dieses Problem
  • 30 Aufrufe
  • Letzte Antwort von wpeary

more options

I get no images or graphics in my Comcast email. I need to 'enable download pictures/graphics' I believe to fix this. Text within a blank graphics box stated this. I'm using Firefox version 27. Windows XP. Comcast email server. Graphics quite showing in my email several months back all of a sudden. I've cleared the cache and cookies. I believe I tried resetting Firefox to default settings. I could try this again. Don't remember if I did this before or after email graphic problems. Comcast tech support could not help me. Thank you.

I get no images or graphics in my Comcast email. I need to 'enable download pictures/graphics' I believe to fix this. Text within a blank graphics box stated this. I'm using Firefox version 27. Windows XP. Comcast email server. Graphics quite showing in my email several months back all of a sudden. I've cleared the cache and cookies. I believe I tried resetting Firefox to default settings. I could try this again. Don't remember if I did this before or after email graphic problems. Comcast tech support could not help me. Thank you.

Alle Antworten (10)

more options

If images are missing then check that you do not block images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden Menu bar.

Check the permissions for the domain of the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

more options

Thanks, Cor-el (nice handle), for your valiant attempt to correct this problem of no images in my email. I ran through all the checks suggested to make sure images were not being blocked. Finally, I reset default settings for Firefox. Images still will not show. I did, however, notice in the report after resetting Firefox that it said in three places: "Blocked for your graphics card because of unresolved driver issues." It said this next to three entries: Direct 2D Enabled GPU Accelerated Windows Web GL Renderer

Could it be my graphics card or driver has a defect and needs replacing? Thank you.

more options

Do the links to those images show in "Tools > Page Info > Media"?

You can right-click such an missing image placeholder and select "View Image Info" and possibly "Inspect Element" to check out what gets selected.

more options

Cor-el, there are no links to the email images in Tools>Page Info>Media that I can see. When I right click the image placeholder and click Inspect Element, It shows line after line of what looks like code. No images loading are only a problem in my Comcast email. I've had three tech reps at Comcast try to solve it. None could. Websites load fine. Could the problem have something to do with my graphics card and driver? Thanks.

more options

I take it you're using Comcast.net Webmail and you can no longer view images in HTML mail messages. Do you have the same problem when you use another browser such as Internet Explorer to access your webmail?

If you're having a particular problem with your webmail only while using Firefox but not in other browsers, see Websites look wrong or appear differently than they should for common solutions.

Ref: Problems with email and how to find help

more options

Alice, thanks for the response. I have taken the steps laid out in the article you linked to make sure images are allowed and not blocked, and the cookies and cache are cleared. This has no effect and it's only in Comcast email. Every other web site looks fine. I'm not sure about the security software. I have Microsoft Security Essentials, Malwarebytes Anti-Malware, and Spybot S&D. I don't think these are blocking images in my email There is no indication of it from what I can see. I can see images in Internet Explorer but it runs so slow, it's unusable. I have ver. 8, running Windows XP. Thank you.

more options

I'll escalate this to the Helpdesk since the problem with Comcast webmail appears to be specific to Firefox (you said you can see images in Internet Explorer but it runs so slow, it's unusable).

more options

You also wrote earlier, Could the problem have something to do with my graphics card and driver?

I would say no, it since the problem only happens when you are using Comcast Webmail, but to rule that out, as well as to check for extension and theme conflicts, follow the steps in this article:

cor-el linked to that article in his answer to you here and that article is also linked in the Websites look wrong or appear differently than they should article. However, you didn't mention that you actually tried restarting in Firefox Safe Mode, which disables hardware acceleration and all added extensions.

more options

Hi wpeary, HelpDesk here, and I am not seeing any know issues with Comcast webmail and images that exist yet.

Please test to make sure it is not an issue from the sender. Try to send an image to yourself and see if the image works.

Are you using an email client for reading your email? If so please troubleshoot the safety options for all attachments and embedded images.

Please check the preferences to see if images are not allowed, or if there is a size issue, since it is running so slow? What is your average internet data rate and what is the size of the image? Limitations for comcast are 25MB http://customer.comcast.com/help-and-.../limitations-on-sending-email/

Geändert am von guigs

more options

Thank you Help Desk. I double checked images on both Firefox and Internet Explorer and found they don't come in on either. Comcast tech support took over my email and could see images on their end, so it's something wrong with my computer settings somewhere. When I hit reply to an email embedded with images, I can see the images. Who can explain that? It's only emails coming into my inbox that I can't see images. I did try all the Firefox remedies like starting in Safe Mode that disables add-ons and hardware acceleration, and going through plug-ins and disabling them one by one. None of this affected my image problem. So it's something unique to my computer getting incoming email and not Firefox. Thank you for your help attempts.