Hilfe durchsuchen

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

OLD Mac 10.5.8 using 3.6.28 won't allow update. HOW can i update?

  • 3 Antworten
  • 4 haben dieses Problem
  • 1239 Aufrufe
  • Letzte Antwort von cor-el

more options

I cannot afford the mac update. Just turned on this comp cos my other has a virus and this is running an old system.

PLEASE show me how to download and use the newest firefox i can!

Alle Antworten (3)

more options

Go to Mozilla.org and download the installer for the latest version.

more options

As of Firefox 17.0 and newer the minimum requirements for Mac OSX was changed to 10.6 so the last release to work on 10.5.x was Firefox 16.0 if you do not upgrade your Mac to OSX 10.6 or newer.

more options