X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Why has the function of my up & down arrow keys changed? Did I click something by accident? Help please?

Veröffentlicht

Why has the function of my up & down arrow keys changed? Did I click something by accident? Help please?

(My new kitten *might* have stood on something on my keyboard - she's done that before & put Full Screen mode on, but I managed to fix that)

Normally, I scroll down a web page a bit at a time using the down arrow key on my laptop keyboard. Since yesterday, when I press the down arrow, the page jumps to the bottom (like pressing PageDown would do) and the up arrow jumps all the way back up.

How do I set it back so that it scrolls a bit whilst I press the key?

Why has the function of my up & down arrow keys changed? Did I click something by accident? Help please? (My new kitten *might* have stood on something on my keyboard - she's done that before & put Full Screen mode on, but I managed to fix that) Normally, I scroll down a web page a bit at a time using the down arrow key on my laptop keyboard. Since yesterday, when I press the down arrow, the page jumps to the bottom (like pressing PageDown would do) and the up arrow jumps all the way back up. How do I set it back so that it scrolls a bit whilst I press the key?

Ausgewählte Lösung

hello Lancs, please press F7 in order to leave caret browsing mode - then the behaviour should be back to normal...

Diese Antwort im Kontext lesen 125

Mehr Details zum System

Installierte Plugins

  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.8 r800
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Anwendung

  • Firefox 24.0
  • User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0
  • Hilfe-URL: http://support.mozilla.com/1/firefox/24.0/WINNT/en-GB/eu/

Erweiterungen

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Twitter Address Bar Search 1 (twitter.address.bar.search@firefox.twitter)
  • avast! Online Security 8.0.1497 (wrc@avast.com) (inaktiv)
  • Ghostery 5.0.4 (firefox@ghostery.com) (inaktiv)
  • HP Smart Web Printing 4.5 (smartwebprinting@hp.com) (inaktiv)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (inaktiv)
  • NoScript 2.6.8.1 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (inaktiv)

JavaScript

  • incrementalGCEnabled: True

Grafiken

  • adapterDescription: ATI Mobility Radeon X1400
  • adapterDescription2:
  • adapterDeviceID: 0x7145
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 12-20-2005
  • driverDate2:
  • driverVersion: 8.204.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Veränderte Einstellungen

  • accessibility.browsewithcaret: True
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.warnOnClose: False
  • extensions.lastAppVersion: 24.0
  • network.cookie.cookieBehavior: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1380104488
  • places.history.expiration.transient_current_max_pages: 53635
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1380104486

Verschiedenes

  • User JS: Nein
  • Barrierefreiheit: Nein
philipp
  • Top 25 Contributor
  • Moderator
5306 Lösungen 23424 Antworten
Veröffentlicht

Ausgewählte Lösung

hello Lancs, please press F7 in order to leave caret browsing mode - then the behaviour should be back to normal...

hello Lancs, please press F7 in order to leave caret browsing mode - then the behaviour should be back to normal...
Veröffentlicht

Fragesteller

Philipp! You're an absolute hero! Thank you SO much! xXx

Philipp! You're an absolute hero! Thank you SO much! xXx
philipp
  • Top 25 Contributor
  • Moderator
5306 Lösungen 23424 Antworten
Veröffentlicht

Hilfreiche Antwort

you're very welcome - these cat-induced errors every now and then really make me smile :))

you're very welcome - these cat-induced errors every now and then really make me smile :))
cor-el
  • Top 10 Contributor
  • Moderator
17479 Lösungen 157962 Antworten
Veröffentlicht

Note that this is an accessibility feature.

  • Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages"
Note that this is an accessibility feature. *Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages" *http://kb.mozillazine.org/accessibility.browsewithcaret *http://kb.mozillazine.org/Scrolling_with_arrow_keys_no_longer_works *http://kb.mozillazine.org/Accessibility_features_of_Firefox
FredMcD
  • Top 10 Contributor
4247 Lösungen 59410 Antworten
Veröffentlicht
I found this ad-on. Check it out. '''https://addons.mozilla.org/en-US/firefox/addon/caret-out/?src=api '''
cor-el
  • Top 10 Contributor
  • Moderator
17479 Lösungen 157962 Antworten
Veröffentlicht

You do not need an extension to disable the F7 key.
Firefox has a built-in pref setting to disable the F7 key.

Set the accessibility.browsewithcaret_shortcut.enabled pref to false on the about:config page.

You do not need an extension to disable the F7 key.<br /> Firefox has a built-in pref setting to disable the F7 key. Set the <b>accessibility.browsewithcaret_shortcut.enabled</b> pref to false on the <b>about:config</b> page.
Veröffentlicht

Fragesteller

Where/How do I get to that setting, please?

Where/How do I get to that setting, please?
cor-el
  • Top 10 Contributor
  • Moderator
17479 Lösungen 157962 Antworten
Veröffentlicht

Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean

See also:

Type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key to open the <i>about:config</i> page, just like you open a website by typing the URL in the location bar. *If you see a warning message then you can confirm that you want to access the about:config page. *use the Search bar at the top of the about:config page to locate preferences more easily *preferences that have been modified and do not have the default value show as bold (user set) *preferences that are user set (bold) can be reset to the default value via the right-click context menu *preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref *preferences can be created via the right-click context menu: New -> String, Integer, Boolean See also: *http://kb.mozillazine.org/about:config
Veröffentlicht

Fragesteller

Amazing - thanks :)

Learning how to "kitten-proof" my laptop!

Seriously - THANK YOU!

Amazing - thanks :) Learning how to "kitten-proof" my laptop! Seriously - THANK YOU!
cor-el
  • Top 10 Contributor
  • Moderator
17479 Lösungen 157962 Antworten
Veröffentlicht

You're welcome.

You're welcome.
paintisnthere 0 Lösungen 1 Antworten
Veröffentlicht

Thanks for that answer Philipp...I know this is a few months late but I guess mine stopped working cause my cat barges over my keyboard for no reason either haha. The caret browsing mode you mentioned that causes this, does it make anywhere you click on a webpage bring up a text cursor like you're editing a field?

Thanks for that answer Philipp...I know this is a few months late but I guess mine stopped working cause my cat barges over my keyboard for no reason either haha. The caret browsing mode you mentioned that causes this, does it make anywhere you click on a webpage bring up a text cursor like you're editing a field?

Geändert am von paintisnthere

cor-el
  • Top 10 Contributor
  • Moderator
17479 Lösungen 157962 Antworten
Veröffentlicht

Yes, when caret browsing is enabled then you get a cursor on the web page if you click to set focus to that page.
When caret browsing mode is active then the cursor keys behave differently.

Yes, when caret browsing is enabled then you get a cursor on the web page if you click to set focus to that page.<br /> When caret browsing mode is active then the cursor keys behave differently. * http://kb.mozillazine.org/accessibility.browsewithcaret *http://en.wikipedia.org/wiki/Caret_navigation
cuefox 0 Lösungen 4 Antworten
Veröffentlicht

Thank you so very much for your great solution. I have been dealing with this issue for awhile and it was driving me crazy. The computer help online provided solutions (ugh) that were extensive and complicated that I did not have any faith in implementing any of them. YOUR F7 SOLUTION WAS RIGHT ON!! Now I have registered for Firefox help. Thank you AGAIN!! Peace! Cuefox

Thank you so very much for your great solution. I have been dealing with this issue for awhile and it was driving me crazy. The computer help online provided solutions (ugh) that were extensive and complicated that I did not have any faith in implementing any of them. YOUR F7 SOLUTION WAS RIGHT ON!! Now I have registered for Firefox help. Thank you AGAIN!! Peace! Cuefox
philipp
  • Top 25 Contributor
  • Moderator
5306 Lösungen 23424 Antworten
Veröffentlicht

hey Cuefox, thanks for your feedback - i hope you can now enjoy your browsing with firefox again as you're used to!

hey Cuefox, thanks for your feedback - i hope you can now enjoy your browsing with firefox again as you're used to!
cuefox 0 Lösungen 4 Antworten
Veröffentlicht

Hello Philipp, Yes, I enjoy using Firefox and the help was great. Being haunted by this annoying problem was frustrating. But, a simple F7 key did the trick. I am not aware how the "caret browsing," whatever this is, occurred. Instead of searching online, I ought to have searched Firefox first. I thought it was a computer problem and not the browser until I noticed that the problem did not occur when I tried it on IE8. Also, I would like to mention that I could not open only the TV Program Guide on my Optimum internet website but eventually realized that it might be an add-on that I recently installed named, Ghostery which thought be useful in not sending my information to other websites. I don't believe I am aware of how it works and/or maybe did not enable the correct settings. So, I disabled it. Thanks, cuefox

Hello Philipp, Yes, I enjoy using Firefox and the help was great. Being haunted by this annoying problem was frustrating. But, a simple F7 key did the trick. I am not aware how the "caret browsing," whatever this is, occurred. Instead of searching online, I ought to have searched Firefox first. I thought it was a computer problem and not the browser until I noticed that the problem did not occur when I tried it on IE8. Also, I would like to mention that I could not open only the TV Program Guide on my Optimum internet website but eventually realized that it might be an add-on that I recently installed named, Ghostery which thought be useful in not sending my information to other websites. I don't believe I am aware of how it works and/or maybe did not enable the correct settings. So, I disabled it. Thanks, cuefox