X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

NoSquint properly resized web pages, but the upper taskbars are still too large--for instance, I can only the beginning of the URL. How to fix?

Veröffentlicht

After the latest Firefox version magnified everything, I used the NoSquint add-on (at 60%), which now makes web pages look as they did before. However, although the top two bars at the top of the screen are of normal size, the lower ones are still too large. The bar that contains the URL on the left and a Google search space on the right, for instance, can display only the first couple of letters of a URL (after the //).

How do I make these bars look the way they used to? Thanks.

After the latest Firefox version magnified everything, I used the NoSquint add-on (at 60%), which now makes web pages look as they did before. However, although the top two bars at the top of the screen are of normal size, the lower ones are still too large. The bar that contains the URL on the left and a Google search space on the right, for instance, can display only the first couple of letters of a URL (after the //). How do I make these bars look the way they used to? Thanks.

Ausgewählte Lösung

To adjust the font size for the user interface, you can use the Theme Font & Size Changer extension.

Did this fix your problems? Please report back to us!

Thank you.

Diese Antwort im Kontext lesen 2

Mehr Details zum System

Installierte Plugins

  • Google Update
  • Shockwave Flash 11.7 r700
  • 5.1.20513.0
  • Garmin Communicator Plug-In 4.0.4.0
  • Picasa plugin
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Motive Plugin for Mozilla Browsers
  • Motive Management Plug-in for Mozilla Browsers
  • Google Updater pluginhttp://pack.google.com/
  • Garmin Communicator Plug-In 3.0.1.0
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • iTunes Detector Plug-in

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0

Weitere Informationen

user633449 1539 Lösungen 10745 Antworten
Veröffentlicht

Ausgewählte Lösung

To adjust the font size for the user interface, you can use the Theme Font & Size Changer extension.

Did this fix your problems? Please report back to us!

Thank you.

To adjust the font size for the user interface, you can use the [https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ Theme Font & Size Changer] extension. Did this fix your problems? Please report back to us! Thank you.
jscher2000
  • Top 10 Contributor
8875 Lösungen 72621 Antworten
Veröffentlicht

Hi Anne, there is a setting in Firefox that controls the scaling of both the toolbar area and the content area. I'm guessing that you have your Windows font setting at 150%. In that case, I'm going to suggest you try to manually adjust the scaling in Firefox to 125% and then set NoSquint to 80%.

Here we go!

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.25 for the equivalent of 125% font size in Windows display settings.

If you view a tab with an address bar and this is not quite right you can adjust it to a different value, such as 1.2 (120%) or 1.3 (130%).

Please do not go lower than 1.0 or everything will start to get tiny.

Once that looks right, you can go back into your NoSquint settings and up your global zoom level for content to a comfortable number.

Can you get it the way you want?

Hi Anne, there is a setting in Firefox that controls the scaling of both the toolbar area and the content area. I'm guessing that you have your Windows font setting at 150%. In that case, I'm going to suggest you try to manually adjust the scaling in Firefox to 125% and then set NoSquint to 80%. Here we go! (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''pix''' and pause while the list is filtered (3) Double-click '''layout.css.devPixelsPerPx''' and change its value to '''1.25''' for the equivalent of 125% font size in Windows display settings. If you view a tab with an address bar and this is not quite right you can adjust it to a different value, such as 1.2 (120%) or 1.3 (130%). Please do not go lower than 1.0 or everything will start to get tiny. Once that looks right, you can go back into your NoSquint settings and up your global zoom level for content to a comfortable number. Can you get it the way you want?
Veröffentlicht

Fragesteller

Thanks for the prompt answer. Before I install the Themes Font add-on, I should explain that the font size in those taskbars (for instance, in the URL) is only slightly larger than normal. But the windows in those taskbars have changed size, so that the one for the URL is now much shorter than it is in IE. (However, icons such as the back-arrow are far larger.)

Is the Themes Font add-on really the right solution, when what I want is to restore the entire appearance of the taskbars to exactly what it was before the upgrade? Thanks!

Thanks for the prompt answer. Before I install the Themes Font add-on, I should explain that the font size in those taskbars (for instance, in the URL) is only slightly larger than normal. But the windows in those taskbars have changed size, so that the one for the URL is now much shorter than it is in IE. (However, icons such as the back-arrow are far larger.) Is the Themes Font add-on really the right solution, when what I want is to restore the entire appearance of the taskbars to exactly what it was before the upgrade? Thanks!
Veröffentlicht

Fragesteller

Jscher--I'm grateful for the about:config suggestion. It was partially successful. The font size of the taskbars is now correctly adjusted. However, I can still see only a few letters of the URL; the rest are blocked by large icons. How can I change the size of the URL window--or reduce the size of the icons (lock, star, etc.) that occupy it? Thanks.

Jscher--I'm grateful for the about:config suggestion. It was partially successful. The font size of the taskbars is now correctly adjusted. However, I can still see only a few letters of the URL; the rest are blocked by large icons. How can I change the size of the URL window--or reduce the size of the icons (lock, star, etc.) that occupy it? Thanks.
jscher2000
  • Top 10 Contributor
8875 Lösungen 72621 Antworten
Veröffentlicht

Hi Anne, the Navigation Toolbar can get crowded with other items and reduce space for the URL bar. You can use the Customize feature to remove icons and create more space and, if you want to shrink the search bar to make more space for the URL bar, there is a way to do that as well.

Any luck?

Hi Anne, the Navigation Toolbar can get crowded with other items and reduce space for the URL bar. You can use the Customize feature to remove icons and create more space and, if you want to shrink the search bar to make more space for the URL bar, there is a way to do that as well. * [[Customize Firefox controls, buttons and toolbars]] * [https://support.mozilla.org/en-US/questions/952811 How do I alter the size of the web address bar?] Any luck?
Veröffentlicht

Fragesteller

Thanks. The problem was solved by the "Helpful replies" section under "How do I alter the size of the web address bar?"

I very much appreciate your help.

Thanks. The problem was solved by the "Helpful replies" section under "How do I alter the size of the web address bar?" I very much appreciate your help.
Veröffentlicht

Fragesteller

Ah. Although I have successfully enlarged the web address bar, the icons are still larger than I would like. I have checked "Choose small icons," but it doesn't seem to work.

Ah. Although I have successfully enlarged the web address bar, the icons are still larger than I would like. I have checked "Choose small icons," but it doesn't seem to work.
jscher2000
  • Top 10 Contributor
8875 Lösungen 72621 Antworten
Veröffentlicht

Hi Anne, I think what you might have to do is reduce your setting for layout.css.devPixelsPerPx a bit more until those icons look right to you. Hopefully the proportions between the icons and text will work for you. If not, then please see the extension Tylerdowner mentioned earlier to enlarge the text in the menu/toolbar/tab area.

Hi Anne, I think what you might have to do is reduce your setting for layout.css.devPixelsPerPx a bit more until those icons look right to you. Hopefully the proportions between the icons and text will work for you. If not, then please see the extension Tylerdowner mentioned earlier to enlarge the text in the menu/toolbar/tab area.
Veröffentlicht

Fragesteller

This all worked pretty well. I wish I could make the icons even smaller, but the Theme Font Changer, combined with the pixels setting, did indeed help. I'm grateful for everyone's assistance.

This all worked pretty well. I wish I could make the icons even smaller, but the Theme Font Changer, combined with the pixels setting, did indeed help. I'm grateful for everyone's assistance.
Veröffentlicht

Fragesteller

ALAS. I spoke too soon. Although the above changes improved the icons, taskbars, and font size, the latest round appears to have disabled Firefox entirely. I now see a blank screen, white on the left, gray on the right. Typing into the address area does nothing. Typing about:config does nothing. I cannot get onto any website, including Google.

I have attached a jpg of what I see. What has happened?

ALAS. I spoke too soon. Although the above changes improved the icons, taskbars, and font size, the latest round appears to have disabled Firefox entirely. I now see a blank screen, white on the left, gray on the right. Typing into the address area does nothing. Typing about:config does nothing. I cannot get onto any website, including Google. I have attached a jpg of what I see. What has happened?
jscher2000
  • Top 10 Contributor
8875 Lösungen 72621 Antworten
Veröffentlicht

Hi Anne, could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using one of these:

  • If the Help menu works: Help > Restart with Add-ons Disabled
  • If the Help menu does not work: exit Firefox, then hold the Shift key while starting it up

In the dialog that appears, click "Start in Safe Mode" (not Reset)

Does the web page display look more normal in Safe Mode? Font sizes will be different due to the disabling of the various extensions.

Hi Anne, could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using one of these: * If the Help menu works: Help > Restart with Add-ons Disabled * If the Help menu does not work: exit Firefox, then hold the Shift key while starting it up In the dialog that appears, click "Start in Safe Mode" (''not'' Reset) Does the web page display look more normal in Safe Mode? Font sizes will be different due to the disabling of the various extensions.
cor-el
  • Top 10 Contributor
  • Moderator
17763 Lösungen 160635 Antworten
Veröffentlicht

The way to proceed is to adjust the layout.css.devPixelsPerPx pref to make icons look correct because you can't change the dimensions of those icons easily otherwise.
Once the icons are correct then you can use the Theme Font & Size Changer extension to correct the font size for the user interface and the Default FullZoom Level or NoSquint extension extension to correct the appearance of the web pages.

The way to proceed is to adjust the layout.css.devPixelsPerPx pref to make icons look correct because you can't change the dimensions of those icons easily otherwise.<br /> Once the icons are correct then you can use the [https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ Theme Font & Size Changer] extension to correct the font size for the user interface and the Default FullZoom Level or NoSquint extension extension to correct the appearance of the web pages.
Veröffentlicht

Fragesteller

Jscher: Yes, Help menus works. When I started in Safe mode, Firefox worked again--the white and gray screen did not appear, and I was able to put in URLs.

However, when I exited Firefox and started it again, I was back with the immoveable gray and white page.

Since in Safe mode I can presumably get into add-ons, what should I change now?

Jscher: Yes, Help menus works. When I started in Safe mode, Firefox worked again--the white and gray screen did not appear, and I was able to put in URLs. However, when I exited Firefox and started it again, I was back with the immoveable gray and white page. Since in Safe mode I can presumably get into add-ons, what should I change now?
Veröffentlicht

Fragesteller

Update: Since the problem was presumably caused by an add-on, I looked at the add-ons, and removed something called Utility Chest, which seems to have automatically added itself when I added the Theme Font and Size Changer. Voila. Things are more or less back to normal.

Thanks to all for your help.

Incidentally, it shouldn't be this hard to undo a major change in appearance caused by a new version!

Update: Since the problem was presumably caused by an add-on, I looked at the add-ons, and removed something called Utility Chest, which seems to have automatically added itself when I added the Theme Font and Size Changer. Voila. Things are more or less back to normal. Thanks to all for your help. Incidentally, it shouldn't be this hard to undo a major change in appearance caused by a new version!
marv6 4 Lösungen 125 Antworten
Veröffentlicht

Thats a lot of work to get Firefox 22.0 to display the screens and text properly. I tried all of your suggestions and they do make some things better, but, at the same time make other things worse. Were any of the users having these problems with version 21.0 and lower? I find that on my laptop there are no problems because my windows DPI is set to 90. However, I have to set my windows DPI to 120 on my desktop to make my desktop and other applications large enough to read properly. With FF 22.0 everything in Firefox is much too large. Using your suggested settings helps for some things, but, at the same time makes my bookmarks, my webmail, and some other sites too small or too large, depending. What is wrong with making the Firefox settings like ver 21.0, which worked just fine on both my laptop and my desktop?

Thats a lot of work to get Firefox 22.0 to display the screens and text properly. I tried all of your suggestions and they do make some things better, but, at the same time make other things worse. Were any of the users having these problems with version 21.0 and lower? I find that on my laptop there are no problems because my windows DPI is set to 90. However, I have to set my windows DPI to 120 on my desktop to make my desktop and other applications large enough to read properly. With FF 22.0 everything in Firefox is much too large. Using your suggested settings helps for some things, but, at the same time makes my bookmarks, my webmail, and some other sites too small or too large, depending. What is wrong with making the Firefox settings like ver 21.0, which worked just fine on both my laptop and my desktop?
marv6 4 Lösungen 125 Antworten
Veröffentlicht

I tried nosquint, but, it will not hold it's settings and reverts back to the defaults everytime I change pages or restart. What am I missing?

I tried nosquint, but, it will not hold it's settings and reverts back to the defaults everytime I change pages or restart. What am I missing?
cor-el
  • Top 10 Contributor
  • Moderator
17763 Lösungen 160635 Antworten
Veröffentlicht

In case you are using "Clear history when Firefox closes":

  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

In case you are using "Clear history when Firefox closes": *do not clear the Site Preferences *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/Clear+Recent+History Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.
kobe 441 Lösungen 5048 Antworten
Veröffentlicht
read * [[Webpages are large and blurry after updating Firefox - how to fix]]
marv6 4 Lösungen 125 Antworten
Veröffentlicht

I do not see anything that says site preferences?

I do not see anything that says site preferences?
marv6 4 Lösungen 125 Antworten
Veröffentlicht

Found it. it is not checked.

Found it. it is not checked.