X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How to stop autoplay of videos?

Veröffentlicht

June 2013: videos on websites start playing without my permission, how to stop this?

What I tried: I uninstalled Adobe Flash (disabling Flash add-on didn't work), existing "stop autoplay" add-ons are no longer working according to reviews, tried solution described in "How can I stop videos on websites from automatically playing?" (Type in the address bar: about:config Then search for: plugins.click_to_play Double click and it will be set to true) - doesn't stop videos from playing either. Sent feedback to FireFox about the issue.

From what I had read in reviews, this is not only about Flash: YouTube disabled add-ons and searches for anything that can play videos installed in Windows, including using HTML5 for this. Have no information how other websites do it.

How to stop this? Thank you.

June 2013: videos on websites start playing without my permission, how to stop this? What I tried: I uninstalled Adobe Flash (disabling Flash add-on didn't work), existing "stop autoplay" add-ons are no longer working according to reviews, tried solution described in "How can I stop videos on websites from automatically playing?" (Type in the address bar: about:config Then search for: plugins.click_to_play Double click and it will be set to true) - doesn't stop videos from playing either. Sent feedback to FireFox about the issue. From what I had read in reviews, this is not only about Flash: YouTube disabled add-ons and searches for anything that can play videos installed in Windows, including using HTML5 for this. Have no information how other websites do it. How to stop this? Thank you.

Mehr Details zum System

Installierte Plugins

  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers

Anwendung

  • Firefox 21.0
  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Hilfe-URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Erweiterungen

  • FireFTP 2.0.14 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • PDF Viewer 0.8.1 (uriloader@pdf.js)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

Grafiken

  • adapterDescription: ATI Radeon HD 3400 Series
  • adapterDescription2:
  • adapterDeviceID: 0x95c5
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ] DISPLAY4 [ Gamma: 2200 Pixel Structure: BGR ]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 11-16-2012
  • driverDate2:
  • driverVersion: 8.970.100.7000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 3400 Series)
  • windowLayerManagerType: Direct3D 10

Veränderte Einstellungen

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: https://duckduckgo.com/?t=
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.autoHide: True
  • browser.tabs.loadInBackground: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.disable_window_move_resize: True
  • dom.event.contextmenu.enabled: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • font.internaluseonly.changed: True
  • font.minimum-size.x-western: 20
  • font.size.fixed.x-western: 18
  • font.size.variable.x-western: 18
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1371052406
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • plugins.click_to_play: True
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Verschiedenes

  • User JS: Nein
  • Barrierefreiheit: Nein
iamjayakumars 493 Lösungen 5983 Antworten
Veröffentlicht
Try with Flash block addons *https://addons.mozilla.org/en-US/firefox/addon/flashblock/ *https://addons.mozilla.org/en-US/firefox/addon/image-and-flash-blocker

Fragesteller

Thanks for suggestion, but I already completely uninstalled Adobe Flash - there is nothing not block with Flash blocks.

Thanks for suggestion, but I already completely uninstalled Adobe Flash - there is nothing not block with Flash blocks.
cor-el
  • Top 10 Contributor
  • Moderator
17690 Lösungen 160039 Antworten
Veröffentlicht

Hilfreiche Antwort

For HTML5 media you can try to set the media.autoplay.enabled pref to false on the about:config page.

For HTML5 media you can try to set the media.autoplay.enabled pref to false on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config

Fragesteller

Thank you, I did what you advised, still videos continue to load and play automatically. Maybe it's not Flash and not HTML5...

Anything else that I could try?

Thank you, I did what you advised, still videos continue to load and play automatically. Maybe it's not Flash and not HTML5... Anything else that I could try?
cor-el
  • Top 10 Contributor
  • Moderator
17690 Lösungen 160039 Antworten
Veröffentlicht

Try to set the Boolean pref media.windows-media-foundation.enabled to false on the about:config page.

Try to set the Boolean pref <b>media.windows-media-foundation.enabled</b> to <i>false</i> on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config

Fragesteller

Thanks again, appreciate it! Did that, videos continue autoload and autoplay. Anything else to try?

Thanks again, appreciate it! Did that, videos continue autoload and autoplay. Anything else to try?

Fragesteller

I'm open to suggestions and appreciate your help. The problem persists on YouTube, but many of other websites' videos are blocked, so there is some progress.

Considering another browser, but there is not much choice between major browsers, that are accepted for transactions and are secure enough. Sorry to end on such sour note.

I'm open to suggestions and appreciate your help. The problem persists on YouTube, but many of other websites' videos are blocked, so there is some progress. Considering another browser, but there is not much choice between major browsers, that are accepted for transactions and are secure enough. Sorry to end on such sour note.
kobe 441 Lösungen 5048 Antworten
Veröffentlicht

go to about:config again type in plugins.click_to_play double click it and it should come bold saying True, does it work now.

go to about:config again type in plugins.click_to_play double click it and it should come bold saying True, does it work now.

Fragesteller

Thank you! Checked, it's in bold and set "true", just as you said. Some videos on YouTube still autoload and autoplay.

What else can I try?

Thank you! Checked, it's in bold and set "true", just as you said. Some videos on YouTube still autoload and autoplay. What else can I try?
kobe 441 Lösungen 5048 Antworten
Veröffentlicht
https://addons.mozilla.org/en-US/firefox/addon/flashblock/ - Flashblock addon

Fragesteller

Sorry, see my 1st and 2nd post here: no Flash at all, there is nothing to block. Updated browser to last version, unusable now, switched to another FireFox based browser, same problem persists.

Sorry, see my 1st and 2nd post here: no Flash at all, there is nothing to block. Updated browser to last version, unusable now, switched to another FireFox based browser, same problem persists.
kobe 441 Lösungen 5048 Antworten
Veröffentlicht

Ausgewählte Lösung

https://addons.mozilla.org/en-us/firefox/addon/stop-tube/

Fragesteller

Thank you so much! At last it worked, no more forced videos. For videos, when I need them, I can always use another browser.

Thank you so much! At last it worked, no more forced videos. For videos, when I need them, I can always use another browser.
baybean 1 Lösungen 3 Antworten
Veröffentlicht

According to my add-ons manager. Stop YouTube autoplay is not compatible with this system-crippling ff22 update. This has caused multiple additional issues ....

According to my add-ons manager. Stop YouTube autoplay is not compatible with this system-crippling ff22 update. This has caused multiple additional issues ....
kobe 441 Lösungen 5048 Antworten
Veröffentlicht

According to my addons-manager it works with firefox 22+

You do understand that you are spamming many email adresses with your rants, you can though ask a new question as jscher said.

According to my addons-manager it works with firefox 22+ * https://addons.mozilla.org/en-us/firefox/addon/stop-tube/ You do understand that you are spamming many email adresses with your rants, you can though ask a new question as jscher said.

Geändert am von kobe

jscher2000
  • Top 10 Contributor
8838 Lösungen 72234 Antworten
Veröffentlicht

Hi baybean, if you are having a lot of issues, please start a new thread and include your configuration details (e.g., OS, plugins, extensions, custom settings), along with a list of the problems. Seeing them all together may help in diagnosing the root cause.

You can start here:

https://support.mozilla.org/questions/new/desktop/fix-problems

Hi baybean, if you are having a lot of issues, please start a new thread and include your configuration details (e.g., OS, plugins, extensions, custom settings), along with a list of the problems. Seeing them all together may help in diagnosing the root cause. You can start here: https://support.mozilla.org/questions/new/desktop/fix-problems
Mesem 0 Lösungen 1 Antworten
Veröffentlicht

Hilfreiche Antwort

For those of you who do not wish to use StopTube, the click to play plugin in the about:config works. You may just be missing one final step. Once you set the boolean to true, navigate to your firefox addons page and look for shockwave (adobe) flash plugin or whatever you use to play videos. Select the drop down to "ask to activate" and there you have it. When the boolean was set to false, the "ask to activate" dropdown option was unavailable.

Hope it helps.

For those of you who do not wish to use StopTube, the click to play plugin in the about:config works. You may just be missing one final step. Once you set the boolean to true, navigate to your firefox addons page and look for shockwave (adobe) flash plugin or whatever you use to play videos. Select the drop down to "ask to activate" and there you have it. When the boolean was set to false, the "ask to activate" dropdown option was unavailable. Hope it helps.
DrewA 0 Lösungen 1 Antworten
Veröffentlicht

Thank you Thank you Thank you!

Users must do both. Set value to True (plugins.click_to_play - see above) AND set Shockwave to "ask to activate." I'm using FF 24.0 and Shockwave 11.8.8 and this combination worked perfectly for me. Thank you Mesem.

Thank you Thank you Thank you! Users must do both. Set value to True (plugins.click_to_play - see above) AND set Shockwave to "ask to activate." I'm using FF 24.0 and Shockwave 11.8.8 and this combination worked perfectly for me. Thank you Mesem.