X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

MP3 or video files are playing instead of downloading

Veröffentlicht

when iam downloading the videos or mp3 files it starts playing insread of downloading

when iam downloading the videos or mp3 files it starts playing insread of downloading

Ausgewählte Lösung

Thank you philipp. I just spent about two hours trying to figure this out, checking all of my settings, uninstalling player software that I thought might be trying to take over, etc. I even did a system restore trying to fix this. Sure would be nice if a feature like this were listed in the settings options, or if a person were asked if they wanted this before it just took over their settings. Maybe that suggestion can be passed along to the right people.

One really odd thing is that the same thing has happened to Google Chrome as well, but the same cure doesn't seem to apply. Oh well, I only use Chrome for testing purposes anyway.

Thanks for providing the answer.

Diese Antwort im Kontext lesen 15

Mehr Details zum System

Anwendung

  • User-Agent:

Weitere Informationen

philipp
  • Top 25 Contributor
  • Moderator
5320 Lösungen 23495 Antworten
Veröffentlicht

Hilfreiche Antwort

hello shivamsood001, firefox 21 now makes use of the codecs that are included in your OS that enable it to directly play mp3 & mpeg files. in order to disable that, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.enabled. double-click it and change its value to false.

another way to download the files without tweaking the preference mentioned above would be to right-click the link that leads to a mp3 file or right-click the player in firefox and choose to download the file like that...

hello shivamsood001, firefox 21 now makes use of the codecs that are included in your OS that enable it to directly play mp3 & mpeg files. in order to disable that, enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.windows-media-foundation.enabled'''. double-click it and change its value to '''false'''. another way to download the files without tweaking the preference mentioned above would be to right-click the link that leads to a mp3 file or right-click the player in firefox and choose to download the file like that...
BobPeck 1 Lösungen 1 Antworten
Veröffentlicht

Ausgewählte Lösung

Thank you philipp. I just spent about two hours trying to figure this out, checking all of my settings, uninstalling player software that I thought might be trying to take over, etc. I even did a system restore trying to fix this. Sure would be nice if a feature like this were listed in the settings options, or if a person were asked if they wanted this before it just took over their settings. Maybe that suggestion can be passed along to the right people.

One really odd thing is that the same thing has happened to Google Chrome as well, but the same cure doesn't seem to apply. Oh well, I only use Chrome for testing purposes anyway.

Thanks for providing the answer.

Thank you philipp. I just spent about two hours trying to figure this out, checking all of my settings, uninstalling player software that I thought might be trying to take over, etc. I even did a system restore trying to fix this. Sure would be nice if a feature like this were listed in the settings options, or if a person were asked if they wanted this before it just took over their settings. Maybe that suggestion can be passed along to the right people. One really odd thing is that the same thing has happened to Google Chrome as well, but the same cure doesn't seem to apply. Oh well, I only use Chrome for testing purposes anyway. Thanks for providing the answer.
muckraker1960 0 Lösungen 2 Antworten
Veröffentlicht

could not find preference named media.windows-media-foundation.enabled. in my mac version of firefox.

any other suggestions?

could not find preference named media.windows-media-foundation.enabled. in my mac version of firefox. any other suggestions?
TwoLeftFeet 0 Lösungen 5 Antworten
Veröffentlicht

Somehow I downloaded an mp3 podcast that automatically starts playing when I open Firefox. How can I stop-remove the autoplay feature. I tried changing the about:config mentioned about and the mp3 podcast is still playing when I open Firefox. What's causing this and how can I eliminate it?

Somehow I downloaded an mp3 podcast that automatically starts playing when I open Firefox. How can I stop-remove the autoplay feature. I tried changing the about:config mentioned about and the mp3 podcast is still playing when I open Firefox. What's causing this and how can I eliminate it?