X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How do I prevent redirect to "wyciwyg://(number)/http://(regular url)" in Firefox Address Bar?

Veröffentlicht

The issue of occasionally getting a redirect to "wyciwyg://(number)/http://(regular URL)" in the Firefox address bar, when trying to return to some previously visited sites, has NOT been fixed.

  NONE of the previously entered alleged fixes, are fixes, or they would work for me, and they do not. A "fix", would fix it, period! 
  My workaround: simply highlight the part preceding the correct protocol and URL, delete it, and the remaining address works.
  But no Mozilla coders have come up with a way to absolutely PREVENT this from occurring. And it is very disconcerting. Others had it happen for different but specific addresses for them, I have had it only for trying to return to my yahoo.com email address by any of several methods. I have tried EVERY suggestion posted. It happens on two different computers running Win7: Pro32bit purchased retail, and Home64bit on a "stock" Dell laptop. I also experienced it on an XP Pro computer decommissioned last year.

(aka) "DrWattsOn" (i.e.: spelled that way deliberately)

The issue of occasionally getting a redirect to "wyciwyg://(number)/http://(regular URL)" in the Firefox address bar, when trying to return to some previously visited sites, has NOT been fixed. NONE of the previously entered alleged fixes, are fixes, or they would work for me, and they do not. A "fix", would fix it, period! My workaround: simply highlight the part preceding the correct protocol and URL, delete it, and the remaining address works. But no Mozilla coders have come up with a way to absolutely PREVENT this from occurring. And it is very disconcerting. Others had it happen for different but specific addresses for them, I have had it only for trying to return to my yahoo.com email address by any of several methods. I have tried EVERY suggestion posted. It happens on two different computers running Win7: Pro32bit purchased retail, and Home64bit on a "stock" Dell laptop. I also experienced it on an XP Pro computer decommissioned last year. (aka) "DrWattsOn" (i.e.: spelled that way deliberately)

Mehr Details zum System

Betroffene Websites

http://webmail.yahoo.com/

Installierte Plugins

  • VLC media player Web Plugin 2.0.2
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

Weitere Informationen

I have followed EVERY suggestion posted. It happens on two different computers running
Win7: Pro32bit purchased retail, and
Home64bit on a "stock" Dell laptop.
I also experienced it on an XP Pro computer decommissioned last year. This involves every version of Firefox. I currently am writing this via the Dell laptop I mentioned previously, using Firefox 16.0.2.
The only actual "fix" I have found involves two steps: 1)Turn off the computer. 2)Leave it off or use another browser.
I refuse to use Microsoft's browser. I only use their OS for familiarity when I work on other peoples computer problems. I have 4 Decades of experience as an Electronics TROUBLESHOOTING Tech, so I know how to think logically to fix complex things, when I have learned how they really work. That does not include Firefox, though I have used Firefox exclusively since v 3.0.

cor-el
  • Top 10 Contributor
  • Moderator
13080 Lösungen 119738 Antworten
Veröffentlicht

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

This can be a problem with the cache: wyciwyg stands for "What You Cache is What You Get"

"Clear the Cache": Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

You may have to delete the cache folder on disk to recover from this.
You can see the location on the about:cache page.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes This can be a problem with the cache: wyciwyg stands for "What You Cache is What You Get" "Clear the Cache": Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" You may have to delete the cache folder on disk to recover from this.<br /> You can see the location on the about:cache page.

Fragesteller

Hi,

  I wanted to acknowledge your prompt reply. As I stated in my original post and the "Troubleshooting" which I also filled out, I have had the problem on several computers with several different Windows OS's. I have tried every suggestion posted prior to today at Mozilla.org, on each of those computers.
  Just as did others whose posts were finally closed "4 months" ago.
  So I expect that I will merely "prove my point" by following your suggestions, which I do intend to carefully follow in the next 24 to 36 hours. 
  I will post the results, including "No Effect", as soon as I have a chance to try your suggestions. 
  Please keep in mind that the problem appears to be "intermittent" or at least, nobody has isolated any consistent causal relationship, even doesn't happen at the same URL all the time.
  You might want to re-read the closed post, which never provided a fix.

http://support.mozilla.org/en-US/questions/699151?page=1

  Again, thanks for your effort, I will soon post my results or lack thereof.

DrWattsOn ADDING Dec. 19, 2012 I decided to just work around it as described previously and accept that it won't be "fixed". Read my reply to replies below.

Hi, I wanted to acknowledge your prompt reply. As I stated in my original post and the "Troubleshooting" which I also filled out, I have had the problem on several computers with several different Windows OS's. I have tried every suggestion posted prior to today at Mozilla.org, on each of those computers. Just as did others whose posts were finally closed "4 months" ago. So I expect that I will merely "prove my point" by following your suggestions, which I '''do''' intend to carefully follow in the next 24 to 36 hours. I will post the results, including "No Effect", as soon as I have a chance to try your suggestions. Please keep in mind that the problem appears to be "intermittent" or at least, nobody has isolated any consistent causal relationship, even doesn't happen at the same URL all the time. You might want to re-read the closed post, which never provided a fix. http://support.mozilla.org/en-US/questions/699151?page=1 Again, thanks for your effort, I will soon post my results or lack thereof. DrWattsOn ADDING Dec. 19, 2012 I decided to just work around it as described previously and accept that it won't be "fixed". Read my reply to replies below.

Geändert am von DrWattsOn

Fibo 0 Lösungen 3 Antworten
Veröffentlicht

A possible solution appears here, suggesting why IE is immune to the problem http://www.experts-exchange.com/Q_27802818.html

A possible solution appears here, suggesting why IE is immune to the problem http://www.experts-exchange.com/Q_27802818.html

Fragesteller

@Fibo, Since I haven't really had the problem except as noted in my previous posts, I merely handle it as I also noted there.

  I do not play with javascript that much, though I get a sense of what it's trying to accomplish. But the link you provided goes to experts-exchange, where the "answer" is only available by starting a subscription with them, WHICH THEY WILL NEVER DELETE! And, their "Free" Trial requires the subscriber to proactively prevent them from automatic billing by "unsubscribing" which NEVER removes you from their database.
  I despise that business model. I have fallen for that elsewhere, so info on me may be everywhere, but I will not encourage yet another organization to add me to their database. I am not using hyperbole: I despise that business model. Just to sign up means they have your financial data forever. I despise the PEOPLE who do that.
  So, your reply provide me no solution, but rather, only a link to a "hook" claiming that they have the answer.
@Fibo, Since I haven't really had the problem except as noted in my previous posts, I merely handle it as I also noted there. I do not play with javascript that much, though I get a sense of what it's trying to accomplish. But the link you provided goes to experts-exchange, where the "answer" is only available by starting a subscription with them, WHICH THEY WILL NEVER DELETE! And, their ''"Free"'' Trial ''requires'' the subscriber to '''proactively''' prevent them from automatic billing by "unsubscribing" which NEVER removes you from their database. I despise that business model. I have fallen for that elsewhere, so info on me may be everywhere, but I will not encourage yet another organization to add me to their database. I am not using hyperbole: I despise that business model. Just to sign up means they have your financial data forever. I despise the '''PEOPLE''' who do that. So, your reply provide me no solution, but rather, only a link to a "hook" claiming that ''they'' have the answer.

Geändert am von DrWattsOn

ddcool 0 Lösungen 2 Antworten
Veröffentlicht

Hilfreiche Antwort

Have a look here, https://bugzilla.mozilla.org/show_bug.cgi?id=788547 solved the problem by removing old google analytics js code calling. Firefox as difficulties dealing with document.write() js function. Make sure your code doesn't include it without closing it.

WTF Mozilla !? Put my email somewhere else, I get enough spam like this !

Have a look here, https://bugzilla.mozilla.org/show_bug.cgi?id=788547 solved the problem by removing old google analytics js code calling. Firefox as difficulties dealing with document.write() js function. Make sure your code doesn't include it without closing it. WTF Mozilla !? Put my email somewhere else, I get enough spam like this !

Geändert am von ddcool

Fibo 0 Lösungen 3 Antworten
Veröffentlicht

The tone of your answer was uselessly aggressive. And proved that you do not know Expert-Exchange. You can have a free access to some answers each month, and if you contribute enough answers you have complete access for some period

Nevertheless, a more correct approach would have been something like "sorry but the link you provide is unavalable without registration", and I would havd provided the answer.

Being so aggressive to someone who proposes to help you, to implicitly suggest that this is business/ money related, is not the best way to find a solution.

But I guess you aready khew that.

The tone of your answer was uselessly aggressive. And proved that you do not know Expert-Exchange. You can have a free access to some answers each month, and if you contribute enough answers you have complete access for some period Nevertheless, a more correct approach would have been something like "sorry but the link you provide is unavalable without registration", and I would havd provided the answer. Being so aggressive to someone who proposes to help you, to implicitly suggest that this is business/ money related, is not the best way to find a solution. But I guess you aready khew that.

Hilfreiche Antwort

Fibo, thank you for your reply. 1): "The tone of your answer was uselessly aggressive." Agreed, and I sincerely apologize. 2): "And proved that you do not know Expert-Exchange." Yes. And I had no way of knowing that upfront when I went to the link while dealing with a frustrating problem. Thank you for the info. 3): "... a more correct approach would have been something like ..." . I completely agree. 4): "Being so aggressive to someone who proposes to help you,..." agreed. 5): "... to implicitly suggest that this is business/ money related". I merely stated my opinion, as in 2) preceding, I had no way of knowing it was not when a "registration" was required. And I was being paranoid. Which does NOT mean they are NOT out to get me (or, my money)! 6): " ... is not the best way to find a solution. But I guess you aready knew that. " Well I should have and I appreciate your accurate retort. And again I apologize. And I thank you for taking time to fire back at me. I did need it on all the matters raised. I will try to be more laid back and wait until my immediate frustration wears off before posting. Some of my frustration was at how others asked the same questions and got basically the same answers, and no one's answer fixed my problem, nor was it fixed by Mozilla ... whom I do appreciate. As well as you, for getting back to me. Thanks, and I apologize for my lack of manners and civility. DrWattsOn PS: The matter has not arisen for many updates (now on 20.0.1) and basically was easy to work around: click in the Address field, then knock off everything but the preface wyciwyg etc.

'''Fibo''', thank you for your reply. 1): "The tone of your answer was uselessly aggressive." Agreed, and I sincerely apologize. 2): "And proved that you do not know Expert-Exchange." Yes. And I had no way of knowing that upfront when I went to the link while dealing with a frustrating problem. Thank you for the info. 3): "... a more correct approach would have been something like ..." . I completely agree. 4): "Being so aggressive to someone who proposes to help you,..." agreed. 5): "... to implicitly suggest that this is business/ money related". I merely stated my opinion, as in 2) preceding, I had no way of knowing it was not when a "registration" was required. And I was being paranoid. Which does NOT mean they are NOT out to get me (or, my money)! 6): " ... is not the best way to find a solution. But I guess you aready knew that. " Well I should have and I appreciate your accurate retort. And again I apologize. And I thank you for taking time to fire back at me. I did need it on all the matters raised. I will try to be more laid back and wait until my immediate frustration wears off before posting. Some of my frustration was at how others asked the same questions and got basically the same answers, and no one's answer fixed my problem, nor was it fixed by Mozilla ... whom I do appreciate. As well as you, for getting back to me. Thanks, and I apologize for my lack of manners and civility. DrWattsOn PS: The matter has not arisen for many updates (now on 20.0.1) and basically was easy to work around: click in the Address field, then knock off everything but the preface wyciwyg etc.
jscher2000
  • Top 10 Contributor
3995 Lösungen 34880 Antworten
Veröffentlicht

Is there a site that reliably induces this problem for you? Some sites were mentioned in the other thread, but I don't know whether it's different for everyone.

Is there a site that reliably induces this problem for you? Some sites were mentioned in the other thread, but I don't know whether it's different for everyone.

Fragesteller

jscher2000: It doesn't seem to happen anymore since several updates ago. As I recall, it only happened at my mailbox at yahoo, and it is unrelated to whether I had to log back on because I set a 2 week expiration on my local computer. It happened when selecting a tab that already had the last place I was at when at yahoo (usually the Inbox, and never the Log In page). As I said, I just dispensed with the preface in the Address bar.Hope this adds to the data helpfully.

'''jscher2000:''' It doesn't seem to happen anymore since several updates ago. ''As I recall,'' it only happened at my mailbox at yahoo, and it is unrelated to whether I had to log back on because I set a 2 week expiration on my local computer. It happened when selecting a tab that already had the last place I was at when at yahoo (usually the Inbox, and never the Log In page). As I said, I just dispensed with the preface in the Address bar.Hope this adds to the data helpfully.

Geändert am von DrWattsOn

Fibo 0 Lösungen 3 Antworten
Veröffentlicht

The problem is caused by document.write not working in FF as the other browsers: in FF it should be used only at load time, not later.

So the problem has 2 solutions: - if you have no control over the javascript remove extra characters in the address bar - if this is your javascript, try to replace your document.write by creating a div with an id and use document.getElementById('the_id') += 'the_text'

The problem is caused by document.write not working in FF as the other browsers: in FF it should be used only at load time, not later. So the problem has 2 solutions: - if you have no control over the javascript remove extra characters in the address bar - if this is '''your''' javascript, try to replace your document.write by creating a div with an id and use document.getElementById('the_id') += 'the_text'
ddcool 0 Lösungen 2 Antworten
Veröffentlicht

or add document.close() after the doment.write() call.

or add document.close() after the doment.write() call.