Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Can't copy translated text from Google Translate web page?

  • 27 Antworten
  • 11 haben dieses Problem
  • 1319 Aufrufe
  • Letzte Antwort von cor-el

more options

It seems this happened after Firefox latest update. I can't seem to be able to copy the translated text box in Google Translate. I tried using IE and that worked. Hopefully you guys can test it on your side to see if it's working for you?

I also tried it with disabling Adblock Plus, but that didn't help.

Ausgewählte Lösung

This seems to be working correctly after updating to the newest flash player this morning.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (7)

more options

Hi GaleAbraham, are you asking how large a selection is needed to crash Firefox? Could you clarify your question and to whom it is directed?

more options

I am having this problem also!

more options

Hi TheTexan1984, this seems to be an incompatibility with the scripts on Google Translate. Three workarounds have been documented in this thread. To summarize:

Hold Ctrl+c

Holding Ctrl+c seems to bypass or overload the script. Hold Ctrl+c until the large textbox to the left starts flashing, which may take 5-7 seconds.

Disable sites from intercepting clipboard commands

You can prevent websites from intercepting and/or canceling cut/copy/paste actions by changing a setting in the about:config preferences editor. Unfortunately, this is a global setting, so if some site is doing something positive by intercepting and canceling or replacing your cut/copy/paste action, you will lose that benefit. Still, if this Google translate problem is a major issue for you, it's probably worth a try.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste clipb and pause while the list is filtered

(3) Double-click dom.event.clipboardevents.enabled to switch its value to false. You're done with this tab.

You might need to reload the Google translate page in order for this to take effect.

Use a bookmarklet to copy the translation text

Instead of using Ctrl+c or right-click>Copy, you could use a bookmarklet -- a script that you save as a bookmark and click when you want to run it. This one is specific to the Google Translate site as of today (changes to the page could break it).

(1) Copy the following line of code (it's all one line):

javascript:void(window.prompt("Copy translation result (e.g., Ctrl+c Enter):",document.getElementById("result_box").textContent));

(2) Right-click the Bookmarks Toolbar and choose New Bookmark

(3) Paste the code in as the Location

(4) Name the bookmark as you wish (for example, CopyGoogTrans)

Now, to copy, instead of selecting the result text, click the bookmark and follow the instructions.

more options

Ausgewählte Lösung

This seems to be working correctly after updating to the newest flash player this morning.

more options

Thanks.

Yes, after updating to the new flash player: Adobe Flash Player 11.5.502.110 http://get.adobe.com/flashplayer/

It works now!

more options

Are you sure that is the resolution because I am still on 11.4.402.287 and since this morning the problem doesn't occur implying that there must have been some other resolution.

btw I see this is under XP whereas I was having the problem under Win 7

Geändert am von gluepack

more options

See also:

  1. 1
  2. 2