Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Can't copy translated text from Google Translate web page?

  • 27 Antworten
  • 11 haben dieses Problem
  • 1324 Aufrufe
  • Letzte Antwort von cor-el

more options

It seems this happened after Firefox latest update. I can't seem to be able to copy the translated text box in Google Translate. I tried using IE and that worked. Hopefully you guys can test it on your side to see if it's working for you?

I also tried it with disabling Adblock Plus, but that didn't help.

Ausgewählte Lösung

This seems to be working correctly after updating to the newest flash player this morning.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (20)

more options

Sorry, false alarm. I fixed it by disabling Flash Block. Before it used to work without having to disable it, but I guess something must have changed since then. I use the translate site frequently and almost every other day, so it must have happened during a recent update.

I now added Google translate to my white-list in Flash Block and now I can copy and paste the translated box without an issue.

Before it was not allowing me to paste the copied content.

more options

I don't think it was a false alarm, because this is happening to me also, as of tonight. I do have flashblock, but disabling it does not help me. Disabling all addons also does not help, nor does clearing all cache, history, and cookies. So far I have only noticed this on Google Translate. The right click context menu is there, and I can choose copy, but nothing goes to the clipboard. The keyboard shortcut for copy also does not work. I can paste into the "translate from" box, but I can't copy the translated text. This only happens in Firefox. Everything works normally in Chrome, IE, and Opera.

more options

I can confirm that the Google Translate page doesn't work for me as well if I try to copy the translated text to the clipboard.

Looks that there is some JavaScript running that is preventing the clipboard from working.
I can drag the selected text to a text area like this one, but the clipboard only works if I disable JavaScript.
There seems to be something on the clipboard (paste is enabled and previous clipboard content is lost).

Hopefully will Google fix this issue soon.

more options

Hi thebigchief, I have the same problem on Google Translate. I don't know what's going on there because Firefox usually does not let sites play with the clipboard.

As a workaround until someone figures out what is going wrong there, you could use a bookmarklet -- a script that you save as a bookmark and click when you want to run it. This one is specific to the Google Translate site as of today (changes to the page could break it).

(1) Copy the following line of code (it's all one line):

javascript:void(window.prompt("Copy translation result (e.g., Ctrl+c Enter):",document.getElementById("result_box").textContent));

(2) Right-click the Bookmarks Toolbar and choose New Bookmark

(3) Paste the code in as the Location

(4) Name the bookmark as you wish (for example, CopyGoogTrans)

Now, to copy, instead of selecting the result text, click the bookmark and follow the instructions.

more options

You guys are right. It stopped working for me today, again. I disabled flash block, but that doesn't fix it. So it's still an issue.

Curious? How come some posts above are doubled-posted? Was strange to read the same posts more than once.

more options

Hi, I too have the same problem: I disabled the plugin and tried it in safe mode but I haven't solved. Solved using bingtranslator. I hope that this bag will be solved. Excuse me for my English.

more options

In FireFox 16.0.2 I click copy translated text from Google Translate field , and when I try paste text in any another field - nothing happens, text don't pasted, WTF Mozilla ? Before all worked normally! cache and cookie cleaned fully, did not help!

more options

@cor-el - You wrote: "Hopefully will Google fix this issue soon."

I don't see how this is Google's problem to fix. They don't serve up a different page for different browsers. This problems does not happen in other browsers, and only began to happen after the latest FF update. It is Firefox's problem to fix.

more options
more options

there's bug #807599 for the issue, which appears to offer a workaround in comment 8 (please don't post in bug reports).

more options

what the hell a workaround? Users needs normal work favorite browser! What is that you made a circus? When Mozilla will update with fixed this bug ?

more options

Comment 12 in that bug references another workaround: holding Ctrl+c for 1-2 seconds. I find that you have to keep holding Ctrl+c until the large textbox to the left starts flashing to be confident that the text actually has been copied to the clipboard. That could take 5-7 seconds or some other random amount of time. So strange.

more options

Hi zemix89, as madperson noted, a bug report is on file with the developers. Here on the support board, I don't think we can offer much more than workarounds at this point.

more options

dude why people suffer this garbage? All just need a normal job functions to copy / paste? In this I do not see anything complicated that to resort to which is perverted! All we need an explanation and fix from the developers with the curves hands!

more options

2 jscher2000

"I find that you have to keep holding Ctrl+c until the large textbox to the left starts flashing to be confident that the text actually has been copied to the clipboard.3-5 sec"


more options

To clarify the workaround madperson mentioned, you can prevent websites from intercepting and/or canceling cut/copy/paste actions by changing a setting in the about:config preferences editor. Unfortunately, this is a global setting, so if some site is doing something positive by intercepting and canceling or replacing your cut/copy/paste action, you will lose that benefit. Still, if this Google translate problem is a major issue for you, it's probably worth a try.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste clipb and pause while the list is filtered

(3) Double-click dom.event.clipboardevents.enabled to switch its value to false. You're done with this tab.

You might need to reload the Google translate page in order for this to take effect.

more options

Flipping the pref works instantly for me.

I need to hold down the Ctrl+C key quite a long time to make this work.
At some point the selection is lost and then it possibly is OK and the text in on the clipboard.
Maybe so may copy commands get cued that the script that prevents it isn't run.

more options

@ jscher2000 , your script works great for me. I added that to my bookmark bar. Thanks. Hopefully it will be fixed. Perhaps the error is with Google?

more options

Thanks for the heads up about holding down Ctl-C for a while (in my case it is only really a couple of seconds at most).

The fact that it wouldn't paste into something like notepad wasn't a big deal, the big problem I had was that after doing the copy it was crashing a mmporg that I was running when pasting.

more options

Thanks, How much text copy will it do? Abe

  1. 1
  2. 2