X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox address field hide the last part of the address when loaded.

Veröffentlicht

Firefox hide the last part of the entered address when it have been loaded.

Firefox hide the last part of the entered address when it have been loaded.

Geändert am von RobinHood

Ausgewählte Lösung

Firefox adressbar works now . That is after a complete reinstall and also a Windows system restore. I had search with different boot search programs but nothing - becouse the fault came after reinstalls reboot wWindows. So I though it was a boot malware or trojan. When I again did a reinstall sudenly the fault came before reboot Windows. So I look at restore points and saw I 10 days earlier did a system restore bu the same day anger that. I think something got wrong there. I restore to 11 days earlier instaed and the old Firefox 15.0 appeared. From that point I could upgrade once again to 15.0.1 and Firefox adress bar worked. Then Windows upgrades could start. Thanks for suggestions !

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Das passierte

Immer wenn Firefox geöffnet wird

Das begann, als…

don´t know

Installierte Plugins

  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Nokia Suite Enabler Plugin
  • VLC media player Web Plugin 2.0.2
  • Nexus Personal Plug-Ins
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • IE Tab Plug-in for Mozilla/Firefox

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

Weitere Informationen

philipp
  • Top 25 Contributor
  • Moderator
5330 Lösungen 23538 Antworten
Veröffentlicht

hello RobinHood, do you mean the http://-part of an url? you can change that...

enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.urlbar.trimURLs - double-click it in order to change the default to false.

hello RobinHood, do you mean the ''http://''-part of an url? you can change that... enter '''about:config''' into the firefox location bar (confirm the info message in case it shows up) & search for the preference named '''browser.urlbar.trimURLs''' - double-click it in order to change the default to '''false'''.

Hilfreiche Antwort

No the last part of the adress . See picture.

No the last part of the adress . See picture.
philipp
  • Top 25 Contributor
  • Moderator
5330 Lösungen 23538 Antworten
Veröffentlicht

Hilfreiche Antwort

maybe an extension or theme is interfering here. please try launching firefox in safe mode once and see if the issue is occurring there too.

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

maybe an extension or theme is interfering here. please try launching firefox in safe mode once and see if the issue is occurring there too. [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]

Fragesteller

Running in Safe Mode Firefox still hides the last part of the address field. Maby I have to reset the installation.

The only thing I´ve done is this - taken from a Computer tech paper :

http://techworld.idg.se/2.2524/1.465718/sa-slipper-du-acrobat-reader-i-firefox-15

TRANSLATED: "From Firefox 15, you can read PDF files directly in the browser if you just know how to do.

Go up in the address bar and type about: config. In the search box that appears, enter browser.preferences.inContent and hit enter. Ensure that the value of the variable is "true".

In the next step, look at pdfjs.disabled. Double-click to set the value of the variable to "false".

Then restart Firefox and test by clicking on a PDF document. Now, the document opens directly in the browser and you do not make use of third-party applications such as Adobe Acrobat Reader. "

Running in Safe Mode Firefox still hides the last part of the address field. Maby I have to reset the installation. The only thing I´ve done is this - taken from a Computer tech paper : http://techworld.idg.se/2.2524/1.465718/sa-slipper-du-acrobat-reader-i-firefox-15 TRANSLATED: "From Firefox 15, you can read PDF files directly in the browser if you just know how to do. Go up in the address bar and type about: config. In the search box that appears, enter browser.preferences.inContent and hit enter. Ensure that the value of the variable is "true". In the next step, look at pdfjs.disabled. Double-click to set the value of the variable to "false". Then restart Firefox and test by clicking on a PDF document. Now, the document opens directly in the browser and you do not make use of third-party applications such as Adobe Acrobat Reader. "
philipp
  • Top 25 Contributor
  • Moderator
5330 Lösungen 23538 Antworten
Veröffentlicht

hello, no the pdf addon shouldn't be a problem. you could try disabling hardware acceleration and firefox > options > advanced > general and see if this is making a difference (although hw acceleration should be already switched off during safemode).

if this doesn't work either, please try resetting firefox (this will keep your passwords and bookmarks).

hello, no the pdf addon shouldn't be a problem. you could try disabling hardware acceleration and firefox > options > advanced > general and see if this is making a difference (although hw acceleration should be already switched off during safemode). if this doesn't work either, please try [[Reset Firefox – easily fix most problems|resetting firefox]] (this will keep your passwords and bookmarks).

Fragesteller

Det only solution seemed to be a reinstall.

When I think in my mind I remember Firefox had have some peculiar behavior last three month. First there was - in blank start page - a line in the middle. But I couldn´t see it in the code for about:blank. Maybe thats not possible. That Line disapperad after Firefox 15 release. Then after an install a SSD on this computer - with a new image of old HDD. Then Sync synced Addons I had to start Firefox as many times as I had the number of Addons installed which was 5 . Someting gott corupted I think.

Anyway - now Firefox works - and it is still the best  ;-)

Det only solution seemed to be a reinstall. When I think in my mind I remember Firefox had have some peculiar behavior last three month. First there was - in blank start page - a line in the middle. But I couldn´t see it in the code for about:blank. Maybe thats not possible. That Line disapperad after Firefox 15 release. Then after an install a SSD on this computer - with a new image of old HDD. Then Sync synced Addons I had to start Firefox as many times as I had the number of Addons installed which was 5 . Someting gott corupted I think. Anyway - now Firefox works - and it is still the best ;-)

Fragesteller

No, now the adress problem is back. But that is after restart computer... I´ve exact the same configuration at two other computers - but not this adress hide problem. They are all using Sync too. It is just this computer. I did a complete reinstall - so I don´t understand ? In Win7 Control panel / programs there where two Firfox - 15 and 15.1 . I unstill both and fetch a new file Firefox 15.1 . Could it be a Malware ? It came back after restart computer ...

No, now the adress problem is back. But that is after restart computer... I´ve exact the same configuration at two other computers - but not this adress hide problem. They are all using Sync too. It is just this computer. I did a complete reinstall - so I don´t understand ? In Win7 Control panel / programs there where two Firfox - 15 and 15.1 . I unstill both and fetch a new file Firefox 15.1 . Could it be a Malware ? It came back after restart computer ...

Geändert am von RobinHood

philipp
  • Top 25 Contributor
  • Moderator
5330 Lösungen 23538 Antworten
Veröffentlicht

you can ignore the two separate entries in the windows control panel - there's actually only one version installed, but because of a glitch in the update to version 15.0.1 the outdated entry wasn't removed. you don't need to take any action for that, it will be corrected on the next update...

back to your original question: yes it sounds quite suspicious, i've never come across something like it before. you should probably do a full scan of your system with the security software already in place and/or a different tool like the free version of malwarebytes...

you can ignore the two separate entries in the windows control panel - there's actually only one version installed, but because of a glitch in the update to version 15.0.1 the outdated entry wasn't removed. you don't need to take any action for that, it will be corrected on the next update... back to your original question: yes it sounds quite suspicious, i've never come across something like it before. you should probably do a full scan of your system with the security software already in place and/or a different tool like the [http://www.malwarebytes.org/products/malwarebytes_free free version of malwarebytes]...

Fragesteller

No nothing suspicious with a Malwarebytes scan . I have no idea ... As I said - it works on the two other computers . Strange that it work before restart computer . It still sounds like a Malware or Trojan ? But I´ve also scan with Comodo Internet Security - but nothing except Nirsoft installed but that a computer magazine said it is safe as long as I control it. But Antivirus program think it is suspicious.

Now I have reinstalled Firefox and after that it works. Also after restart Firefox. But after restart computer the problem where there again. Now I am quite sure there is a Trojan or Malware activated by boot or something . I´m going to test other "boot scan tools" . Maybe SpyBoot ? Emisoft ? moore ?

No nothing suspicious with a Malwarebytes scan . I have no idea ... As I said - it works on the two other computers . Strange that it work before restart computer . It still sounds like a Malware or Trojan ? But I´ve also scan with Comodo Internet Security - but nothing except Nirsoft installed but that a computer magazine said it is safe as long as I control it. But Antivirus program think it is suspicious. Now I have reinstalled Firefox and after that it works. Also after restart Firefox. But after restart computer the problem where there again. Now I am quite sure there is a Trojan or Malware activated by boot or something . I´m going to test other "boot scan tools" . Maybe SpyBoot ? Emisoft ? moore ?

Geändert am von RobinHood

cor-el
  • Top 10 Contributor
  • Moderator
17690 Lösungen 160043 Antworten
Veröffentlicht

Maybe the trailing part is too faint to see.

You can set the browser.urlbar.formatting.enabled pref to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly.

You can set the browser.urlbar.trimURLs pref to false on the about:config page to see the http: protocol on the location bar and in the pop-up if you hover a link.

Maybe the trailing part is too faint to see. You can set the <b>browser.urlbar.formatting.enabled</b> pref to <i>false</i> on the <b>about:config</b> page to disable the highlighting of the domain and see the full URL more clearly. You can set the <b>browser.urlbar.trimURLs</b> pref to <i>false</i> on the <b>about:config</b> page to see the http: protocol on the location bar and in the pop-up if you hover a link. *http://kb.mozillazine.org/about:config

Geändert am von cor-el

Fragesteller

I did that but nothing change with Highlight (swedebank) or without Highlight (wikimedia) . It seems to be the length of the address - see example pic here with adress slackware.com - which is OK , but also short.

But it is strange that it is ok when I reinstall Firefox - but the same after computer restart and only this computer. I have the same configuration and Addons in 2 other computers with Firfox installed. And there are Sync between these 3 Firefox.

Something happens at boot time I think. I´m going to search boot malware/trojan with Spyboot , or some other program . Tip ?

I did that but nothing change with Highlight (swedebank) or without Highlight (wikimedia) . It seems to be the length of the address - see example pic here with adress slackware.com - which is OK , but also short. But it is strange that it is ok when I reinstall Firefox - but the same after computer restart and only this computer. I have the same configuration and Addons in 2 other computers with Firfox installed. And there are Sync between these 3 Firefox. Something happens at boot time I think. I´m going to search boot malware/trojan with Spyboot , or some other program . Tip ?

Geändert am von RobinHood

cor-el
  • Top 10 Contributor
  • Moderator
17690 Lösungen 160043 Antworten
Veröffentlicht

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Fragesteller

Thanks for your advices but all that is already done.

Thanks for your advices but all that is already done.
cor-el
  • Top 10 Contributor
  • Moderator
17690 Lösungen 160043 Antworten
Veröffentlicht

Try to do a clean reinstall and delete the Firefox program folder (C:\Program Files (x86)\Mozilla Firefox\) before reinstalling a fresh copy of Firefox.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


Try to do a clean reinstall and delete the Firefox program folder (C:\Program Files (x86)\Mozilla Firefox\) before reinstalling a fresh copy of Firefox. *http://kb.mozillazine.org/Installation_directory Download a fresh Firefox copy and save the file to the desktop. *Firefox 15.0.x: http://www.mozilla.org/en-US/firefox/all.html Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software. *Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Fragesteller

Well I uninstall Firefox and program folder disappeared . I run CCleaner on registry. CCleaner ask for delete Firefox history , bookmarks etc. - because I have backup . I reboot computer an installed Firefox - and for some reason bookmarks was there ! CCleaner didnt delete it. Firefox worked perfekt. Then I reboot computer and the fault was there again..

I think I have to manually delete Firefox data folders in Personal folders. (Local, Roaming etc. ) Now I need a day in rest mode. I´ll be back.

Well I uninstall Firefox and program folder disappeared . I run CCleaner on registry. CCleaner ask for delete Firefox history , bookmarks etc. - because I have backup . I reboot computer an installed Firefox - and for some reason bookmarks was there ! CCleaner didnt delete it. Firefox worked perfekt. Then I reboot computer and the fault was there again.. I think I have to manually delete Firefox data folders in Personal folders. (Local, Roaming etc. ) Now I need a day in rest mode. I´ll be back.

Fragesteller

Now I have reinstalled Firefox again and let the uninstaller to remove personal data. But just in case, I checked the program folder /Mozilla/Firefox was gone. And this time that all Firefox folders under /AppData (/Local /LocalLow /Roaming) etc were gone.

I installed Firefox from a new download. I didnt install extensions - and did not activate Sync this time. Thus a completely clean install. Adresses Address bar then looked completely normal.

Then I restarted the computer - and the error was back ! The last part of the address can not be seen.

There must be some junk at boot time?

Must take a log on the boot ... Tip?

Now I have reinstalled Firefox again and let the uninstaller to remove personal data. But just in case, I checked the program folder /Mozilla/Firefox was gone. And this time that all Firefox folders under /AppData (/Local /LocalLow /Roaming) etc were gone. I installed Firefox from a new download. I didnt install extensions - and did not activate Sync this time. Thus a completely clean install. Adresses Address bar then looked completely normal. Then I restarted the computer - and the error was back ! The last part of the address can not be seen. There must be some junk at boot time? Must take a log on the boot ... Tip?
philipp
  • Top 25 Contributor
  • Moderator
5330 Lösungen 23538 Antworten
Veröffentlicht

could you do a scan with hijackthis, paste the result into http://pastebin.com/ & post the link here (when you paste directly into the replay in this forum the formatting would be scrambled)?

could you do a scan with [http://sourceforge.net/projects/hjt/ hijackthis], paste the result into http://pastebin.com/ & post the link here (when you paste directly into the replay in this forum the formatting would be scrambled)?

Fragesteller

Here´s a boot up scan http://pastebin.com/YBvkQepe

Here´s a boot up scan http://pastebin.com/YBvkQepe
philipp
  • Top 25 Contributor
  • Moderator
5330 Lösungen 23538 Antworten
Veröffentlicht

hm, nothing out of the ordinary there... the one last thing that comes to my mind is to disable plugins (especially the nokia, nexus & ie-tab one) & see if this makes a difference.

edit: you can disable plugins in firefox > addons > plugins

ie-tab was mentioned here in the forums in the past for causing some issues regarding the address-bar.

hm, nothing out of the ordinary there... the one last thing that comes to my mind is to disable plugins (especially the nokia, nexus & ie-tab one) & see if this makes a difference. ''edit: you can disable plugins in firefox > addons > plugins'' ''ie-tab was mentioned here in the forums in the past for causing [https://support.mozilla.org/questions/751072 some] [https://support.mozilla.org/questions/753101 issues] regarding the address-bar.''

Geändert am von philipp

Fragesteller

Nokia and Nexus is not extensions.

Edit : Oh yes - now I se - they are plugins but I also have them as programs. Well I can uninstall them for a try. But I had have them a long time and this problem occur the last two weeks. I Also have the same plugins for a long timev in the two other Firefox of mine .

Now I inactivated all plugins but there are no differences.

But there are another suggention at the swedish forum. Look at answers in the swedish forum where "Cecilia" suggest to run DDS-scan for more proper function with 64-bit.

http://eforum.idg.se/topic/337994-firefox-doljer-sista-delen-av-adressen-i-adressfaltet/page__gopid__1588955#entry1588955 .

You can translate by Google Translate or just follow the new link to DDS-Scan below.

DDS-Scan : http://pastebin.com/kKUXyyWM

Nokia and Nexus is not extensions. Edit : Oh yes - now I se - they are plugins but I also have them as programs. Well I can uninstall them for a try. But I had have them a long time and this problem occur the last two weeks. I Also have the same plugins for a long timev in the two other Firefox of mine . Now I inactivated all plugins but there are no differences. But there are another suggention at the swedish forum. Look at answers in the swedish forum where "Cecilia" suggest to run DDS-scan for more proper function with 64-bit. http://eforum.idg.se/topic/337994-firefox-doljer-sista-delen-av-adressen-i-adressfaltet/page__gopid__1588955#entry1588955 . You can translate by Google Translate or just follow the new link to DDS-Scan below. DDS-Scan : http://pastebin.com/kKUXyyWM

Geändert am von RobinHood