Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF will not display search results from realtor.com website

  • 17 Antworten
  • 1 hat dieses Problem
  • 840 Aufrufe
  • Letzte Antwort von dumdidadida

more options

This problem has been so frustrating it actually got me to finally upgrade from 3.6 to 12.0. Sadly (for me), the problem still existed after upgrade.

When I put it any zipcode or any search criteria for searching on the main page (Find a home) of REALTOR.COM and press the Orange SEARCH button, only the banner displays, not the search results. The url that shows up on the mostly empty page is bogus and seems incomplete (http://www.realtor.com/search/SearchRoute.aspx?). The url that shows up on a working environment after a search is http://www.realtor.com/realestateandhomes-search/01740 (e.g.).

Ausgewählte Lösung

I was about to dig in and start deep troubleshooting with profile recreation when I decided to just eyeball the list of "important" user preferences shown in about:support and compare it visually with the same page on my laptop. There are several screenfuls of settings (mostly printer stuff), but one preference just jumped out at me as suspicious and it was present on my PC but not on my laptop. It was the guilty culprit!!!

network.http.sendRefererHeader 0

I vaguely recall setting that to zero some time ago after reading some discussions about privacy issues and that a 0 setting would reduce tracking. When I saw that the laptop did not have it set as a user pref, I read more about this key and found: "Caveats: Disabling Referer headers may cause some functionality on some sites to no longer work. "

Ta-da!!! problem solved!!!

I still may go do some prefs cleanup anyhow, but at least this nagging problem is gone!!

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (17)

more options

Hi,

If you are using the latest Firefox, you can try the Reset Firefox feature via Help (Alt + H) > Troubleshooting Information.

(To revert to the previous profile you were using, close the new profile (i.e. exit Firefox), start Firefox and choose the Default User profile. While the Profile Manager is open, you can also delete the newly reset profile (the one containing random numbers), or the former profile, as the case may be). If the reset is okay, it would be a good idea to delete the old profile as otherwise it would be left intact with the previous data until deleted.

Managing profiles

Profiles Howto

more options

hmmm...seems a bit drastic for me. I don't want to lose the items that will be lost. I would like to uncover the root cause.

more options

Actually you won't lose the previous profile as long as you don't delete it. If the reset profile is okay, you can exit and open Firefox in the old profile, and then try to troubleshoot it.

more options

I read the part about "Warning: When using the reset feature, the following items are either NOT SAVED or set to their defaults." and got scared off. Are those items restorable or not? confusing. Maybe in the morning after coffee, I will get it :-)

more options

Can you/Did you try to reproduce my problem?

more options

The "NOT SAVED or set to their defaults" items still exists in the previous profile. Actually the whole previous profile is still present, kingdom intact. You can switch to that after exiting Firefox. The previous profile would be usually named Default User and the newly reset profile would have random numbers in its name. I tried the search in the range $20,000 to $200,000 and there were seven pages, 10 results with thumbnails on each page sorted from the highest priced to the lowest. Clicking on a thumbnail/link takes you to a page with details, map, photos etc.

more options

As expected, a new blank profile did not have the problem. However, then what? I barely recognized the browser I was running. It would take enormous effort to convert that browser to my comfort-zone browser, piece by piece to isolate the factors involved. And it is highly unlikely I would totally capture everything I once had. I would be surprised and missing things for months I imagine.

I also saw a gazillion crash reports (pending and submitted) in the old profile's folders dated yesterday (12.0 upgrade) and today. Could be another red herring though. I see that FF 12.0 is known for that.

more options

You can open Help (Alt + H) > Troubleshooting Information and copy or print the Extensions section to easily install the extensions into the new profile. You can also browse to Tools (Alt + T) > Add-ons > Appearance to get the name of the currently enabled theme (if any).

more options

thanks, but that would be a drop in the bucket to get it the way I had it.

I want to troubleshoot the actual problem in the actual profile if I can.

more options

I'm looking at prefs.js and see tons and tons of crap and unknown stuff in my old one -- 590 lines!! The new profile has 39 lines.

I might try cleaning up that file in chunks at a time to see if there is something in there causing mayhem.

At a minimum, just to tidy up, there are many prefs relating to ancient unused add-ons that don't need to be there.

more options
more options

Done most of that. The standard diagnostic link has some goodies in it. It looks time-consuming, but I am carrying around many years of crud, so it might be a good investment of time to clean up, regardless of this problem. I do have a funny feeling about the stuff in prefs.js though. I may start there anyhow. At least now I have a clean testing profile to compare to.

It would be nice to troubleshoot backwards from the symptom (www.realtor.com/search/SearchRoute.aspx?) to something even mildrly related, but I don't know asp enough to even guess at what it was trying to do.

At least I've got all my plugins and add-ons up-to-date, which is rare for me. Can't blame anything on stale software. (I'm of the mindset if it ain't broke, don't fix it and hate to update arbitrarily. Mostly causes more headaches and work. But this time I can't blame this problem on the update.)

more options

An easy way to clean the prefs.js would be to Reset all user preferences to Firefox defaults: and Make Changes and Restart in the Safe Mode start screen. You may get a permissions screen at the next startup (the first image). You can choose to simply Continue which would disable the said add-on until enabled again. Otherwise you can also choose to Allow... and Continue. Remember to Restart only at the last tab.

more options

But I don't want to reset all of them. I depend on most of them. I need to narrow it down to the problematic ones -- if any. I will attempt to do it in binary fashion... halves, quarters, etc. First I will remove all the ones that are associated with removed add-ons.

I could also test the other way. I could move chunks of old profile into new profile and then install my potentially-corrupt prefs.js into mynew testing profile. although will need to globally edit paths first. Might be spaghetti project tho.

I was reading this page that looked like fun:

http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

I think that info would help avoid the spaghetti element.

more options

That seems to be a very good start. Hope you are able to quickly isolate the issue.

more options

Ausgewählte Lösung

I was about to dig in and start deep troubleshooting with profile recreation when I decided to just eyeball the list of "important" user preferences shown in about:support and compare it visually with the same page on my laptop. There are several screenfuls of settings (mostly printer stuff), but one preference just jumped out at me as suspicious and it was present on my PC but not on my laptop. It was the guilty culprit!!!

network.http.sendRefererHeader 0

I vaguely recall setting that to zero some time ago after reading some discussions about privacy issues and that a 0 setting would reduce tracking. When I saw that the laptop did not have it set as a user pref, I read more about this key and found: "Caveats: Disabling Referer headers may cause some functionality on some sites to no longer work. "

Ta-da!!! problem solved!!!

I still may go do some prefs cleanup anyhow, but at least this nagging problem is gone!!

more options