X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox 11 not displaying pdfs with Adobe Reader update (MacOS)

Veröffentlicht

Since updating to Adobe Reader 10.1.3, I noticed Firefox 11 does not display PDF files. It just shows a blank screen.

The only workaround I found is disabling the Adobe Acrobat NPAPI Plug-in (ver. 10.1.3) the update installs. Firefox will prompt which application to use.Choosing Preview allows the PDFs to display correctly.

Neither Chrome or Safari exhibit this behavior, nor does Firefox 11 (Windows) with the update installed.

Has anyone else experienced this?

Since updating to Adobe Reader 10.1.3, I noticed Firefox 11 does not display PDF files. It just shows a blank screen. The only workaround I found is disabling the Adobe Acrobat NPAPI Plug-in (ver. 10.1.3) the update installs. Firefox will prompt which application to use.Choosing Preview allows the PDFs to display correctly. Neither Chrome or Safari exhibit this behavior, nor does Firefox 11 (Windows) with the update installed. Has anyone else experienced this?

Mehr Details zum System

Installierte Plugins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.3
  • Shockwave Flash 11.2 r202
  • Java Plug-In 2 for NPAPI Browsers

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0

Weitere Informationen

throwawayacct1 0 Lösungen 1 Antworten
Veröffentlicht

Hilfreiche Antwort

I've found another workaround to this problem. If you open Firefox 11 in 32-bit mode, it will be able to display PDF files.

To open Firefox in 32-bit mode, quit Firefox, go to the Applications folder, right-click on Firefox and click on "Get Info".

Then, under General, you should see a checkbox where you can have Firefox open in 32-bit. Close this window and restart Firefox and you should be good to go.

I've found another workaround to this problem. If you open Firefox 11 in 32-bit mode, it will be able to display PDF files. To open Firefox in 32-bit mode, quit Firefox, go to the Applications folder, right-click on Firefox and click on "Get Info". Then, under General, you should see a checkbox where you can have Firefox open in 32-bit. Close this window and restart Firefox and you should be good to go.
amandaw 0 Lösungen 1 Antworten
Veröffentlicht

Thanks for the work around! Anybody know of other updates to fix this problem without having to run Firefox in 32 bit mode?

Thanks for the work around! Anybody know of other updates to fix this problem without having to run Firefox in 32 bit mode?
underwater 0 Lösungen 2 Antworten
Veröffentlicht

Hilfreiche Antwort

This is a re-post of a success I had fixing the same problem. Go to [Menu] Tools/Add-Ons/Plugins and disable the Adobe Acrobat NPAPI 10.1.3 reader plugin. It seems to be a common problem, and Adobe will fix it. But for now, this may work.

With this plugin disabled you'll see your download dialog box again.

This is a re-post of a success I had fixing the same problem. Go to [Menu] Tools/Add-Ons/Plugins and disable the Adobe Acrobat NPAPI 10.1.3 reader plugin. It seems to be a common problem, and Adobe will fix it. But for now, this may work. With this plugin disabled you'll see your download dialog box again.

Geändert am von underwater

moose123 0 Lösungen 5 Antworten
Veröffentlicht

Thanks for posting the workaround. But damn, now none of our PDFs will display for people running FF 11 and Reader 10.1.3? I really hope they fix this bug soon.

Thanks for posting the workaround. But damn, now none of our PDFs will display for people running FF 11 and Reader 10.1.3? I really hope they fix this bug soon.
d0ckw0rka 0 Lösungen 1 Antworten
Veröffentlicht

This issue appears only using the combination MacOS X, Firefox 11 with the Adobe Acrobat (Update 10.1.3) Viewer Plugin. As workarround you could do a "rightklick" and "save" as the pdf will work with the Acrobat viewer itself

This issue appears only using the combination MacOS X, Firefox 11 with the Adobe Acrobat (Update 10.1.3) Viewer Plugin. As workarround you could do a "rightklick" and "save" as the pdf will work with the Acrobat viewer itself

Geändert am von d0ckw0rka

Cheng Wang 34 Lösungen 435 Antworten
Veröffentlicht

From: https://support.mozilla.org/en-US/que.../925239.

You can also go into Firefox > Preferences > Applications and look for "PDF file"

Next to that, select use Adobe Acrobat (or use Preview) rather than Adobe Acrobat NPAPI 10.1.3

Adobe's NPAPI plugin doesn't work in 64-bit Firefox ... there's probably a bug where the Adobe Reader update is setting that preference.

From: [https://support.mozilla.org/en-US/questions/925239]. You can also go into Firefox > Preferences > Applications and look for "PDF file" Next to that, select use Adobe Acrobat (or use Preview) rather than Adobe Acrobat NPAPI 10.1.3 Adobe's NPAPI plugin doesn't work in 64-bit Firefox ... there's probably a bug where the Adobe Reader update is setting that preference.
moose123 0 Lösungen 5 Antworten
Veröffentlicht

d0ckw0rka and Cww,

Thanks very much for these solutions. This is very helpful.

d0ckw0rka and Cww, Thanks very much for these solutions. This is very helpful.
chemenway 0 Lösungen 1 Antworten
Veröffentlicht

This is incredibly frustrating. I have FF 11 with Adobe Reader 10.1.3 on the latest MacBook Pro 17", just bought. With the pace of work I have, and the constant use of internet sites that require me to glance at, review, skim PDF documents in another window, I have to have this capability. I DO NOT want to downloand the PDF clutter and create more work having to clean the stuff out. Safari has its problems, but the PDF viewer works there. However, Chrome will be my home browser now. FF used to be so reliable, and compatible with everything! Bye Bye For Now. (BBFN?)

This is incredibly frustrating. I have FF 11 with Adobe Reader 10.1.3 on the latest MacBook Pro 17", just bought. With the pace of work I have, and the constant use of internet sites that require me to glance at, review, skim PDF documents in another window, I have to have this capability. I DO NOT want to downloand the PDF clutter and create more work having to clean the stuff out. Safari has its problems, but the PDF viewer works there. However, Chrome will be my home browser now. FF used to be so reliable, and compatible with everything! Bye Bye For Now. (BBFN?)
moose123 0 Lösungen 5 Antworten
Veröffentlicht

chemenway,

I understand your frustration. My organization posts bids and RFPs to vendors using PDFs, and a lot of these folks use FF11/Reader 10.1.3. We basically now have to edit all those posts to alert them to this problem and offer a workaround.

chemenway, I understand your frustration. My organization posts bids and RFPs to vendors using PDFs, and a lot of these folks use FF11/Reader 10.1.3. We basically now have to edit all those posts to alert them to this problem and offer a workaround.
DonaE 0 Lösungen 1 Antworten
Veröffentlicht

Many thanks for this. It took me a whole morning to work out that the problem was with Firefox rather than anything else and thought it would take me much longer to sort it [I'm a bumbling idiot when it comes to the inner workings of computers!] Anyway, it's now solved thanks to your solution. The only thing that did baffle me a little bit was that I couldn't find a reference to a "PDF file" in the Applications part of Firefox preferences but when I clicked on "asp file" and changed to "use Adobe Acrobat" that did the trick. I'll now go and lie down in a darkened room.

Many thanks for this. It took me a whole morning to work out that the problem was with Firefox rather than anything else and thought it would take me much longer to sort it [I'm a bumbling idiot when it comes to the inner workings of computers!] Anyway, it's now solved thanks to your solution. The only thing that did baffle me a little bit was that I couldn't find a reference to a "PDF file" in the Applications part of Firefox preferences but when I clicked on "asp file" and changed to "use Adobe Acrobat" that did the trick. I'll now go and lie down in a darkened room.
Sheilago 0 Lösungen 1 Antworten
Veröffentlicht

Thanks for the advice. With plug-in disabled, all OK.

Thanks for the advice. With plug-in disabled, all OK.
jimhaynes 0 Lösungen 6 Antworten
Veröffentlicht

Right click where. If I right click on the URL with the pdf file name all I get is a dialog box with Undo, Cut, Copy, etc.

Right click where. If I right click on the URL with the pdf file name all I get is a dialog box with Undo, Cut, Copy, etc.
Cheng Wang 34 Lösungen 435 Antworten
Veröffentlicht

Apparently, some people have PDF File listed under Applications, some have Adobe Reader Document, some have Preview Document, Adobe PDF File, Portable Document File...

Just look for the line that corresponds to PDFs and is using Adobe Acrobat NPAPI 10.1.3

Apparently, some people have '''PDF File''' listed under Applications, some have '''Adobe Reader Document''', some have '''Preview Document''', '''Adobe PDF File''', '''Portable Document File'''... Just look for the line that corresponds to PDFs and is using '''Adobe Acrobat NPAPI 10.1.3'''
Safwan Rahman
  • SUMO Warrior
22 Lösungen 141 Antworten
Veröffentlicht

the latest version of adobe plugin fix the problem.u can download it from. http://www.macupdate.com/app/mac/73/adobe-reader

the latest version of adobe plugin fix the problem.u can download it from. http://www.macupdate.com/app/mac/73/adobe-reader
esopher 0 Lösungen 3 Antworten
Veröffentlicht

That appears to be the same package that's available from Adobe (10.1.3). That's the one that caused the problem in the first place.

That appears to be the same package that's available from Adobe (10.1.3). That's the one that caused the problem in the first place.
Bmac4426 0 Lösungen 1 Antworten
Veröffentlicht

It works, but the pdf form does not keep any of the form fields - urghh

It works, but the pdf form does not keep any of the form fields - urghh
Cheng Wang 34 Lösungen 435 Antworten
Veröffentlicht

Most PDF reader software doesn't save form fields (although I think Preview actually might). Try downloading the PDF file to your computer and then opening it in Preview.

Most PDF reader software doesn't save form fields (although I think Preview actually might). Try downloading the PDF file to your computer and then opening it in Preview.
Hood 0 Lösungen 1 Antworten
Veröffentlicht

I had the same problem, but got tired of searching on forums to try to solve it. So I tried the PDF add-on for Mozilla Firefox. Works like a charm. And it´s fast too! No more headache.

It can be found on:

https://addons.mozilla.org/en-US/firefox/addon/pdfjs/

I had the same problem, but got tired of searching on forums to try to solve it. So I tried the PDF add-on for Mozilla Firefox. Works like a charm. And it´s fast too! No more headache. It can be found on: https://addons.mozilla.org/en-US/firefox/addon/pdfjs/
Kiwitombo 0 Lösungen 1 Antworten
Veröffentlicht

Simple solution for me: went to FF 13.0.1 Preferences (Mac OS X 10.7.4) and clicked on the arrows and changed from "Use Adobe Acrobat and Reader Plug-in (In Firefox)" to "Use Adobe Reader 7" and voila - success!!

Simple solution for me: went to FF 13.0.1 Preferences (Mac OS X 10.7.4) and clicked on the arrows and changed from "Use Adobe Acrobat and Reader Plug-in (In Firefox)" to "Use Adobe Reader 7" and voila - success!!

Geändert am von Kiwitombo

jimhaynes 0 Lösungen 6 Antworten
Veröffentlicht

I have FF 13.0.1 Preferences (Mac OS 10.7.4) set to - Content type: Adobe PDF document, Action: Use Adobe Reader. This seems to work fine. I am using Adobe Reader 10.1.3. When I click on a PDF document on a website, it opens in Adobe Reader and a copy is downloaded to my desk top, where I initially down load files.

I have FF 13.0.1 Preferences (Mac OS 10.7.4) set to - Content type: Adobe PDF document, Action: Use Adobe Reader. This seems to work fine. I am using Adobe Reader 10.1.3. When I click on a PDF document on a website, it opens in Adobe Reader and a copy is downloaded to my desk top, where I initially down load files.