X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.
Scheduled maintenance: Wednesday, April 1, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Hilfeforum

Firefox 9 : 2 fingers swipe not working

Veröffentlicht

Just downloaded and installed Firefox 9.0 today on my MacBook pro.

2 fingers swipe simply does not work. No signs of movements :)

I even restarted after the install ... very Windows of me

Just downloaded and installed Firefox 9.0 today on my MacBook pro. 2 fingers swipe simply does not work. No signs of movements :) I even restarted after the install ... very Windows of me

Ausgewählte Lösung

Just tried it, and yes, same issue. Two-finger swipe works from the .dmg file but not from the Applications folder. I decided to experiment a little further, though, and found a workaround! I first tried copying Firefox.app from the .dmg file onto the desktop and running it from there. Surprisingly, two-finger swipe worked! Then I moved into the Applications folder from there. Two-finger swipe died. Then I tried moving it into a new subfolder in Applications (which I creatively called "Firefox"), and behold! Two-finger swipe worked again! I even moved a backup of the Firefox I had overwritten the first time (which was a few MB smaller, for some reason) into the subfolder and it, too, worked (though it's possible the app from the .dmg file changed something).

So, bottom line: here's the workaround for getting two-finger swipe to work for Firefox 9.0.1 if it doesn't already:

  1. Close Firefox.
  2. Create a subfolder in your Applications folder, with whatever name you choose (though "Firefox" is probably a good choice to keep things organized).
  3. Move Firefox.app from your Applications folder into the newly-created subfolder.
  4. Open Firefox and test two-finger swipe. If it works, hooray! If not, try downloading a fresh copy of Firefox 9.0.1 and putting that in the subfolder. Trash the old one. (All your preferences, bookmarks, etc. should remain the same, but it never hurts to do a backup first if those are important to you, just in case your setup's different from mine.)

Hope that helps! Sure is a perplexing mystery as to why being in the Applications folder would affect that. Hopefully someone smarter than me figures that out soon so the above is no longer necessary.

Diese Antwort im Kontext lesen 2

Mehr Details zum System

Installierte Plugins

  • Google Talk Plugin Video Accelerator version:0.1.44.14
  • Version 2.5.6.4871
  • Shockwave Flash 11.1 r102
  • Facebook Video Calling by Skype
  • LogMeIn remote control components
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Garmin Communicator Plug-in Version 2.9.3.0
  • iPhoto6

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0

Weitere Informationen

the-edmeister
  • Top 25 Contributor
  • Moderator
5433 Lösungen 40564 Antworten
Veröffentlicht
See this support thread - https://support.mozilla.com/en-US/questions/905861

Fragesteller

This is what I've found in the about:config

I don't know what to input there to make it work ??

This is what I've found in the about:config I don't know what to input there to make it work ??
cor-el
  • Top 10 Contributor
  • Moderator
17854 Lösungen 161578 Antworten
Veröffentlicht

You can use the pinch gestures that are probably currently set to an empty string instead of the swipe.

You can use the pinch gestures that are probably currently set to an empty string instead of the swipe.

Fragesteller

ok ... I'm just a user. It says "support 2 fingers swipe", but it does not work.

I don't know anything about any input or data to put there ...

ok ... I'm just a user. It says "support 2 fingers swipe", but it does not work. I don't know anything about any input or data to put there ...
cor-el
  • Top 10 Contributor
  • Moderator
17854 Lösungen 161578 Antworten
Veröffentlicht
See: *http://kb.mozillazine.org/about:config
valerr 0 Lösungen 6 Antworten
Veröffentlicht

Downloading Firefox and running it from the dmg file shows the 2 fingers swipe correctly, but after installing it in /Applications seems like it brokes. Is it a preferences issue?

Downloading Firefox and running it from the dmg file shows the 2 fingers swipe correctly, but after installing it in /Applications seems like it brokes. Is it a preferences issue?
cor-el
  • Top 10 Contributor
  • Moderator
17854 Lösungen 161578 Antworten
Veröffentlicht

Did you try to move the current Firefox application to the trash and drag the new version from the DMG file to the applications folder?

Did you try to move the current Firefox application to the trash and drag the new version from the DMG file to the applications folder? *http://kb.mozillazine.org/Installing_Firefox#Mac_OS_X *https://support.mozilla.com/kb/Installing+Firefox+on+Mac
valerr 0 Lösungen 6 Antworten
Veröffentlicht

Of course yes, cor-el Thanks for answering and merry christmas ^^

Of course yes, cor-el Thanks for answering and merry christmas ^^

Fragesteller

This is exactly what I have done too.

This is exactly what I have done too.
valerr 0 Lösungen 6 Antworten
Veröffentlicht

Any news about this issue? Can anyone confirm what happens with the dmg version of firefox?

Any news about this issue? Can anyone confirm what happens with the dmg version of firefox?
waltcf 1 Lösungen 4 Antworten
Veröffentlicht

My problem is exactly the same as the original poster's, and my about:config entries (running FF9.0.1) look exactly the same. Three-finger swipe works to go back/forward, but two-finger swipe does not. Any ideas?

My problem is exactly the same as the original poster's, and my about:config entries (running FF9.0.1) look exactly the same. Three-finger swipe works to go back/forward, but two-finger swipe does not. Any ideas?

Fragesteller

3-fingers works for you ??? you're lucky. I have nothing with 2 or 3 fingers ...

3-fingers works for you ??? you're lucky. I have nothing with 2 or 3 fingers ...
waltcf 1 Lösungen 4 Antworten
Veröffentlicht

Three-fingers swipe to back/forward does work for me, as long as I have the "Swipe between pages" setting in System Preferences ("Trackpad preference pane" > "More Gestures") set to the "Swipe with two or three fingers" option. Till Firefox fixes this problem, I'll have to stick with that.

Three-fingers swipe to back/forward does work for me, as long as I have the "Swipe between pages" setting in System Preferences ("Trackpad preference pane" > "More Gestures") set to the "Swipe with two or three fingers" option. Till Firefox fixes this problem, I'll have to stick with that.
valerr 0 Lösungen 6 Antworten
Veröffentlicht

It is crazy that I can use the 2 fingers swype while running firefox from the .dmg file and not while I install it in Applications. Do you guys have the same issue?

It is crazy that I can use the 2 fingers swype while running firefox from the .dmg file and not while I install it in Applications. Do you guys have the same issue?
waltcf 1 Lösungen 4 Antworten
Veröffentlicht

Ausgewählte Lösung

Just tried it, and yes, same issue. Two-finger swipe works from the .dmg file but not from the Applications folder. I decided to experiment a little further, though, and found a workaround! I first tried copying Firefox.app from the .dmg file onto the desktop and running it from there. Surprisingly, two-finger swipe worked! Then I moved into the Applications folder from there. Two-finger swipe died. Then I tried moving it into a new subfolder in Applications (which I creatively called "Firefox"), and behold! Two-finger swipe worked again! I even moved a backup of the Firefox I had overwritten the first time (which was a few MB smaller, for some reason) into the subfolder and it, too, worked (though it's possible the app from the .dmg file changed something).

So, bottom line: here's the workaround for getting two-finger swipe to work for Firefox 9.0.1 if it doesn't already:

  1. Close Firefox.
  2. Create a subfolder in your Applications folder, with whatever name you choose (though "Firefox" is probably a good choice to keep things organized).
  3. Move Firefox.app from your Applications folder into the newly-created subfolder.
  4. Open Firefox and test two-finger swipe. If it works, hooray! If not, try downloading a fresh copy of Firefox 9.0.1 and putting that in the subfolder. Trash the old one. (All your preferences, bookmarks, etc. should remain the same, but it never hurts to do a backup first if those are important to you, just in case your setup's different from mine.)

Hope that helps! Sure is a perplexing mystery as to why being in the Applications folder would affect that. Hopefully someone smarter than me figures that out soon so the above is no longer necessary.

Just tried it, and yes, same issue. Two-finger swipe works from the .dmg file but not from the Applications folder. I decided to experiment a little further, though, and found a workaround! I first tried copying Firefox.app from the .dmg file onto the desktop and running it from there. Surprisingly, two-finger swipe worked! Then I moved into the Applications folder from there. Two-finger swipe died. Then I tried moving it into a new subfolder in Applications (which I creatively called "Firefox"), and behold! Two-finger swipe worked again! I even moved a backup of the Firefox I had overwritten the first time (which was a few MB smaller, for some reason) into the subfolder and it, too, worked (though it's possible the app from the .dmg file changed something). So, bottom line: here's the workaround for getting two-finger swipe to work for Firefox 9.0.1 if it doesn't already: # Close Firefox. # Create a subfolder in your Applications folder, with whatever name you choose (though "Firefox" is probably a good choice to keep things organized). # Move Firefox.app from your Applications folder into the newly-created subfolder. # Open Firefox and test two-finger swipe. If it works, hooray! If not, try [http://www.mozilla.org/en-US/products/download.html downloading a fresh copy of Firefox] 9.0.1 and putting that in the subfolder. Trash the old one. (All your preferences, bookmarks, etc. should remain the same, but it never hurts to do a backup first if those are important to you, just in case your setup's different from mine.) Hope that helps! Sure is a perplexing mystery as to why being in the Applications folder would affect that. Hopefully someone smarter than me figures that out soon so the above is no longer necessary.

Geändert am von waltcf

valerr 0 Lösungen 6 Antworten
Veröffentlicht

waltcf, you are totally right! it works by simply changing the dir. This is even stranger to me. Shall we file a bug or open a ticket somewhere?

waltcf, you are totally right! it works by simply changing the dir. This is even stranger to me. Shall we file a bug or open a ticket somewhere?

Fragesteller

Yes this works !!!!

Yes this works !!!!
waltcf 1 Lösungen 4 Antworten
Veröffentlicht

triathlete_be: Glad it worked for you, too!

valerr: I agree that it's strange. I'm surprised that more people aren't complaining about it. It was, after all, a key feature they announced for Firefox 9. If it's a bug, then it doesn't seem like a universal one. In any case, it would probably be worth reporting somehow, though I'm not sure what the best way is to go about doing so. Any ideas?

triathlete_be: Glad it worked for you, too! valerr: I agree that it's strange. I'm surprised that more people aren't complaining about it. It was, after all, a key feature they announced for Firefox 9. If it's a bug, then it doesn't seem like a universal one. In any case, it would probably be worth reporting somehow, though I'm not sure what the best way is to go about doing so. Any ideas?
b.pwned 0 Lösungen 1 Antworten
Veröffentlicht

Hilfreiche Antwort

Make sure Firefox isn't set to 32 bit mode.

Make sure Firefox isn't set to 32 bit mode.
valerr 0 Lösungen 6 Antworten
Veröffentlicht
https://bugzilla.mozilla.org/show_bug.cgi?id=718027